PDA

View Full Version : Is this noise normal?


sftom
02-27-2003, 07:41 PM
Just bought a '98 318ti w/ 50k miles on it. The car runs great. I've noticed, however, that when the engine is cold, about 30 seconds after I've started it a noise kicks in that sounds like a compressor or something running off the engine (it revs when the engine revs, etc.) The engine continues to function normally throughout this time, and then about a minute later the noise stops and won't come back until I start it again w/ a cold engine. Anyone else experienced this or have an idea what this might be? (I've looked in the owner's manual, but it didn't help.) Thanks.

KIRASIR
02-27-2003, 07:50 PM
Sounds like a secondary air pump. They only came on 97+ ti's. If it's not too loud it should be normal.

SL

Just bought a '98 318ti w/ 50k miles on it. The car runs great. I've noticed, however, that when the engine is cold, about 30 seconds after I've started it a noise kicks in that sounds like a compressor or something running off the engine (it revs when the engine revs, etc.) The engine continues to function normally throughout this time, and then about a minute later the noise stops and won't come back until I start it again w/ a cold engine. Anyone else experienced this or have an idea what this might be? (I've looked in the owner's manual, but it didn't help.) Thanks.

J!m
02-28-2003, 01:18 AM
I agree. Most likely the secondary air pump.

If you don't hear it when re-starting a 'hot' engine, I would say definately.

It only runs for a few minutes on a cold engine, to reduce start-up emmisions, then shuts down.

If it's really loud, you may need another one. I have one avilable, if you are interested. Just let me know.

sftom
03-04-2003, 05:50 PM
Thanks for the info. You've put my mind at ease.

suzqfl
10-26-2003, 03:04 AM
My noise at times (not consistent 50/50) is pretty loud...enough to rattle the alley cats and enough that I'm ready to think about getting it fixed......is a secondary air pump something that can be somewhat easily installed on your own??

Anyone have to replace theirs? let me know what type of $$$ I might be looking at used or new. I'm still under warranty would this be covered by any chance????

thanks for any 2cents you throw my way!

alfresco80
10-28-2003, 08:41 PM
I have a '98 ti and the secondary air filter went bad last year and again just a few weeks ago. The car was under warranty at the time of the first repair and it was just replaced again for free since it was under warranty the first time! :) From what I've heard this is a common problem in the '98 & '99 ti's...

1smile
05-05-2004, 12:33 AM
:oops: i just took my 98 in to get the cam sensor replaced (check engine light has been on for a while), and found out that my secondary air pump needs to be replaced. i remember a month back or so that it would whine a bit on cold starts. the pump turns on just after you cold-start the engine, for a few minutes, then will turn off. my mechanic recommends that it is replaced. unfortunately, it will set me back about 800.

alfresco80
05-05-2004, 02:02 AM
Just out of curiosity... how much did it cost to have the camshaft position sensor replaced? Or was it really the secondary air pump all along? My check engine light came on a few weeks ago and the fault code is the cam position sensor. My local mechanic wants $200 parts & labor for the job, but it looks like it might be an easy repair. Thoughts anyone?