PDA

View Full Version : Broken motor mount/ really bad day


hcw318
05-14-2004, 05:00 AM
So I planned on spending this evening putting the transmission back in my Ford E350, but since the tranny shop called and said it needed a full rebuild, that wasn't in the cards. Bad news #1

So I decided to do some maintenance on my 318ti. I doing the inspection II stuff I little at a time.

Last night I did the fuel filter...2 skinned knuckles and gas in my eye. Why do they use those weird special tool hose clamps anyway?

Tonight I did my micro filters and cleaned my K&N air filter. While looking around the engine compartment I notice my right motor mount looks off. Upon closer examination, the bolt has sheared and the engine is off set about 2 inches. Bad news #2 for the day.

So it's late Thursday, The closest dealership is 70 miles away and I have to work tommorow. I have no idea how long it's been this way, but I certainly don't want to drive it now that I know about it.

It doesn't look like to hard of a job other than the fact that I have no idea how I'm going to get the motor back into position. Anyone run into this before? Is ther an upgraded engine mount available since I have to replace the one anyway?

My '73 /5 motorcycle isn't running right either. I have 3 vehicles and not one that I can take to work tommorow! Bad day.

Harrison
98' Metallic Silver Active

2ndBimmer
05-14-2004, 09:52 AM
I had my motor mounts break on me last year. Thus I also would be interested in more durable replacements, should the need arise again.

J!m
05-17-2004, 03:29 PM
Check the trans mounts as well. They are small and soft, and if the motor moved that much, they are probably shot as well.

The drive shaft guibo is most likely on the way out as well due to the extreme angle it's absorbing now. Also since it's probably never been replaced... You don't want it breaking on you, or you day gets far worse...