318ti.org forum (http://www.318ti.org/forum/index.php)
-   Maintenance (http://www.318ti.org/forum/forumdisplay.php?f=24)
-   -   WORRIED! 525i (http://www.318ti.org/forum/showthread.php?t=35970)

Breticus 04-12-2012 04:49 AM

WORRIED! 525i
 
So my Ti has been in the shop for quite sometime and I've been driving my mom's 2001 525i around. I'm a little worried because sometimes I smell something burning and on occasion some white smoke from under the hood. I noticed her oil light kept coming on and off so I checked the oil level and it was pretty low about at the first tick mark. Our mechanic just fixed an oil leak and did an oil change for her, we know him well and he does a great job, so I'm almost positive it isn't his fault. I bought a 5 quart jug of oil and it took about half of it... It's a little over full now which isn't really a big deal. When I opened the cap to put the oil in, granted the engine was warm, white smoke puffed out from inside the engine. I drove it around after filling it up and when I stopped and turned off the engine I opened the cap again to see if it still smoked. It was a lot less this time. Every now and then I stop to see if it smokes when I take the cap off, and it now seems like it's just a normal little bit of smoke. My educated guess is that it is leaking some oil, and that the smoke from up under the hood is oil burning off of the engine. I'm thinking it may have been from me having a little fun in it since it is a lot faster than my car. :rolleyes: I could have reopened the seal on the leak he made? I also noticed today that the electric fan isn't spinning. It comes on and off I think. The fan attached to the engine spins though obviously. The engine doesn't seem to be overheating unless the engine temp gauge in the car is broken. Also if it has anything to do with it the battery went bad in it, so I got that replaced. Sorry for the long message just want to get as much info as possible to you guys. Any thoughts? :confused:

Breticus 04-12-2012 10:46 PM

Bump.

teen ti 04-12-2012 10:53 PM

i know exactly what you're talking about, i drive my dads 2000 528i a bit and when i drive it, well, exuberantly :rolleyes: it smells of burning oil and smokes a bit. you're educated guess is exactly right, these engines are known to leak a little oil when they're being pushed a little and it just burns off the hot engine, causing the smell and smoke. As for our 528i my dad looked at it, found nothing wrong, and we took it to a mechanic for a second opinion and he confirmed everything. it leaked a bit of oil, nothing sever though, but aside from that the engine was fine :smile: im not saying there isn't anything wrong with your car but it is a common issue and might be nothing at all. hope this is of some help

Breticus 04-12-2012 11:00 PM

Thank so much. That is so good to hear! I think that might be all it is. Although I guess maybe I do a little more spirited driving than I think :rolleyes: since I had to fill it with oil. Maybe it has a leak though.

teen ti 04-12-2012 11:04 PM

thats definitely a possibility if you just had it replaced and drive spiritedly. but i know what you mean with the spirited driving, i can easily get the tail out on the 528i which is a blast and the tires on it lasted about 1000 miles less because of it :rolleyes:

Breticus 04-12-2012 11:09 PM

Haha! I've been sliding the 525i around a bit too. :rolleyes: I just can't help it! What do you know about the electric fan up front? Does it only kick on when it gets too hot? I never see it spinning when I check. Anyway so from the sounds of it you think there is no major problem other than possible leak?

teen ti 04-12-2012 11:15 PM

the only thing about the electric fan that i really know is that its prone to breaking, ours was missing all but one blade when we looked at it after the car was running hot for a while. its definitely possible that it only turns on when the engine is running too hot. but from the sound of it id say the car is fine other than the possible leak.

Breticus 04-12-2012 11:19 PM

Well thank you for the help! I can't wait to get my Ti back from the shop and get some pics up! I've been here for awhile and you guys still don't know what I have! I think I'll post some pics of when I first got it.

cooljess76 04-13-2012 01:47 AM

Quote:

Originally Posted by Breticus (Post 326803)
So my Ti has been in the shop for quite sometime and I've been driving my mom's 2001 525i around. I'm a little worried because sometimes I smell something burning and on occasion some white smoke from under the hood. I noticed her oil light kept coming on and off so I checked the oil level and it was pretty low about at the first tick mark. Our mechanic just fixed an oil leak and did an oil change for her, we know him well and he does a great job, so I'm almost positive it isn't his fault. I bought a 5 quart jug of oil and it took about half of it... It's a little over full now which isn't really a big deal. When I opened the cap to put the oil in, granted the engine was warm, white smoke puffed out from inside the engine. I drove it around after filling it up and when I stopped and turned off the engine I opened the cap again to see if it still smoked. It was a lot less this time. Every now and then I stop to see if it smokes when I take the cap off, and it now seems like it's just a normal little bit of smoke. My educated guess is that it is leaking some oil, and that the smoke from up under the hood is oil burning off of the engine. I'm thinking it may have been from me having a little fun in it since it is a lot faster than my car. :rolleyes: I could have reopened the seal on the leak he made? I also noticed today that the electric fan isn't spinning. It comes on and off I think. The fan attached to the engine spins though obviously. The engine doesn't seem to be overheating unless the engine temp gauge in the car is broken. Also if it has anything to do with it the battery went bad in it, so I got that replaced. Sorry for the long message just want to get as much info as possible to you guys. Any thoughts? :confused:

Quote:

Originally Posted by Breticus (Post 326870)
Thank so much. That is so good to hear! I think that might be all it is. Although I guess maybe I do a little more spirited driving than I think :rolleyes: since I had to fill it with oil. Maybe it has a leak though.

Quote:

Originally Posted by Breticus (Post 326874)
Haha! I've been sliding the 525i around a bit too. :rolleyes: I just can't help it! What do you know about the electric fan up front? Does it only kick on when it gets too hot? I never see it spinning when I check. Anyway so from the sounds of it you think there is no major problem other than possible leak?

Kinda makes me wonder why your ti is in the shop. Is mom paying for that car to be repaired too? I mean she was kind enough to loan you her car, beating on it isn't really a nice way to return the favor:rolleyes:

Breticus 04-13-2012 03:11 AM

Oh nothing is wrong with my car! Haha. I'm getting rims and tires and suspension put in as well as a new steering column because when I bought the car the steering wheel would stay locked up even upon starting and you would have to jiggle the wheel to break it free. And I'm paying for my cars things. :] I really can't wait to have it back though... Mom's car just isn't the same as the Ti :(


All times are GMT +1. The time now is 03:10 AM.

vBulletin Version 3.8.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2017, 318ti.org