318ti.org forum

Go Back   318ti.org forum > Search Forums

Notices

.
Showing results 1 to 16 of 16
Search took 0.01 seconds.
Search: Posts Made By: Newbomb Turk
Forum: HVAC 04-07-2018, 08:45 PM
Replies: 2
Views: 316
Posted By Newbomb Turk
Not sure what it was, but the fan is working...

Not sure what it was, but the fan is working again, as before. It was possibly the connection at the resistor. I used dielectric grease on each pin and plugged it back in and it started...
Forum: HVAC 04-07-2018, 05:57 PM
Replies: 2
Views: 316
Posted By Newbomb Turk
Inoperative Blower Fan on 97 base car.

HVAC fan stopped working all at once. Fan speed is left on high, on defrost for early morning warm up. It worked when shut off, then didnít the next morning. Weíve searched for info, and most is...
Forum: Transmission 01-23-2018, 04:54 AM
Replies: 5
Views: 912
Posted By Newbomb Turk
Pelican parts had one, I guess I just didn’t look...

Pelican parts had one, I guess I just didn’t look hard enough.
Forum: Transmission 01-07-2018, 07:56 PM
Replies: 5
Views: 912
Posted By Newbomb Turk
Thanks BlackBMWs. Still baffles me why I can’t...

Thanks BlackBMWs. Still baffles me why I can’t find a fill. I guess I’ll have to go to the dealer. Thanks again
Forum: Transmission 01-07-2018, 04:47 PM
Replies: 5
Views: 912
Posted By Newbomb Turk
That would be great! If I knew they were...

That would be great! If I knew they were interchangeable, or not, that would sure help. I guess I can’t understand why NO supplier offers the “fill”, only the “drain”. Also, if you could tell me if...
Forum: Transmission 01-07-2018, 12:54 AM
Replies: 5
Views: 912
Posted By Newbomb Turk
Automatic Trans Fill & Drain bolts? Same or not?

Are the Drain and Fill bolts/plugs on the 97 318ti automatic trans pan the same size? Interchangeable? I canít seem to find a new one (fill plug) listed at parts houses. They all say Drain...
Forum: Transmission 01-05-2018, 06:03 PM
Replies: 4
Views: 1,933
Posted By Newbomb Turk
So Wynand, how did you make out with your...

So Wynand, how did you make out with your vibration? Was it the mounts? I’m curious what auto trans fluid you used? Did you drop pan and change filter, reassemble with fresh fluid? Or did you...
Forum: Engine 04-17-2017, 04:53 PM
Replies: 8
Views: 1,369
Posted By Newbomb Turk
Unfortunately the P0420 code showed up. But...

Unfortunately the P0420 code showed up. But that'll be for another time.
Forum: Engine 04-17-2017, 03:42 AM
Replies: 8
Views: 1,369
Posted By Newbomb Turk
Cleaned MAF and the sensor in the air box, can't...

Cleaned MAF and the sensor in the air box, can't say that I noticed a difference running. Did some more reading, about the Cam Position Sensor. Pulled the upper intake off again and ran the CPS...
Forum: Lounge 04-16-2017, 07:50 AM
Replies: 4
Views: 1,588
Posted By Newbomb Turk
What did you do for problem #2?

What did you do for problem #2?
Forum: Engine 04-16-2017, 06:49 AM
Replies: 8
Views: 1,369
Posted By Newbomb Turk
Pulled the plugs and found a couple #2,#3 had oil...

Pulled the plugs and found a couple #2,#3 had oil on the plug ceramics. Replaced the valve cover gasket, plug tube gaskets and replaced the oil supply tube seal, it was hard as plastic. Started it...
Forum: Engine 04-13-2017, 03:58 PM
Replies: 8
Views: 1,369
Posted By Newbomb Turk
I pulled the plug wires and checked, not a lot of...

I pulled the plug wires and checked, not a lot of water in that area, but some. I used air compressor and blew out any water and debris. Blew out the wire ends and used a paper towel and...
Forum: Engine 04-05-2017, 06:52 PM
Replies: 8
Views: 1,369
Posted By Newbomb Turk
Thanks Maverick. I had know idea the plugs were...

Thanks Maverick. I had know idea the plugs were under that black BMW strip. Easy fix. Thanks again for your reply.
Forum: Engine 04-05-2017, 03:35 AM
Replies: 8
Views: 1,369
Posted By Newbomb Turk
Chugs after steam cleaning. Help!

My son has a 1997 318ti that while he was away, I took it to the car wash and power washed the engine and compartment. Engine was chugging when I started it. Felt like only one cylinder out so I ran...
Forum: Electrical 10-17-2016, 06:24 AM
Replies: 5
Views: 3,836
Posted By Newbomb Turk
Motor replacement fixed the problem. (don't...

Motor replacement fixed the problem. (don't forget to index the linkage) After plugging in new motor, run it and shut it off, this parks motor. Then when attaching motor to linkage, make sure linkage...
Forum: Electrical 10-15-2016, 11:50 PM
Replies: 5
Views: 3,836
Posted By Newbomb Turk
Don't worry, your dad should be able to fix it ;)

Don't worry, your dad should be able to fix it ;)
Showing results 1 to 16 of 16

 
Forum Jump

All times are GMT +1. The time now is 07:54 PM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2018, 318ti.org
[page compression: 53.36 k/60.63 k (11.98%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.