318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Engine Swaps

Notices

Engine Swaps Engine conversions.

.
» Recent Threads
Rear strut brace
04-04-2014 04:39 AM
Last post by MisterM52
Yesterday 09:48 PM
46 Replies, 14,718 Views
M44 strange water leak...
05-18-2019 09:01 AM
Last post by MisterM52
Yesterday 09:46 PM
6 Replies, 340 Views
Fox well NT510 - service...
Yesterday 07:27 PM
Last post by dudecati
Yesterday 07:27 PM
0 Replies, 34 Views
FS: Complete Black Dash
Yesterday 04:08 AM
Last post by KGB318TI
Yesterday 04:08 AM
0 Replies, 134 Views
WTB: Black Dash and...
03-21-2019 03:28 AM
Last post by KGB318TI
Yesterday 03:15 AM
1 Replies, 501 Views
Brakelights not working
05-17-2019 07:59 PM
Last post by PNWm52Project
05-19-2019 04:41 PM
4 Replies, 406 Views
new engine build. dasc +...
01-02-2016 01:28 AM
Last post by andakn
05-19-2019 03:49 PM
193 Replies, 97,926 Views
DIY X-Brace & Support...
05-19-2019 11:12 AM
Last post by MisterM52
05-19-2019 11:12 AM
0 Replies, 134 Views
Rudolph the Red 318ti
05-06-2019 10:49 PM
Last post by MisterM52
05-19-2019 10:54 AM
11 Replies, 1,100 Views
Valve cover gaskets?
05-13-2019 10:05 PM
Last post by MisterM52
05-18-2019 10:16 PM
4 Replies, 509 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 08-03-2018, 04:15 AM   #16
Projectvoltron
Junior Member
 
Join Date: May 2018
Location: Colorado
Posts: 24
iTrader: (0)
Default

Quote:
Originally Posted by spidertri View Post
My M44/getrag didn't have a CDV so you may not need the delete. I did all that stuff except for the lower temp tstat and coolant sensor, what's the benefit of those? I didn't know they made a lower temp sensor.

I had to have a friend machine the tstat housing flat so that it would seal correctly. The cheap housings all come from china and are cast aluminum. It's good to clean up the casting flash inside too.

I used stock exhaust manifolds to the OBD2 midpipe and then a Z3 3.0i catback, had to cut it down slightly but the exhaust hangers all lined up.

Awesome! That's good to know!

As far as clutch is concerned. Do you guys have any opinions on a decent cheap option? Is the valeo kit a decent kit?
Projectvoltron is offline   Reply With Quote
Old 08-16-2018, 02:38 AM   #17
Kglenn328
Junior Member
 
Join Date: Aug 2018
Location: Indiana
Posts: 3
iTrader: (0)
Default

So would you guys know where I could get some info about swapping a 97m52b28 into a 95 318ti I have the whole doner car still and will keep it till everything is good with the ti but I'm concerned about obd1 car with obd2 motor and the ews as well it's my first swap in a bmw but I can tell getting the motor in is the easy part
Kglenn328 is offline   Reply With Quote
Old 09-07-2018, 02:22 AM   #18
Projectvoltron
Junior Member
 
Join Date: May 2018
Location: Colorado
Posts: 24
iTrader: (0)
Default

I should be commencing my swap next week. I got all the parts I needed ordered. I have my swap car lined up and the 318ti waiting a new transplant.

Iím getting pretty excited about it all. Iím goint to do a lot of stuff to the motor while itís out like
Sap delete
M50 manifold with the bimmerworld swap kit
New silicone elbow
Aluminum radiator
Silicone coolant lines
New water pump
Vanos rebuild with tools
Asc delete plug
Iím trading some Audi wheels for a stage 4 clutch kit (kinda way to aggressive)
Fan delete kit
New coolant tank
Bought a dme with sap delete, rear o2 delete, ews delete, etc

Is there anything Iím forgetting that you guys can think of?

Thanks again for all the help and support!
Projectvoltron is offline   Reply With Quote
Old 09-20-2018, 03:59 AM   #19
Projectvoltron
Junior Member
 
Join Date: May 2018
Location: Colorado
Posts: 24
iTrader: (0)
Default

Quote:
Originally Posted by spidertri View Post
I had to read the wire diagrams, wiring is not my strong point either, lol. No pictures unfortunately, I had to get it done quickly so my car would pass inspection. When I finally have a need to pull the engine apart I'm probably going to install a manual M52 wiring harness, it bothers me to have the auto trans stuff just hanging around in there.

In the wiring harness X20 connector, I had to add pin 10, that is the signal to the reverse light plug. And then in the plastic box of wires that sits over the engine, there is a junction in there that I spliced the power wire for the reverse light switch into. If you trace pin 22 from the X20 to the plastic box, that is what I spliced into.

No you don't need the TCU, that and the associated wiring just gets ignored.
So I am balls deep in the swap right now and I am a little confused on what to do with the reverse light. from what I understand this is what I need to do.
Cut the 2 plug connector off either the Auto harness or the old M44 manual harness. Run one wire from pin 10 on the x20 and run the other wire from the box above the engine and connect it to the wire that comes off of pin 22 of the x20

Please let me know if I am wrong.

Also I ran into another problem. What do I do with the x69 Connector off the auto harness. My 318ti Doesn't have a X69 connector. It only has the x20 and the x6031 connector. If someone could help me out with that I would greatly appreciate it. Thank you
Projectvoltron is offline   Reply With Quote
Old 09-25-2018, 08:29 PM   #20
spidertri
Senior Member
 
spidertri's Avatar
 
Join Date: Apr 2007
Location: Elizabeth City, NC
Posts: 3,861
Vehicles
iTrader: (9)
Default

Sounds like what I did, it was a while ago but yeah. Did you get it to work?


EDIT - My car does not have the x69.
My car had the x69 so I can't help there, did you find any threads talking about it here or on bf.c?
__________________
~Dave~

98 328ti Morea Grun slicktop
13 JGC WK2 Deep Cherry

Search | RealOEM

Last edited by spidertri; 01-30-2019 at 08:05 PM. Reason: I was wrong about my car having x69
spidertri is offline   Reply With Quote
Old 09-25-2018, 08:42 PM   #21
Projectvoltron
Junior Member
 
Join Date: May 2018
Location: Colorado
Posts: 24
iTrader: (0)
Default

Quote:
Originally Posted by spidertri View Post
Sounds like what I did, it was a while ago but yeah. Did you get it to work?

My car had the x69 so I can't help there, did you find any threads talking about it here or on bf.c?
I havenít gotten that far. I have posted on bummer forums and here looking for an answer by havenít found anything.

Iím also waiting on a clutch to come in.

Was your ti originally a auto or manual?
Projectvoltron is offline   Reply With Quote
Old 09-26-2018, 07:01 PM   #22
spidertri
Senior Member
 
spidertri's Avatar
 
Join Date: Apr 2007
Location: Elizabeth City, NC
Posts: 3,861
Vehicles
iTrader: (9)
Default

Mine is a '98 manual ti with engine from a '97 auto 328i.
__________________
~Dave~

98 328ti Morea Grun slicktop
13 JGC WK2 Deep Cherry

Search | RealOEM
spidertri is offline   Reply With Quote
Old 09-26-2018, 10:25 PM   #23
Projectvoltron
Junior Member
 
Join Date: May 2018
Location: Colorado
Posts: 24
iTrader: (0)
Default

Quote:
Originally Posted by spidertri View Post
Mine is a '98 manual ti with engine from a '97 auto 328i.
I wonder why my 97 ti doesnít have one then. Thatís crazy and very confusing
Projectvoltron is offline   Reply With Quote
Old 01-29-2019, 04:52 PM   #24
pilsberry
Member
 
Join Date: Aug 2003
Location: ATL
Posts: 43
Vehicles
iTrader: (0)
Default backup light

I am figuring out how to wire my light up too. S52 from 97 auto, into 99Ti manual. I just solved the low speed fan riddle. Did anyone else notice terminal 86 in low speed relay is missing in bottom of socket? Same for AC relay next door. The diagrams do not address this, but do not tear into the fuse box. These signals don't use 86 even though the ETM displays that it does.
pilsberry is offline   Reply With Quote
Old 01-30-2019, 02:49 PM   #25
pilsberry
Member
 
Join Date: Aug 2003
Location: ATL
Posts: 43
Vehicles
iTrader: (0)
Default X69

Quote:
Originally Posted by Projectvoltron View Post
I wonder why my 97 ti doesnít have one then. Thatís crazy and very confusing
My 99 Ti doesn't have it either. I believe it is because that connector is for auto Trans.
Mine was/is also a manual car.
pilsberry is offline   Reply With Quote
Old 01-30-2019, 08:03 PM   #26
spidertri
Senior Member
 
spidertri's Avatar
 
Join Date: Apr 2007
Location: Elizabeth City, NC
Posts: 3,861
Vehicles
iTrader: (9)
Default

My bad, I just looked back at the pictures in my build thread and saw that my '98 manual ti does not have the x69 connector.

I forgot that I just set the auto harness connector where the x69 would be. It's been a couple years, lol.
__________________
~Dave~

98 328ti Morea Grun slicktop
13 JGC WK2 Deep Cherry

Search | RealOEM
spidertri is offline   Reply With Quote
Old 01-31-2019, 05:14 AM   #27
Projectvoltron
Junior Member
 
Join Date: May 2018
Location: Colorado
Posts: 24
iTrader: (0)
Default

I found that out after a while of being worried. That being said my swap started right up and runs like a champ. I have one check engine light for an 02 sensor that isn’t even attached to the car. I am using a dme from a 328 that has the ews system deleted. The motor is out of a 98 323 which only had one pre cat and one post cat o2 sensor. I have the original dme but I didn’t want to have to deal with the ews system.
Projectvoltron is offline   Reply With Quote
Old 05-09-2019, 11:14 PM   #28
Motts
Junior Member
 
Join Date: Jul 2017
Location: Salt Lake City
Posts: 14
iTrader: (0)
Default Congrats

Just saw that your swap is running, congratulations.
I picked up an aluminum block M52 and have been going through it.
What clutch did you end up using? I've got to get a flywheel + clutch, planning to use the manual that came with my ti.
Any suggestions now that you've been through the process?
Motts is offline   Reply With Quote
Old 05-10-2019, 12:10 AM   #29
Projectvoltron
Junior Member
 
Join Date: May 2018
Location: Colorado
Posts: 24
iTrader: (0)
Default

I ended up going with this clutch. It worked pretty good

I ended up getting rid of the car for a 2007 Audi A4 avant.

But the clutch held good and the car was a blast

https://rover.ebay.com/rover/0/0/0?m...2F132617773337
Projectvoltron is offline   Reply With Quote
Old 05-10-2019, 04:53 PM   #30
Motts
Junior Member
 
Join Date: Jul 2017
Location: Salt Lake City
Posts: 14
iTrader: (0)
Default

Good to know.
My last car was an 2007 A4 avant. I miss it, great car, fun to drive and amazing in the snow.


Sent from my iPhone using Tapatalk
Motts is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
97 M44 to 97 M52 swap questions Octarine Engine Swaps 5 02-21-2014 12:46 PM
M Roadster Suspension Swap (front and rear subframes, brakes, etc) questions Ragnorak Suspension 7 01-11-2013 04:29 PM
E30 Diff and Axle swap questions pred Differentials 2 08-14-2012 08:54 PM
M52 swap questions??? Diamon7 Engine Swaps 3 12-16-2011 01:30 AM
questions for the swap people Jean H.318TI Engine Swaps 17 10-29-2010 03:30 AM


All times are GMT +1. The time now is 12:35 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2019, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 129.49 k/153.93 k (15.88%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.