318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Electrical

Notices

Electrical All wiring questions.

.
» Recent Threads
Help with figuring out...
Yesterday 09:49 PM
Last post by cocofunk
Today 04:03 AM
3 Replies, 78 Views
M44 E-Bay Turbo Build
01-15-2018 03:32 AM
Last post by manydubs
Yesterday 03:00 PM
5 Replies, 288 Views
Happy Birthday Wynand
Yesterday 06:00 AM
Last post by 1996 328ti
Yesterday 06:00 AM
0 Replies, 110 Views
Turbo kit interest
07-18-2011 10:10 AM
Last post by Estii
Yesterday 03:41 AM
128 Replies, 31,851 Views
Injector recomendations?
01-14-2018 02:17 AM
Last post by Estii
Yesterday 03:35 AM
21 Replies, 689 Views
SAP location with M52...
01-11-2018 05:45 PM
Last post by zachdog
Yesterday 12:32 AM
2 Replies, 347 Views
Anyone on banded...
01-13-2018 04:26 PM
Last post by E36 Ti
01-15-2018 07:14 PM
3 Replies, 322 Views
FS - TX: TC Kline Front...
01-15-2018 05:28 PM
Last post by teamjoe
01-15-2018 05:28 PM
0 Replies, 182 Views
Looking for a s50
01-11-2018 11:52 AM
Last post by Johjamkep
01-15-2018 01:38 AM
3 Replies, 366 Views
Just bought a ti with a...
01-11-2018 05:11 PM
Last post by havocfears
01-14-2018 08:49 PM
5 Replies, 478 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 05-26-2009, 06:59 PM   #1
s_menezes
Junior Member
 
Join Date: Jan 2009
Location: Miami
Posts: 13
iTrader: (0)
Angry Electrical Shutoff after Ignition ?!?!?!?!

Very strange and dangerous issue with my '95 TI :

I turn the car on (before the ignition) .... all electrical elements work perfect (radio, wipers, etc.). As soon as I turn the ignition key and the motor starts running .... radio, wipers, windows all cease to function.

Sometimes ... while driving ... out of nowhere the electrical comes on miraculously; but more often than not I have to make sure it won't rain, etc. because I live in South Florida and this could be a real hazard while driving.

Anyone have any clue what is going on?

Comments MOST APPRECIATED ! THANKS
s_menezes is offline   Reply With Quote
Old 05-26-2009, 10:28 PM   #2
xxxJohnBoyxxx
Senior Member
 
Join Date: Dec 2007
Location: Gulfport, Florida
Posts: 3,208
iTrader: (1)
Default

Quote:
Originally Posted by s_menezes View Post
Very strange and dangerous issue with my '95 TI :

I turn the car on (before the ignition) .... all electrical elements work perfect (radio, wipers, etc.). As soon as I turn the ignition key and the motor starts running .... radio, wipers, windows all cease to function.

Sometimes ... while driving ... out of nowhere the electrical comes on miraculously; but more often than not I have to make sure it won't rain, etc. because I live in South Florida and this could be a real hazard while driving.

Anyone have any clue what is going on?

Comments MOST APPRECIATED ! THANKS
Bad unloader relay or bad wiring to unloader relay or ground issues
xxxJohnBoyxxx is offline   Reply With Quote
Old 05-26-2009, 10:46 PM   #3
s_menezes
Junior Member
 
Join Date: Jan 2009
Location: Miami
Posts: 13
iTrader: (0)
Thumbs up Unloader Relay

Hey I really appreciate the response. Is this unloader relay something I can simply buy and replace myself? Any idea where it is in a 318ti?

Thanks so much!
s_menezes is offline   Reply With Quote
Old 05-30-2009, 10:12 PM   #4
xxxJohnBoyxxx
Senior Member
 
Join Date: Dec 2007
Location: Gulfport, Florida
Posts: 3,208
iTrader: (1)
Default

Quote:
Originally Posted by s_menezes View Post
Hey I really appreciate the response. Is this unloader relay something I can simply buy and replace myself? Any idea where it is in a 318ti?

Thanks so much!
Sorry for the delayed reponse. I forgot about this thread. Yes it can be purchased and is a plug in item. I'm not sure where it is on the ti. mine is a 97 318is and is position #2 in the relay group in fuse box. I'm sure someone on the board can help if you post a question of were is my unloader relay. Maybe check a Bentley manual.

Good luck
xxxJohnBoyxxx is offline   Reply With Quote
Reply

Bookmarks

Tags
electrical , ignition , shut off , wipers


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical questions minicoop900 Interior and ICE 11 05-25-2008 07:15 PM
Electrical drain Borg561 Electrical 5 03-24-2008 02:16 AM
electrical problems m44ic Electrical 7 05-15-2005 02:07 PM
Electrical woos Teno Electrical 5 04-18-2005 03:02 PM
electrical problem dodj Electrical 6 08-11-2004 06:18 AM


All times are GMT +1. The time now is 04:11 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2018, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 77.71 k/90.20 k (13.84%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.