318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > HVAC

Notices

HVAC Heating, ventilation and air conditioning.

.
» Recent Threads
Long time swapped to...
11-16-2018 04:12 AM
Last post by BRADESTAR
Today 07:08 AM
3 Replies, 268 Views
205/60r16 tires on model...
11-17-2018 06:02 PM
Last post by mrmikkelsen
Today 04:39 AM
1 Replies, 205 Views
1996 M44 Crank, no...
10-18-2018 10:36 PM
Last post by 318tiFatherFigure
Yesterday 08:03 PM
7 Replies, 970 Views
New ti owner from Chicago
10-12-2018 10:28 PM
Last post by K12Pilot
Yesterday 01:31 PM
7 Replies, 1,147 Views
names for your TI
10-08-2004 04:48 AM
Last post by andakn
Yesterday 02:38 AM
347 Replies, 82,478 Views
Age Demographics
10-30-2004 05:06 AM
Last post by Locus7
11-19-2018 03:04 AM
322 Replies, 88,119 Views
FS: 1998 Black BMW 318ti...
10-29-2016 07:52 AM
Last post by winky
11-18-2018 11:31 PM
12 Replies, 9,005 Views
What model ti do you own?
02-26-2003 04:40 AM
Last post by K12Pilot
11-18-2018 01:51 PM
324 Replies, 108,626 Views
New to the Ti but not...
11-18-2018 01:48 PM
Last post by K12Pilot
11-18-2018 01:48 PM
0 Replies, 133 Views
FS Black 1997 318ti...
11-09-2018 01:05 AM
Last post by tmca
11-17-2018 09:14 PM
4 Replies, 956 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 08-05-2013, 09:03 PM   #1
stanlwi
Junior Member
 
Join Date: Apr 2011
Location: Chapel Hill, NC, USA
Posts: 14
iTrader: (0)
Default RIP AC compressor?

Hi guys, I was hoping someone will know what I'm dealing with re: an inop AC system. I originally assumed I could give it a charge and be back on top, so I bought the DIY hose with gauge and a couple cans of R134a. However, the low side pressure was over 100 psi even with the engine running and AC on full blast. I looked down at the compressor and noticed it hadn't engaged.

I figured I'd check to see if it was lack of signal (therefore probably a bad sensor) or if the compressor itself was dead. So, I jumpered 12v from the battery to the pin on the compressor. It switched right on! I checked the vents in the car, and I was getting cold AC! So, then I checked the low side pressure and it was around 40psi, pretty much right on given the 85 degree temps.

However, around that time I noticed that there was some noise coming from the front of the engine, presumably from the compressor. I revved the engine a little, and it stumbled badly returning to idle. I did it again (for some reason) and it stumbled quite badly, then made a loud buzzing sort of sound (almost an electronic sounding beep) and stalled. I immediately disconnected the power lead to the compressor. It (the inner part of the clutch) then slowly spun a few rotations, with the engine off. I think it spun opposite from normal.

What does this seem to indicate to you? I'm thinking it doesn't bode well for the compressor's continuing to work, but the thing that puzzles me is why I would have both a compressor on the brink of death, and an apparent signal problem. The system was not being powered on... I know it can turn the compressor off if the outside temp gauge or the pressure sensor in the compressor are not working properly, but I don't think it would be able to detect if there was some other issue with the compressor.

And, what can actually go wrong with a compressor? The seals must be OK as it was compressing. The bearings seemed to spin fine at least at first. I can spin the inner part by hand, and it feels smooth. And the clutch seemed to work. I don't know what to do next here. Any help appreciated!
stanlwi is offline   Reply With Quote
Old 08-05-2013, 09:29 PM   #2
hotmilk400
Senior Member
 
hotmilk400's Avatar
 
Join Date: Apr 2008
Location: Bethlehem, PA
Posts: 1,106
iTrader: (13)
Default

Mine did the same thing. The high side is leaking into the low side. I am in the process of replacing the compressor and hoping it fixes it. My parents Kia minivan is also doing the same thing. the seals are okay, but its an internal leak. it lowers back down to 40ish when you jump it since it just compresses it to the high side.

thats the best i can tell you, hopefully someone will be able to help you better.
hotmilk400 is offline   Reply With Quote
Old 08-06-2013, 05:11 AM   #3
stanlwi
Junior Member
 
Join Date: Apr 2011
Location: Chapel Hill, NC, USA
Posts: 14
iTrader: (0)
Default

Thanks for the reply. You don't think there's any chance that's normal operation- for the pressure differential to equalize when the compressor is off?
stanlwi is offline   Reply With Quote
Reply

Bookmarks

Tags
air conditioning , clutch , compressor , pressure


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
AC Compressor Removal Graphics in Bentley Manual gusgriff HVAC 9 06-21-2012 03:33 AM
AC compressor clutch fix?? weloveiggy HVAC 9 06-15-2011 10:29 PM
Length of 10mm for AC compressor PHL Misc 1 03-31-2009 06:20 AM
AC Compressor lines jon@theMshop Engine Swaps 3 02-20-2008 10:21 PM
Bad Air Compressor? AC bit the dust... bmwracerchick HVAC 5 06-16-2006 10:32 PM


All times are GMT +1. The time now is 12:34 PM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2018, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 74.37 k/85.75 k (13.27%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.