318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Engine Swaps

Notices

Engine Swaps Engine conversions.

.
» Recent Threads
For Sale; 98 318ti...
04-29-2020 05:54 PM
Last post by runnr548
Today 08:16 PM
13 Replies, 1,361 Views
M42 / M44 Phenolic...
05-28-2013 06:03 AM
Last post by TonyE30
06-04-2020 08:09 AM
4 Replies, 1,635 Views
Ultimate Supercharger...
06-23-2019 08:06 AM
Last post by mikesanto70
06-03-2020 10:28 PM
115 Replies, 107,475 Views
FS: BBS RX 204 17x8 ET38...
06-02-2020 10:22 PM
Last post by jahnaboi
06-02-2020 10:22 PM
0 Replies, 153 Views
Installing Thule Roof...
02-08-2010 06:06 PM
Last post by koi
06-02-2020 08:45 AM
7 Replies, 16,673 Views
1997 318ti M52/S52 swap
09-30-2019 05:31 AM
Last post by anassa
06-01-2020 04:56 PM
6 Replies, 16,898 Views
Happy Birthday finlay
06-01-2020 05:00 AM
Last post by 1996 328ti
06-01-2020 05:00 AM
0 Replies, 304 Views
Midnight Tuning...
02-08-2012 05:38 PM
Last post by Omega
06-01-2020 04:23 AM
193 Replies, 89,691 Views
PERMANENT WINDOW...
01-26-2008 04:27 AM
Last post by Omega
06-01-2020 04:18 AM
212 Replies, 149,072 Views
parting out a nice 95...
05-16-2020 10:27 PM
Last post by J!m
06-01-2020 03:09 AM
8 Replies, 1,382 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 12-08-2011, 04:51 PM   #1
dylanreid16
Member
 
Join Date: Oct 2008
Location: Mass.
Posts: 53
iTrader: (0)
Default S52 Swap, need help with fuel pressure and 3/2 valve

Hey guys,

recently put an s52 in my ti. Did not even realize that i needed to put the FPR on from the donor m3 so i sold it.

Clamped return line and it ran amazing!!! then died after a bit. really dumb to clamp it for so long.

installed m50 rail with fpr on it and now it starts and runs without needing to be clamped but HORRIBLY.

will hold a 500rpm idle and if i feather the throttle i can get the revs up high but if i give it any consitant gas it will just die.

car throws codes for 02 sensors and this 3/2 valve.

I have no 3/2 valve because i used obd1 fuel rail and no fpr under the car.

SO i have a connector under the car that goes to nothing and its supposed to go to the 3/2 valve.

Does anyone have any experience with this????? Or this 3/2 valve.
dylanreid16 is offline   Reply With Quote
Old 12-08-2011, 05:00 PM   #2
dylanreid16
Member
 
Join Date: Oct 2008
Location: Mass.
Posts: 53
iTrader: (0)
Default

also running very rich. Plugs are black.

Either my ECU is trying to get used to the new normal fuel pressure, needs time or a GT1.

Or it has to do with no 3/2 valve and it not being plugged in
dylanreid16 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 11:30 PM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2020, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 63.03 k/73.17 k (13.86%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.