318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Transmission

Notices

Transmission Automatic, manual and shift lever discussions.

.
» Recent Threads
Trip Meter Resets to Zero
Today 05:21 PM
Last post by tsr66
Today 05:21 PM
0 Replies, 21 Views
1996 5 speed feeler.
10-06-2018 05:30 PM
Last post by HellrotRuss
Today 02:53 AM
10 Replies, 875 Views
1996 M44 Crank, no...
Yesterday 09:36 PM
Last post by burner505
Yesterday 09:36 PM
0 Replies, 113 Views
Testing dual radiator...
08-05-2011 02:49 AM
Last post by bazar01
Yesterday 10:42 AM
62 Replies, 38,368 Views
Error Code P0455
02-10-2006 02:57 PM
Last post by Estii
Yesterday 03:02 AM
7 Replies, 3,358 Views
IMPORTANT: Two plastic...
05-16-2007 06:28 PM
Last post by weste46
10-16-2018 08:17 PM
167 Replies, 84,395 Views
New ti owner from Chicago
10-12-2018 09:28 PM
Last post by FunElan
10-15-2018 03:18 PM
5 Replies, 650 Views
Looking for running...
10-15-2018 03:06 AM
Last post by HellrotRuss
10-15-2018 03:06 AM
0 Replies, 231 Views
Oil Pan Cleaning
10-12-2018 02:46 AM
Last post by ZEK
10-14-2018 04:15 AM
3 Replies, 540 Views
NEED TO BUY BLACK SHIFT...
10-14-2018 03:29 AM
Last post by Estii
10-14-2018 03:29 AM
0 Replies, 172 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 04-23-2018, 06:50 PM   #1
rico_vancouver
Junior Member
 
Join Date: Apr 2018
Location: Vancouver, BC
Posts: 3
iTrader: (0)
Default Newbie transmission compatibility question

Hi all,

New 1995 318Ti owner (one week). Having an auto transmission issue, and it's in the tranny shop right now. Hoping for the best, but expecting the worst. I see a 1996 328is parting out on Craigslist, and the 4-sp auto only has 86k kms on it. My web research says it is/should be a GM 4L30E, like in mine. Is that all I need to know to tell if it will be a match? What would be a good offer price for a low mileage auto transmission?

Anyhow, for anyone interested or has input, the problem occurs only after warming up for 7-10 mins. Drives/shifts normally (I think) when cold. After warmed up a bit, there is a "slip" between 1st and 2nd, where the engine revs freely between gears, and then most of the time, 2nd engages. Doesn't seem to slip going into 3rd. Similarly, don't seem to have any issues going into 4th. Had the transmission fluid checked when the oil was changed a few days ago, and it was full, but dark. Haven't driven the car enough to know for sure, but it doesn't seem that the A/M switch works - i.e. if I put it in M mode, and select 2nd, for example, I would expect the car to shift down to 2 and stay there.

Thanks for your input.

Rich
rico_vancouver is offline   Reply With Quote
Old 04-29-2018, 04:23 AM   #2
wodcutr
Senior Member
 
Join Date: Dec 2011
Location: Heber City, Utah
Posts: 237
iTrader: (1)
Default

I had a 328is that had a similar issue. I changed the fluid and filter and added Lucas tranny additive to it with the new fluid and slipping went away. I would try that before buying a new used one.
wodcutr is offline   Reply With Quote
Old 05-08-2018, 08:01 PM   #3
alco
Junior Member
 
Join Date: Oct 2015
Location: Augusta, VA
Posts: 5
iTrader: (0)
Default

There are several ( at least three cutoffs for the transmission versions and thus their controller and wirign harness compatability. What is the last seven of your VIN? I have several transmissions here. I know that 1/96 is a huge cut off, and of course there are a couple of earlier versions. You will want to find an OBD1 trans.
alco is offline   Reply With Quote
Old 05-09-2018, 04:36 PM   #4
rico_vancouver
Junior Member
 
Join Date: Apr 2018
Location: Vancouver, BC
Posts: 3
iTrader: (0)
Default

Thanks for reading. I ended up having the tranny shop put in a used transmission.
rico_vancouver is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Question for newbie Guti59 Engine Swaps 1 08-14-2017 06:20 PM
Engine Swap Transmission Question Coop540iT Engine Swaps 4 04-03-2012 08:37 PM
transmission drive shaft differential question aznlonewolf135 Engine Swaps 4 12-19-2011 02:14 AM
K I got a transmission question... TroyWagner Transmission 8 03-25-2010 09:48 PM
Newbie CHECK ENGINE question SJM Maintenance 5 07-28-2006 05:55 PM


All times are GMT +1. The time now is 08:30 PM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2018, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 74.77 k/87.01 k (14.06%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.