318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Engine Swaps

Notices

Engine Swaps Engine conversions.

.
» Recent Threads
Rebuild M44 or S52 swap?
12-13-2019 07:21 AM
Last post by ZEK
12-13-2019 10:32 PM
1 Replies, 356 Views
FS: 1998 BMW 318ti...
11-25-2019 12:57 AM
Last post by doucy2
12-13-2019 07:29 PM
5 Replies, 856 Views
Ultimate Supercharger...
06-23-2019 09:06 AM
Last post by Blindsparky
12-11-2019 04:38 AM
101 Replies, 63,745 Views
bc racing or KWs?
12-05-2019 02:48 AM
Last post by Z3nki
12-09-2019 05:41 AM
3 Replies, 625 Views
heater bowden cable fix...
02-25-2012 02:50 AM
Last post by Hotredti
12-09-2019 01:00 AM
16 Replies, 15,435 Views
FS: 17" Style 40 / FULLY...
12-05-2019 09:34 PM
Last post by Meller1
12-05-2019 09:34 PM
0 Replies, 352 Views
FS: Brake UPGRADE Thread...
12-05-2019 09:33 PM
Last post by Meller1
12-05-2019 09:33 PM
0 Replies, 216 Views
FS: E36 M3 OEM Mirrors
11-13-2019 05:39 PM
Last post by Meller1
12-05-2019 09:26 PM
1 Replies, 730 Views
DASC Inforation or parts
12-05-2019 01:15 PM
Last post by pvansickler
12-05-2019 07:38 PM
2 Replies, 291 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 09-03-2016, 07:12 PM   #1
Vegan m3
Junior Member
 
Join Date: Sep 2016
Location: Sj,ca
Posts: 5
iTrader: (0)
Default S52 obd2 swap wiring help

Hello everyone I'm new to the forum. I need help wiring my s52 obd2 swap. I have a 1997 318ti manual and my donor car is 98 m3 sedan also manual. My 318ti only has 2 main harness connectors and the m3 came with 3 connectors. I originally thought I can just plug the 2 connectors in and it would fire right up. But that's not the case, now I'm stuck and not sure which pins need to be moved around. Any help is greatly appreciated. Thanks for reading.
Vegan m3 is offline   Reply With Quote
Old 09-06-2016, 03:11 PM   #2
wodcutr
Senior Member
 
Join Date: Dec 2011
Location: Heber City, Utah
Posts: 242
iTrader: (1)
Default

Read the OBD2 wiring questions thread in this section. I just finished doing mine and had similar issues but figured it out and posted what I did. Pm me if you want to discuss further!
wodcutr is offline   Reply With Quote
Old 09-06-2016, 10:12 PM   #3
Vegan m3
Junior Member
 
Join Date: Sep 2016
Location: Sj,ca
Posts: 5
iTrader: (0)
Default

Hi woodcutr, thanks for responding. I would have sent you a PM but I don't have 5 posts yet. I have been looking through your old posts and I have not come across the wiring part of it, unless I overlooked something . I saw the posts about the asc wiring and aux fan.
Vegan m3 is offline   Reply With Quote
Old 09-07-2016, 02:23 AM   #4
wodcutr
Senior Member
 
Join Date: Dec 2011
Location: Heber City, Utah
Posts: 242
iTrader: (1)
Default

I believe the car will run without you doing anything really. My guess is that you are dealing with an EWS issue. You have to use the M3 DME, EWS, and key to get it to run. Iirc the only real pin swapping that needs to take place is the 9 pin from the smaller connector needs to be put into the 8 pins place in the larger connector. The other stuff is all just convenience wiring for aux fan, econometer, fog lights, etc.
wodcutr is offline   Reply With Quote
Old 09-07-2016, 03:43 AM   #5
Vegan m3
Junior Member
 
Join Date: Sep 2016
Location: Sj,ca
Posts: 5
iTrader: (0)
Default

I have swapped over the ews2 module , the DME, and I also taped the two keys together temporarily . The car is not turning On at all. The lights on the dash do not light up either and my battery is brand new. What would be the cause of nothing turning on.? Without swapping over wires in the main harness, would my dash still light up when turning the key on?
Vegan m3 is offline   Reply With Quote
Old 09-07-2016, 04:26 PM   #6
wodcutr
Senior Member
 
Join Date: Dec 2011
Location: Heber City, Utah
Posts: 242
iTrader: (1)
Default

Yes the dash should light up when you turn the key on. Did you relocate the battery to the trunk? The ti had the battery in the front so the engine harness had the proper connectors included in it. The M3 harness has no positive battery connections other than the ones for the + tower link and a trunk installed battery has a fusible link that also comes into play. You obviously aren't getting power from the battery!
wodcutr is offline   Reply With Quote
Old 09-07-2016, 10:49 PM   #7
Vegan m3
Junior Member
 
Join Date: Sep 2016
Location: Sj,ca
Posts: 5
iTrader: (0)
Default

I got the dash lights to turn on. I did not notice that the distribution block has 2 terminals that do not connect to the rest of the circuit, Greenhorn mistake lol. I swapped the chip over from the m3 key and still no start. Now I think it could be ews issue. I am using the ews module from the m3 along with the DME.
The wire swap you mentioned in earlier post, does that need to be done for my vehicle to crank over?
I apologize for asking such newbie questions, I appreciate all of your help.
Vegan m3 is offline   Reply With Quote
Old 09-08-2016, 01:49 AM   #8
wodcutr
Senior Member
 
Join Date: Dec 2011
Location: Heber City, Utah
Posts: 242
iTrader: (1)
Default

I don't believe that would cause a no crank issue, only a CEL. Your EWS is probably not aligned. If the chip is not being recognized you should get a code.
wodcutr is offline   Reply With Quote
Old 09-10-2016, 06:27 AM   #9
Vegan m3
Junior Member
 
Join Date: Sep 2016
Location: Sj,ca
Posts: 5
iTrader: (0)
Default

Thanks woodcutr, for answering all my questions I really appreciate you helping me out. I got my car to fire up today
Vegan m3 is offline   Reply With Quote
Old 09-10-2016, 03:22 PM   #10
wodcutr
Senior Member
 
Join Date: Dec 2011
Location: Heber City, Utah
Posts: 242
iTrader: (1)
Default

That's always a great sound and a relief! Enjoy your car.
wodcutr is offline   Reply With Quote
Old 11-04-2016, 06:34 AM   #11
summerlinbrayden
Junior Member
 
Join Date: Oct 2016
Location: Gwinnette, ga
Posts: 1
iTrader: (0)
Default

What ended up being the issue?

Sent from my SM-G920P using Tapatalk
summerlinbrayden is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Questions on wiring on OBD2 S52 engine bay Silverfox99 Engine Swaps 42 09-19-2016 08:37 PM
WI Feeler: 318ti S52 swap alexw Cars for Sale 4 06-15-2014 06:46 AM
New Member s52 Swap cnaville210 Engine Swaps 34 08-06-2012 12:22 AM
S52 OBDII to OBDI M50 Manifold Swap DYI dahamler Engine Swaps 42 09-18-2011 03:33 PM
M42 to m44 Obd2 Swap Questions allenergies Engine Swaps 1 03-09-2009 06:31 PM


All times are GMT +1. The time now is 10:46 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2019, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 98.45 k/117.37 k (16.12%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.