318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Electrical

Notices

Electrical All wiring questions.

.
» Recent Threads
Questions on wiring on...
02-20-2016 08:22 AM
Last post by Trusted-1
Yesterday 08:12 PM
44 Replies, 29,051 Views
The 318ti OBD-II engine...
10-19-2006 06:48 PM
Last post by J!m
08-01-2020 09:14 PM
155 Replies, 106,758 Views
Torque wrench...
07-28-2020 08:01 PM
Last post by J!m
08-01-2020 12:52 AM
3 Replies, 518 Views
318ti parts
06-09-2020 12:00 AM
Last post by NMSDAD1
07-31-2020 11:57 PM
17 Replies, 3,331 Views
Engine cooling fan...
07-31-2020 01:02 AM
Last post by mperez
07-31-2020 04:45 PM
2 Replies, 256 Views
FS / FT: 1987 LS1/T-56...
08-18-2011 02:57 AM
Last post by Mad A
07-29-2020 03:33 PM
4 Replies, 14,776 Views
Mini hangars with stock...
07-16-2020 06:26 AM
Last post by mb0686
07-26-2020 06:02 AM
1 Replies, 625 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 07-31-2020, 01:02 AM   #1
mperez
Junior Member
 
Join Date: Jun 2020
Location: North Carolina
Posts: 3
iTrader: (0)
Default Engine cooling fan doesnít turn on, on low speed

So I have a 97 TI, and itís starting to over heat. It has never overheated until recently when I flushed out all the old coolant. Iíve checked the coolant and had some leaks so I fixed them. But now with every leak fixed I continued to overheat until I saw that my fan wasnít turning on. So I checked the relays and they seemed fine, I checked the coolant temp sensor and it was showing the correct temperature. I replaced the water pump. I supplied direct current to the fan and it ran so the fan motor is fine. The fan connections are good. I just donít get what could be causing this to overheat. It still overheats with the a/c on. I even checked the fuses and they were fine. So Iíve hit a wall and I need my car running soon for college. Might this be an electrical problem? Please help me
Thanks
mperez is offline   Reply With Quote
Old 07-31-2020, 06:14 AM   #2
FunElan
Senior Member
 
Join Date: Jul 2012
Location: Dodging potholes in SoCal
Posts: 405
iTrader: (1)
Default

You might want to change your thermostat for the hell of it, but your problem might be the resistor on the fan. You can get one online and just solder it in: http://www.318ti.org/forum/showthread.php?t=40133

Welcome to the org!
__________________
'96 318ti California Edition- Montreal blue
'68 1600-2-Caribe blue
FunElan is offline   Reply With Quote
Old 07-31-2020, 04:45 PM   #3
mperez
Junior Member
 
Join Date: Jun 2020
Location: North Carolina
Posts: 3
iTrader: (0)
Default

Thanks for the help but I checked my fan and it doesn’t have an exterior resistor on the fan.
mperez is offline   Reply With Quote
Reply

Bookmarks

Tags
cooling system , electrical problem , fan , overheating


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Radiator cooling fan question bazar01 HVAC 3 08-19-2015 10:21 PM
NO low speed fan signal Bills86e Electrical 25 08-09-2012 03:28 PM
Test if Fan Works? bmw318tiChic Electrical 62 09-25-2009 03:43 PM
TI DOWN: Engine Blew! HuGo Misc 43 05-24-2007 02:08 PM
2 Speed fan Relays Compact Missile General Chit Chat 9 02-08-2006 06:52 PM


All times are GMT +1. The time now is 06:14 PM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2020, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 69.24 k/80.32 k (13.79%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.