318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Electrical

Notices

Electrical All wiring questions.

.
» Recent Threads
Radiator Electric Fan...
04-14-2014 01:39 AM
Last post by rpinzonc
Today 06:37 PM
5 Replies, 13,341 Views
318ti M package with...
07-11-2015 01:19 AM
Last post by BRADESTAR
Today 05:38 AM
31 Replies, 15,073 Views
California top issue 1997
02-14-2019 02:35 AM
Last post by BRADESTAR
Today 05:35 AM
3 Replies, 231 Views
Track ti build (M52)
03-05-2016 04:00 PM
Last post by Murt
Today 05:12 AM
48 Replies, 24,337 Views
Does anyone run a TI in...
Today 04:13 AM
Last post by Murt
Today 04:13 AM
0 Replies, 88 Views
Injector...
02-19-2019 11:23 PM
Last post by spidertri
02-21-2019 08:57 PM
5 Replies, 527 Views
TI part?
02-21-2019 05:26 AM
Last post by FunElan
02-21-2019 05:37 PM
1 Replies, 211 Views
Dash lights on strike
01-18-2008 04:24 PM
Last post by pilsberry
02-20-2019 09:55 PM
38 Replies, 6,892 Views
Window coming off track
01-27-2003 04:51 PM
Last post by FunElan
02-20-2019 06:11 PM
216 Replies, 81,060 Views
What intake for S54...
02-20-2019 09:29 AM
Last post by Simas323
02-20-2019 09:29 AM
0 Replies, 193 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 05-26-2009, 06:59 PM   #1
s_menezes
Junior Member
 
Join Date: Jan 2009
Location: Miami
Posts: 13
iTrader: (0)
Angry Electrical Shutoff after Ignition ?!?!?!?!

Very strange and dangerous issue with my '95 TI :

I turn the car on (before the ignition) .... all electrical elements work perfect (radio, wipers, etc.). As soon as I turn the ignition key and the motor starts running .... radio, wipers, windows all cease to function.

Sometimes ... while driving ... out of nowhere the electrical comes on miraculously; but more often than not I have to make sure it won't rain, etc. because I live in South Florida and this could be a real hazard while driving.

Anyone have any clue what is going on?

Comments MOST APPRECIATED ! THANKS
s_menezes is offline   Reply With Quote
Old 05-26-2009, 10:28 PM   #2
xxxJohnBoyxxx
Senior Member
 
Join Date: Dec 2007
Location: Gulfport, Florida
Posts: 3,208
iTrader: (1)
Default

Quote:
Originally Posted by s_menezes View Post
Very strange and dangerous issue with my '95 TI :

I turn the car on (before the ignition) .... all electrical elements work perfect (radio, wipers, etc.). As soon as I turn the ignition key and the motor starts running .... radio, wipers, windows all cease to function.

Sometimes ... while driving ... out of nowhere the electrical comes on miraculously; but more often than not I have to make sure it won't rain, etc. because I live in South Florida and this could be a real hazard while driving.

Anyone have any clue what is going on?

Comments MOST APPRECIATED ! THANKS
Bad unloader relay or bad wiring to unloader relay or ground issues
xxxJohnBoyxxx is offline   Reply With Quote
Old 05-26-2009, 10:46 PM   #3
s_menezes
Junior Member
 
Join Date: Jan 2009
Location: Miami
Posts: 13
iTrader: (0)
Thumbs up Unloader Relay

Hey I really appreciate the response. Is this unloader relay something I can simply buy and replace myself? Any idea where it is in a 318ti?

Thanks so much!
s_menezes is offline   Reply With Quote
Old 05-30-2009, 10:12 PM   #4
xxxJohnBoyxxx
Senior Member
 
Join Date: Dec 2007
Location: Gulfport, Florida
Posts: 3,208
iTrader: (1)
Default

Quote:
Originally Posted by s_menezes View Post
Hey I really appreciate the response. Is this unloader relay something I can simply buy and replace myself? Any idea where it is in a 318ti?

Thanks so much!
Sorry for the delayed reponse. I forgot about this thread. Yes it can be purchased and is a plug in item. I'm not sure where it is on the ti. mine is a 97 318is and is position #2 in the relay group in fuse box. I'm sure someone on the board can help if you post a question of were is my unloader relay. Maybe check a Bentley manual.

Good luck
xxxJohnBoyxxx is offline   Reply With Quote
Reply

Bookmarks

Tags
electrical , ignition , shut off , wipers


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical questions minicoop900 Interior and ICE 11 05-25-2008 07:15 PM
Electrical drain Borg561 Electrical 5 03-24-2008 02:16 AM
electrical problems m44ic Electrical 7 05-15-2005 02:07 PM
Electrical woos Teno Electrical 5 04-18-2005 03:02 PM
electrical problem dodj Electrical 6 08-11-2004 06:18 AM


All times are GMT +1. The time now is 10:29 PM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2019, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 78.26 k/90.73 k (13.74%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.