318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Engine

Notices

Engine Tuneups, chips, wires, spark plugs.

.
» Recent Threads
1996 ti added to the...
Yesterday 03:37 PM
Last post by runnr548
Yesterday 03:37 PM
0 Replies, 72 Views
AT Italia M Contour Reps...
12-30-2020 03:18 AM
Last post by ///Mpwr
10-25-2021 12:18 PM
2 Replies, 3,583 Views
Ultimate Supercharger...
06-23-2019 08:06 AM
Last post by MisterM52
10-25-2021 07:34 AM
132 Replies, 225,006 Views
weird problem
12-07-2011 04:27 PM
Last post by bcp
10-23-2021 12:56 PM
10 Replies, 1,932 Views
HELP: New spark plugs...
10-21-2021 04:03 PM
Last post by rupace120
10-21-2021 04:03 PM
0 Replies, 533 Views
95 318ti 5-Spd w/factory...
10-15-2021 07:22 PM
Last post by Mongwit
10-21-2021 03:31 AM
2 Replies, 1,159 Views
Hello from ND!
10-20-2021 04:44 PM
Last post by WingDinger
10-21-2021 12:17 AM
2 Replies, 453 Views
96 318ti Sport package...
10-07-2021 10:57 PM
Last post by 318tiJoe
10-20-2021 06:55 PM
5 Replies, 2,301 Views
6cylinder Cluster Swap
08-30-2019 06:01 PM
Last post by AnotherPotatoChip
10-19-2021 07:28 PM
5 Replies, 11,478 Views
hi from Los Angeles
10-19-2021 02:47 AM
Last post by LO_1998_318ti
10-19-2021 02:47 AM
0 Replies, 663 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 09-13-2021, 02:37 PM   #1
ti-billy
Senior Member
 
ti-billy's Avatar
 
Join Date: Mar 2010
Location: Tulsa, OK
Posts: 252
iTrader: (0)
Default Running rough

96 ti, m44. Engine idles perfect when cold but as soon as it warms up it starts sucking a ton of air in the pcv valve and runs very rough with a weird pressure equalizing noise when shut off. No cel, no codes. Checked for vacuum leaks and found none. Anyone ever encountered anything like this?

Sent from my Pixel 3 XL using Tapatalk
__________________
1996 318ti base: m44, 5 spd, lsd - 18x8 bremmer kraft wheels w/sumitumo tires 225/40R18 & bmw locking lug studs, 10mm spacers in rear, halo headlights, cold air intake, koni str.t struts and shocks w/mounts, h&r sport springs, serp belts, control arm & tie rod kits, front sway bar links, JVC kd-x50bt headunit w/ipod hook up in the glove box, alpine sps-500(front and rear), jl audio 10" powerwedge max, jl audio 250.1 amp, motor mounts, fuel filter, passenger side window motor, drivers lower window run, muffler hanger kit, various interior bulbs, left door striker/ajar switch, lower hood latches, changed from gray vinal to black leather shift and parking brake boots, m3 weighted shift knob, ngk-r spark plugs, magnecor spark plug wires(blue),new cabin micro-filters,new headliner & a-pillar mouldings, 5w20 synth-blend oil and filter, BG Ultra Guard syn. rear end fluid & ls additive, BG Syncro Shift II syn. manual trans fluids, stainless steel braided brake lines and dot 4 fluid, extra brake light mod, new p/s reservoir and rubber hoses

need to do - fix door panels, paint job, MORE MONEY!!
ti-billy is offline   Reply With Quote
Old 09-22-2021, 01:19 PM   #2
ti-billy
Senior Member
 
ti-billy's Avatar
 
Join Date: Mar 2010
Location: Tulsa, OK
Posts: 252
iTrader: (0)
Default

It was a bad ccv valve that was causing all the issues. Replaced with oe and now it runs great.

Sent from my Pixel 3 XL using Tapatalk
__________________
1996 318ti base: m44, 5 spd, lsd - 18x8 bremmer kraft wheels w/sumitumo tires 225/40R18 & bmw locking lug studs, 10mm spacers in rear, halo headlights, cold air intake, koni str.t struts and shocks w/mounts, h&r sport springs, serp belts, control arm & tie rod kits, front sway bar links, JVC kd-x50bt headunit w/ipod hook up in the glove box, alpine sps-500(front and rear), jl audio 10" powerwedge max, jl audio 250.1 amp, motor mounts, fuel filter, passenger side window motor, drivers lower window run, muffler hanger kit, various interior bulbs, left door striker/ajar switch, lower hood latches, changed from gray vinal to black leather shift and parking brake boots, m3 weighted shift knob, ngk-r spark plugs, magnecor spark plug wires(blue),new cabin micro-filters,new headliner & a-pillar mouldings, 5w20 synth-blend oil and filter, BG Ultra Guard syn. rear end fluid & ls additive, BG Syncro Shift II syn. manual trans fluids, stainless steel braided brake lines and dot 4 fluid, extra brake light mod, new p/s reservoir and rubber hoses

need to do - fix door panels, paint job, MORE MONEY!!
ti-billy is offline   Reply With Quote
Old 09-25-2021, 04:46 AM   #3
FunElan
Senior Member
 
Join Date: Jul 2012
Location: Dodging potholes in SoCal
Posts: 443
iTrader: (1)
Default

glad you were able to fix it. I found that the Febi brand one isn't as good as OEM.
__________________
'96 318ti California Edition- Montreal blue
'68 1600-2-Caribe blue
FunElan is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
95 318ti m42 5 speed stalling/ running rough MrMajicCity Engine 2 04-12-2014 05:17 PM
Running rough on re-start mbradican Misc 1 08-27-2012 05:48 PM
M44 running rough, oil inside cyl2???? RsKeyz Engine 15 11-25-2009 12:46 AM
Rough running when started haworthp Engine 20 01-27-2009 05:01 PM
Running rough... 3-4k RPM cossieturbo Engine 1 02-15-2006 01:04 AM


All times are GMT +1. The time now is 01:45 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2021, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 73.83 k/85.30 k (13.45%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.