318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Maintenance

Notices

Maintenance Service Interval questions, oil change info.

.
» Recent Threads
Rebuild M44 or S52 swap?
12-13-2019 07:21 AM
Last post by ZEK
12-13-2019 10:32 PM
1 Replies, 493 Views
FS: 1998 BMW 318ti...
11-25-2019 12:57 AM
Last post by doucy2
12-13-2019 07:29 PM
5 Replies, 907 Views
Ultimate Supercharger...
06-23-2019 09:06 AM
Last post by Blindsparky
12-11-2019 04:38 AM
101 Replies, 63,976 Views
bc racing or KWs?
12-05-2019 02:48 AM
Last post by Z3nki
12-09-2019 05:41 AM
3 Replies, 651 Views
heater bowden cable fix...
02-25-2012 02:50 AM
Last post by Hotredti
12-09-2019 01:00 AM
16 Replies, 15,481 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 11-14-2019, 05:30 AM   #16
paul somlo
Senior Member
 
Join Date: Sep 2006
Location: Greeley CO
Posts: 208
iTrader: (0)
Default

Quote:
Originally Posted by Newbomb Turk View Post
Paul, itís not the gauge. Instrument cluster is new. Iím betting on a bad pin in the blue connector on the back of the cluster head.
Could be - you're lucky if that's so; easy to diagnose, as I've heard that the cluster is a sealed unit.
paul somlo is offline   Reply With Quote
Old 11-22-2019, 01:48 AM   #17
Newbomb Turk
Junior Member
 
Join Date: May 2016
Location: Illinois
Posts: 19
iTrader: (0)
Default

11/21/19
As it turned out, one of the sender wires under the seat was chewed up. Absolutely baffled as to what happened. The boy drives the car everyday. When the gauge first started to act up, he would give the dash a shot with his fist over the fuel gauge, then it would work. I pulled cluster out, checked all wiring, took apart each wire connector, removed each pin connector from connector. Checked all were tight. Checked fuel gauge driver motor for visual defects. Bought new cluster, figuring it was a bad gauge driver motor, due to him being able to get gauge working with a fist bump to the top of the dash/cluster. After installing new cluster and nothing happening, I was pissed... swapped out clusters again and started looking further down the harness, behind brake pedal.
Another issue we had was a fuel vapor smell outside the car. Being that we replaced fuel pump/sender, we pulled the rear seat and round panel to check that our connections were still good on the fuel pump we had just installed, that’s when we found the sender wire chewed up..about a 1/2” missing. I guess the both of us are blind. Amazed, neither of us saw the chewed wire, which was 2” from the plug we disconnected from the pump.
I’m still trying to figure how it worked after the fist bump, with the problem being under the rear seat. Anyone need a 187k dash cluster? I have one for sale.

Last edited by Newbomb Turk; 11-22-2019 at 01:51 AM.
Newbomb Turk is offline   Reply With Quote
Old 11-22-2019, 05:00 AM   #18
paul somlo
Senior Member
 
Join Date: Sep 2006
Location: Greeley CO
Posts: 208
iTrader: (0)
Default

Quote:
Originally Posted by Newbomb Turk View Post
Iím still trying to figure how it worked after the fist bump, with the problem being under the rear seat. Anyone need a 187k dash cluster? I have one for sale.
Yep, that one's a mystery. Sounds like maybe you've got meeces.
paul somlo is offline   Reply With Quote
Old 11-23-2019, 02:43 AM   #19
mr-canada
Junior Member
 
Join Date: Sep 2019
Location: Vancouver, BC, Canada
Posts: 5
iTrader: (0)
Default

Quote:
Originally Posted by 318ti97 View Post
My gas guage tends to suddenly drop all the way to "nil" and jump back again. At time it sticks in the "nil" position until I bang on the dash board right above it. Then, it tends to go back to the correct reading.

Any help..........

Thanks!
Not sure if your problem is the same as mine, but when I bought mine it did a similar thing. I just filled the tank up a few times to max with the proper gas, and waalaa, the guage worked. The float was probably stuck with old gas turning to varnish around the post.

You might try Seafoam in the gas and drive the hell out of it. Creates a lot of smoke but if it's a bad gas issue it will clean it out pretty quick. Just don't do it near your neighbors or they will think your car is a clunker.
mr-canada is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I have a fuse problem. Gas and the Temp. Will'sBimmer Electrical 11 11-02-2009 05:15 AM


All times are GMT +1. The time now is 05:31 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2019, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 70.62 k/82.52 k (14.42%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.