318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Maintenance

Notices

Maintenance Service Interval questions, oil change info.

.
» Recent Threads
TI part?
Today 05:26 AM
Last post by BRADESTAR
Today 05:26 AM
0 Replies, 67 Views
Injector...
02-19-2019 11:23 PM
Last post by BRADESTAR
Today 05:24 AM
4 Replies, 243 Views
Dash lights on strike
01-18-2008 04:24 PM
Last post by pilsberry
Yesterday 09:55 PM
38 Replies, 6,742 Views
Window coming off track
01-27-2003 04:51 PM
Last post by FunElan
Yesterday 06:11 PM
216 Replies, 80,987 Views
What intake for S54...
Yesterday 09:29 AM
Last post by Simas323
Yesterday 09:29 AM
0 Replies, 158 Views
Happy Birthday barische
Yesterday 06:00 AM
Last post by 1996 328ti
Yesterday 06:00 AM
0 Replies, 125 Views
OEM roof spoiler
06-14-2018 01:19 AM
Last post by sortasorted
02-19-2019 06:27 PM
16 Replies, 4,197 Views
Swap Manual Q&A
01-09-2007 04:32 AM
Last post by Dphu
02-16-2019 05:21 PM
195 Replies, 55,469 Views
new engine build. dasc +...
01-02-2016 02:28 AM
Last post by Jean H.318TI
02-16-2019 05:55 AM
190 Replies, 94,640 Views
throttle bodies on the...
01-19-2019 12:20 AM
Last post by jerseytim
02-15-2019 11:13 PM
2 Replies, 588 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 10-11-2018, 10:18 PM   #1
NorCalBert
Junior Member
 
Join Date: Oct 2017
Location: Novato, California
Posts: 10
iTrader: (0)
Default Bucking, loss of power on acceleration

Car bucks randomly under brisk acceleration. Cleaned MAF, replaced plugs and wires. No improvement. New problem; Stopped at light. Car would not rev up when accelerator pedal was depressed. Rolled to curb, popped hood. Pulled throttle cable, engine revved. On way home car lacking power, feels like 30% at full throttle. Tested TPS with ohmmeter, seems within spec. Suggestions?
NorCalBert is offline   Reply With Quote
Old 10-14-2018, 03:45 AM   #2
BRADESTAR
Senior Member
 
Join Date: May 2013
Location: Seattle
Posts: 421
Vehicles
iTrader: (0)
Default

Fuel pump? Fuel starvation is a bit smoother than electrical loss and should probably stall. "bucking" usually means spark related.

Maybe Coil pack?

...I'd start by checking the grounds. Bad grounds do weird stuff in these rigs. Then I'd check the alt. and battery.
BRADESTAR is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent loss of power john318isau Engine 45 06-09-2017 01:28 AM
rough idle, and acceleration, loss of power mig29 Engine 2 09-05-2016 07:11 AM
Loss of power, engine vibration and squeal squeak noise bmwtinut Engine 7 11-18-2013 10:08 PM
Acceleration Loss 15 to 17 inch mreroc Wheels and Tires 16 11-19-2011 04:32 PM
loss of power steering 97 318ti Maintenance 7 12-10-2005 08:55 PM


All times are GMT +1. The time now is 02:43 PM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2019, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 68.23 k/78.65 k (13.25%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.