318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Maintenance

Notices

Maintenance Service Interval questions, oil change info.

.
» Recent Threads
Never thought Iíd love...
03-05-2019 11:00 AM
Last post by roadrash
Today 04:55 PM
6 Replies, 514 Views
Z3 rack cooler
Yesterday 04:05 AM
Last post by spidertri
Today 03:52 PM
3 Replies, 278 Views
1997 318ti California...
03-01-2019 05:13 PM
Last post by coopc
Today 03:02 PM
7 Replies, 1,133 Views
Happy Birthday arkanay.v
Today 05:00 AM
Last post by EtherD5
Today 02:27 PM
1 Replies, 97 Views
318ti auto to 328ti auto...
03-16-2019 02:05 AM
Last post by Dgerry
Today 12:52 PM
8 Replies, 355 Views
'95 318TI - S50 swap
01-03-2019 02:21 AM
Last post by Locus7
Today 07:08 AM
6 Replies, 1,735 Views
Changing wheels soon,...
Yesterday 10:17 PM
Last post by Estii
Yesterday 10:17 PM
0 Replies, 110 Views
Hello from Scotland
12-07-2017 11:09 PM
Last post by MAZI
Yesterday 07:22 PM
2 Replies, 644 Views
At my end with trying to...
03-16-2019 10:07 PM
Last post by Bobtail_Bimmer
Yesterday 01:44 PM
4 Replies, 251 Views
318ti Covercraft...
03-16-2019 04:24 AM
Last post by K12Pilot
03-16-2019 01:55 PM
1 Replies, 299 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 10-11-2018, 09:18 PM   #1
NorCalBert
Junior Member
 
Join Date: Oct 2017
Location: Novato, California
Posts: 10
iTrader: (0)
Default Bucking, loss of power on acceleration

Car bucks randomly under brisk acceleration. Cleaned MAF, replaced plugs and wires. No improvement. New problem; Stopped at light. Car would not rev up when accelerator pedal was depressed. Rolled to curb, popped hood. Pulled throttle cable, engine revved. On way home car lacking power, feels like 30% at full throttle. Tested TPS with ohmmeter, seems within spec. Suggestions?
NorCalBert is offline   Reply With Quote
Old 10-14-2018, 02:45 AM   #2
BRADESTAR
Senior Member
 
Join Date: May 2013
Location: Seattle
Posts: 425
Vehicles
iTrader: (0)
Default

Fuel pump? Fuel starvation is a bit smoother than electrical loss and should probably stall. "bucking" usually means spark related.

Maybe Coil pack?

...I'd start by checking the grounds. Bad grounds do weird stuff in these rigs. Then I'd check the alt. and battery.
BRADESTAR is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent loss of power john318isau Engine 45 06-09-2017 12:28 AM
rough idle, and acceleration, loss of power mig29 Engine 2 09-05-2016 06:11 AM
Loss of power, engine vibration and squeal squeak noise bmwtinut Engine 7 11-18-2013 09:08 PM
Acceleration Loss 15 to 17 inch mreroc Wheels and Tires 16 11-19-2011 03:32 PM
loss of power steering 97 318ti Maintenance 7 12-10-2005 07:55 PM


All times are GMT +1. The time now is 06:33 PM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2019, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 68.07 k/78.63 k (13.44%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.