318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Engine

Notices

Engine Tuneups, chips, wires, spark plugs.

.
» Recent Threads
What intake for S54...
Today 09:29 AM
Last post by Simas323
Today 09:29 AM
0 Replies, 46 Views
Happy Birthday barische
Today 06:00 AM
Last post by 1996 328ti
Today 06:00 AM
0 Replies, 65 Views
Window coming off track
01-27-2003 04:51 PM
Last post by sortasorted
Today 05:53 AM
215 Replies, 80,159 Views
Injector...
Yesterday 11:23 PM
Last post by KASZ
Today 01:34 AM
2 Replies, 122 Views
OEM roof spoiler
06-14-2018 01:19 AM
Last post by sortasorted
Yesterday 06:27 PM
16 Replies, 4,082 Views
Swap Manual Q&A
01-09-2007 04:32 AM
Last post by Dphu
02-16-2019 05:21 PM
195 Replies, 55,451 Views
new engine build. dasc +...
01-02-2016 02:28 AM
Last post by Jean H.318TI
02-16-2019 05:55 AM
190 Replies, 94,618 Views
throttle bodies on the...
01-19-2019 12:20 AM
Last post by jerseytim
02-15-2019 11:13 PM
2 Replies, 578 Views
Racewars Australia -...
02-15-2019 09:09 PM
Last post by 318tiFatherFigure
02-15-2019 09:09 PM
0 Replies, 152 Views
Magnaflow catback $60
02-08-2019 07:18 PM
Last post by Mongwit
02-14-2019 06:41 AM
2 Replies, 594 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 04-25-2012, 03:16 AM   #1
coug65
Junior Member
 
Join Date: Apr 2012
Location: dublin, ca
Posts: 1
iTrader: (0)
Default 96 engine misfires randomly

First and foremost, first post... looked for a TI forever before finding one last year with 133K. love these cars.

Has run excellent up until a month ago. While below 3K RPM it will occasionally 'lag' .. not sure if it's misfire but there is a sudden loss of power. If i push the gas harder or downshift it will take off and runs strong.

I can't seem to pinpoint a pattern other than it happens more frequently when the engine is cold and it rarely if ever happens above 3K RPM.

There is no check engine light/code and if I gun the engine it appears to run strong.

I tried fuel injector cleaner and it seemed to help a bit for awhile but not consistently.

any help is most appreciated.

thanks.
coug65 is offline   Reply With Quote
Old 05-02-2012, 10:22 PM   #2
RodneyWarren
Junior Member
 
Join Date: May 2012
Location: Savannah,Ga
Posts: 5
iTrader: (0)
Default

does the rpm gauge go up during this?
RodneyWarren is offline   Reply With Quote
Old 05-03-2012, 12:14 AM   #3
dave45056
Senior Member
 
Join Date: Apr 2006
Location: Oxford, Ohio
Posts: 865
iTrader: (0)
Default

Check your spark plugs. Do any of them have oil in the well when you pull the wires?
Then remove each one and see if any look different. You should also get your codes read at an auto parts store near you. Not all codes throw a CEL.
dave45056 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Shellbackís Project Shellback Engine Swaps 57 02-04-2012 10:34 PM
328ti Post Swap Analysis BMW_Hatchback Engine Swaps 6 06-29-2011 07:12 AM
F.S. BMW M42 (M42B18) engine fits e36 318, 318i,318is, 318ti chrisbec eBay and Craig's list listings 6 11-03-2010 03:21 PM
Engine swap woe's =( uchigatana Engine Swaps 2 12-28-2009 08:13 AM
TI DOWN: Engine Blew! HuGo Misc 43 05-24-2007 03:08 PM


All times are GMT +1. The time now is 03:07 PM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2019, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 69.91 k/81.33 k (14.04%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.