318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Electrical

Notices

Electrical All wiring questions.

.
» Recent Threads
Happy Birthday Bozola
04-15-2018 05:00 AM
Last post by Bozola
Today 01:57 PM
1 Replies, 618 Views
The 318ti OBD-II engine...
10-19-2006 06:48 PM
Last post by AFDanHef
Today 07:42 AM
106 Replies, 62,321 Views
New rear brake upgrade...
10-04-2016 08:16 PM
Last post by sirius815
Today 03:43 AM
47 Replies, 14,700 Views
Center console lock...
05-22-2018 06:29 AM
Last post by BRADESTAR
Yesterday 05:54 AM
3 Replies, 426 Views
IACV Question
Yesterday 05:38 AM
Last post by Estii
Yesterday 05:38 AM
0 Replies, 87 Views
Happy Birthday ...
05-24-2018 04:00 PM
Last post by 1996 328ti
05-24-2018 04:00 PM
0 Replies, 136 Views
Happy Birthday ...
05-24-2018 04:00 PM
Last post by 1996 328ti
05-24-2018 04:00 PM
0 Replies, 105 Views
1998 318ti HellRot 5...
05-06-2018 09:44 PM
Last post by lelikemd
05-24-2018 01:29 AM
16 Replies, 2,556 Views
for sale grey door cards...
04-17-2018 02:29 PM
Last post by derek502
05-23-2018 09:05 PM
2 Replies, 824 Views
Feeler: 98 318Ti Black M...
09-09-2017 03:57 AM
Last post by Shadotracker
05-23-2018 01:42 AM
29 Replies, 9,489 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 05-10-2018, 08:54 PM   #1
slade13
Senior Member
 
slade13's Avatar
 
Join Date: Mar 2011
Location: Westminster,Maryland
Posts: 159
iTrader: (0)
Default Dead tach

Has anyone had the tach stop working on their ti's? Mine just stopped working a few days ago. Did anyone fix theirs?
slade13 is offline   Reply With Quote
Old 05-10-2018, 09:24 PM   #2
BRADESTAR
Senior Member
 
Join Date: May 2013
Location: Seattle
Posts: 378
Vehicles
iTrader: (0)
Default

This happened to me. Mine was followed by bad idle and eventual stalling. Was related to a bad ground I think, I don't remember if it was the engine or battery box ground but cleaned and reattached. That and I changed the battery out at same time.
BRADESTAR is offline   Reply With Quote
Old 05-11-2018, 12:27 AM   #3
slade13
Senior Member
 
slade13's Avatar
 
Join Date: Mar 2011
Location: Westminster,Maryland
Posts: 159
iTrader: (0)
Default

Cool thanks, I’ll check it out this weekend.
slade13 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead fuel gauge; Dead eng temp; and dead OBC Shellback Electrical 8 05-29-2013 04:38 AM
erractic Tach or no tach fast2002 Electrical 0 12-06-2012 05:04 PM
Tach Problems with M3 Cluster BimmerBum Engine Swaps 22 05-21-2008 06:49 PM
batt was dead now have a misfire krovax Engine 2 02-09-2008 07:33 PM
christmas of the evil dead cali-ti General Chit Chat 0 12-26-2007 12:47 AM


All times are GMT +1. The time now is 08:28 PM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2018, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 70.74 k/82.36 k (14.11%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.