318ti.org forum

Go Back   318ti.org forum > Garage > Personal bios and Introductions

Notices

Personal bios and Introductions A short personal history.

.
» Recent Threads
turbo 6 speed ti offerup
12-30-2019 02:55 AM
Last post by BRADESTAR
Today 04:50 AM
2 Replies, 1,182 Views
Bmw compact e36 child...
02-16-2020 04:50 PM
Last post by BRADESTAR
Today 04:47 AM
1 Replies, 177 Views
Oil light comes on when...
02-09-2020 08:58 PM
Last post by noshots00
Today 02:34 AM
11 Replies, 848 Views
Diff and transmission...
02-18-2020 06:59 AM
Last post by M52tu 318ti guy
02-18-2020 07:17 PM
2 Replies, 232 Views
Auto to Manual swap on a...
02-16-2020 09:39 PM
Last post by littlebobby
02-16-2020 09:39 PM
0 Replies, 342 Views
97 BMW 318TI Auto
02-15-2020 07:47 PM
Last post by KGB318TI
02-15-2020 07:51 PM
1 Replies, 283 Views
Valeo Single Mass...
02-10-2020 01:12 AM
Last post by FunElan
02-12-2020 11:15 PM
1 Replies, 397 Views
FS: 3.45 small case LSD...
02-09-2020 04:16 AM
Last post by Budget M3
02-12-2020 10:36 PM
1 Replies, 406 Views
Oil Filter Housing Leak...
02-14-2008 09:21 PM
Last post by noshots00
02-12-2020 07:55 PM
120 Replies, 97,243 Views
Hello! New owner here.
12-20-2019 06:52 PM
Last post by J!m
02-11-2020 07:57 PM
10 Replies, 2,318 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 11-05-2019, 02:59 PM   #1
ricardoflynn
Junior Member
 
Join Date: Nov 2019
Location: UK
Posts: 1
iTrader: (0)
Default New member from the UK

I have an automatic 318ti which I bought back in June, after lurking around forums for a while. Has a surprising amount of extras for a '97 model, have been really happy with it, but it now has a rough idle/stalling issue. Would appreciate if anyone has any suggestions before I take it to a garage. Would like to avoid spending a fortune trying lots of different things to diagnose the problem! I wrote more info in the video description. Thanks for reading!

https://youtu.be/UMim5HbVdt4
ricardoflynn is offline   Reply With Quote
Old 11-05-2019, 09:54 PM   #2
thenjnick
Junior Member
 
Join Date: Aug 2018
Location: Beachwood
Posts: 28
iTrader: (0)
Default

Sounds like its really struggling to get started, is that a new problem?

How about the vacuum system? Have you gone around and checked hoses and/or sprayed around with some carb cleaner or anything?

Any loss in power other than the dropping RPMs? A compression test could be in order if you have the tool, its very cheap and a good one to have for any car.


Sent from my iPhone using Tapatalk
thenjnick is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
NEW 318ti member and website member jempsmaramba Wheel Cleaners 8 06-29-2012 05:08 AM
Cracked rear cross member tire warmer Suspension 5 09-18-2010 02:09 PM
Bad Post-Sale Experience with Org Member... what can I do? SNOWti US and North America 68 01-17-2010 02:43 PM
FS: Headlights, Front core support, Front cross member, Differential, Bumper Cover zboot US and North America 6 12-16-2007 08:45 AM
Member 3000 1996 328ti Announcements 11 01-27-2007 08:45 AM


All times are GMT +1. The time now is 08:04 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2020, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 66.86 k/77.16 k (13.35%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.