318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Interior and ICE

Notices

Interior and ICE For all interior and In Car Entertainment discussion.

.
» Recent Threads
Feeler: 98 318Ti Black M...
09-09-2017 04:57 AM
Last post by GregGT
Yesterday 11:38 PM
24 Replies, 4,658 Views
aqua cali in Tampa Fl
Yesterday 02:21 AM
Last post by aqua cali
Yesterday 10:19 PM
3 Replies, 204 Views
FS: 1995 BMW 318ti Only...
11-28-2017 06:16 PM
Last post by manydubs
Yesterday 09:39 PM
4 Replies, 731 Views
96 318ti Chico, CA
Yesterday 02:35 AM
Last post by manydubs
Yesterday 09:38 PM
2 Replies, 269 Views
Question: ti m52 swap...
12-08-2017 03:49 AM
Last post by Strawman
Yesterday 07:28 PM
8 Replies, 827 Views
M52/ZF into '96 318ti...
07-28-2013 07:49 PM
Last post by apexspeedtech
Yesterday 06:45 PM
64 Replies, 24,206 Views
Happy Birthday graymae
12-14-2017 06:01 AM
Last post by graymae
Yesterday 10:20 AM
1 Replies, 236 Views
San Jose CA 318ti Owner...
11-30-2017 02:15 AM
Last post by cocofunk
Yesterday 06:39 AM
12 Replies, 1,198 Views
Derek's Sluggish and...
03-19-2015 10:32 PM
Last post by DerekNH
Yesterday 05:51 AM
49 Replies, 9,114 Views
The 318ti OBD-II engine...
10-19-2006 07:48 PM
Last post by Beam318i
Yesterday 05:23 AM
98 Replies, 51,541 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 03-02-2009, 09:00 PM   #1
blackdragn
Junior Member
 
Join Date: Mar 2009
Location: illinois
Posts: 3
iTrader: (0)
Default Cannot get Heater AC/Stereo Panel back on

I am having trouble putting the heater AC/Stereo panel back on. There are 2 top screws which I can easily work with, but my main trouble is getting the two bottom clips back in. Seems like no matter how hard I push or bend the panel, I cannot get those clips to lock into place.
blackdragn is offline   Reply With Quote
Old 03-03-2009, 12:06 AM   #2
budget76
Senior Member
 
budget76's Avatar
 
Join Date: Nov 2007
Location: Rocky Hill, CT
Posts: 1,065
iTrader: (1)
Default

Quote:
Originally Posted by blackdragn View Post
I am having trouble putting the heater AC/Stereo panel back on. There are 2 top screws which I can easily work with, but my main trouble is getting the two bottom clips back in. Seems like no matter how hard I push or bend the panel, I cannot get those clips to lock into place.
I'm sure there's a trick one of the guys will say. FWIW my clips are long gone, and it stays in place fine. I broke those clips when I took it out the first time.

It's not that the HVAC knobs aren't lining up correctly, is it?
__________________
1995 318TI base. 95 2.5L from 325IS. S50 cams+pistons, e36 M3 front brakes. H&R race springs F+R. Turner Motorsport front sway bars, M3 control arms. M Roadster rear sway bar. Racing Dynamics strut brace. e36 325i 5spd. 3.25lsd from e28 535is. M Roadster short shifter. Conforti chip.
budget76 is offline   Reply With Quote
Old 03-03-2009, 12:10 AM   #3
blackdragn
Junior Member
 
Join Date: Mar 2009
Location: illinois
Posts: 3
iTrader: (0)
Default

No, its not that the HVAC is out of place, I'm pretty sure that it is lining up perfectly fine. Its just that no matter how hard I try to slip the clip into the hole, it does not seem like it even reaches the hole enough to lock into place. True, if I did not clip it together, the face holds in place, however, since I am working on a friend's car, I would prefer it to look as if nothing changed.
blackdragn is offline   Reply With Quote
Old 03-05-2009, 02:51 PM   #4
1CivetDei2
Senior Member
 
1CivetDei2's Avatar
 
Join Date: May 2008
Location: Rhode Island
Posts: 144
iTrader: (3)
Default

pull the angled bottom part of the panel little bit and try and slide the clips into place then put the panel on from there. Thats how i've done it. The first time i just kept pushing and they eventually feell into place but it was a pain in the ass
1CivetDei2 is offline   Reply With Quote
Old 03-05-2009, 10:11 PM   #5
blackdragn
Junior Member
 
Join Date: Mar 2009
Location: illinois
Posts: 3
iTrader: (0)
Default

I'll play with it a bit. But what happens is that if I just try to push the bottom portion in as much as possible, it doesnt seem like the clips even come close to the hole, almost as if I have to really push it in just to get the clips REMOTELY close to the holes.
blackdragn is offline   Reply With Quote
Old 07-14-2011, 05:15 AM   #6
AlexanderWayne
Junior Member
 
Join Date: Nov 2009
Location: New York City
Posts: 11
iTrader: (1)
Default

I have the same problem.Also the top of the panel that has the hole for screws on the left and the right are missing.Missing peices on the inside of car where the wires for the radio go.looks like the screws would go threw black stereo panel and connect that to the top of that inside comparment.hard to explain.
AlexanderWayne is offline   Reply With Quote
Old 07-14-2011, 05:35 PM   #7
bullmand
Senior Member
 
bullmand's Avatar
 
Join Date: Jun 2003
Location: Catonsville, MD
Posts: 1,028
iTrader: (0)
Default

That thing is a son-of-a-bitch. I ended up not driving mine for two weeks while I screwed around with trying to get that thing in there. I had bought a new panel because I broke off the passenger's side plastic clip a few years ago. I ended up breaking it off on the new one as well. The one on the driver's side seems to go in just fine, but the other side doesn't seem to want to be there. With just the driver's side in there's a slightly larger gap on the right side of the panel, but most people probably won't notice it. If anybody has a consistent, repeatable method for getting that thing installed correctly please share.
__________________
'98 Alaska Blue Sport
'99 Titan Silber 332ti
www.armyfieldband.com
www.baltimorecitypipeband.com
bullmand is offline   Reply With Quote
Old 07-15-2011, 05:29 AM   #8
englishposse
Member
 
Join Date: Jul 2009
Location: Port St Lucie, Florida
Posts: 46
iTrader: (1)
Default

I also had the same problem yesterday. I was replacing the bulb that lights up the HVAC panel, while replacing the factory radio with a new Kenwood head unit. The old panel had a burlwood on it, plus it was broken in a couple of spots so I replaced it with a new one. The panel was a pain to replace; it was the longest and hardest part of replacing the head unit. I eventually got it to fit by lining the HVAC controls up, and then getting a long flat head screwdriver to push the bottom clips back a little to line up with the holes. It took a couple of tries but worked eventually.
englishposse is offline   Reply With Quote
Old 02-18-2012, 02:29 AM   #9
turbodude
Junior Member
 
Join Date: Jun 2010
Location: Georgetown, MA
Posts: 19
Vehicles
iTrader: (0)
Default

I am having this exact same problem. I needed to replace the light bulb--which I found out is not just a replaceable minibulb (like on my e28s), but a whole minibulb assembly. I already had the minibulb ready to go and just swapped in a minibulb socket I had leftover from my e28 days--and it works great. Anyhow, I pulled the HVAC panel out okay, but it did take some jostling to get the stubborn two bottom tabs out.

It looks like if I take out the center console piece that sits directly below the panel it will give me enough space to get the tabs to insert at the right angle--but I don't see a ready way to pull that part of the center console out. I pulled apart the shift boot (5-speed) and didn't see any screws that would loosen the console, but I didn't pull things apart searching (yet), as I had to drive the car right away.

It would be great to hear from anyone who has put this back in there WITHOUT breaking the tabs off.
turbodude is offline   Reply With Quote
Reply

Bookmarks

Tags
face , heater , panel , stereo


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB: Door panel clip stand off pieces, Roll bars, Front springs, Cat Back exhaust dgroebl US and North America 10 02-25-2009 12:01 AM
WTB:Climate/Heater Control Panel trunks03 US and North America 4 11-11-2008 06:11 AM
front grille panel (nose panel) clem318ti US and North America 3 11-06-2008 07:19 PM
instrument panel back light illumination help toast27 Electrical 20 05-11-2006 04:16 PM
Heater Control - Panel 318ti Coupe Interior and ICE 1 02-06-2006 03:30 PM


All times are GMT +1. The time now is 02:23 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2017, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 100.42 k/118.15 k (15.00%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.