318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Electrical

Notices

Electrical All wiring questions.

.
» Recent Threads
Thinking of doing a body...
Today 01:38 AM
Last post by Tasmaniak
Today 01:38 AM
0 Replies, 37 Views
FS - 1996 318ti 5 speed
08-19-2017 10:58 PM
Last post by salguod
Today 12:05 AM
3 Replies, 716 Views
Which diff on 2.8 engine?
09-21-2017 01:06 AM
Last post by E30-M3
Yesterday 10:58 PM
12 Replies, 553 Views
Happy Birthday ...
Yesterday 05:01 AM
Last post by anassa
Yesterday 08:23 PM
2 Replies, 170 Views
96, M Sport, 5 speed,...
09-09-2017 07:24 PM
Last post by cjm1219
Yesterday 05:14 PM
13 Replies, 1,180 Views
Any active part-outs...
08-30-2017 09:35 PM
Last post by marleymon
09-22-2017 01:22 PM
5 Replies, 752 Views
318ti Turbo by MK...
09-18-2017 03:02 PM
Last post by Nakamiki
09-22-2017 09:23 AM
12 Replies, 654 Views
Hello from Wisconsin
09-21-2017 04:06 AM
Last post by MikeF
09-22-2017 02:57 AM
5 Replies, 363 Views
Feeler: 98 318Ti Black M...
09-09-2017 03:57 AM
Last post by E30-M3
09-21-2017 11:33 PM
5 Replies, 738 Views
Euro glass headlights
09-24-2014 10:27 PM
Last post by apexspeedtech
09-21-2017 05:25 PM
172 Replies, 85,819 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 05-26-2009, 05:59 PM   #1
s_menezes
Junior Member
 
Join Date: Jan 2009
Location: Miami
Posts: 13
iTrader: (0)
Angry Electrical Shutoff after Ignition ?!?!?!?!

Very strange and dangerous issue with my '95 TI :

I turn the car on (before the ignition) .... all electrical elements work perfect (radio, wipers, etc.). As soon as I turn the ignition key and the motor starts running .... radio, wipers, windows all cease to function.

Sometimes ... while driving ... out of nowhere the electrical comes on miraculously; but more often than not I have to make sure it won't rain, etc. because I live in South Florida and this could be a real hazard while driving.

Anyone have any clue what is going on?

Comments MOST APPRECIATED ! THANKS
s_menezes is offline   Reply With Quote
Old 05-26-2009, 09:28 PM   #2
xxxJohnBoyxxx
Senior Member
 
Join Date: Dec 2007
Location: Gulfport, Florida
Posts: 3,208
iTrader: (1)
Default

Quote:
Originally Posted by s_menezes View Post
Very strange and dangerous issue with my '95 TI :

I turn the car on (before the ignition) .... all electrical elements work perfect (radio, wipers, etc.). As soon as I turn the ignition key and the motor starts running .... radio, wipers, windows all cease to function.

Sometimes ... while driving ... out of nowhere the electrical comes on miraculously; but more often than not I have to make sure it won't rain, etc. because I live in South Florida and this could be a real hazard while driving.

Anyone have any clue what is going on?

Comments MOST APPRECIATED ! THANKS
Bad unloader relay or bad wiring to unloader relay or ground issues
xxxJohnBoyxxx is offline   Reply With Quote
Old 05-26-2009, 09:46 PM   #3
s_menezes
Junior Member
 
Join Date: Jan 2009
Location: Miami
Posts: 13
iTrader: (0)
Thumbs up Unloader Relay

Hey I really appreciate the response. Is this unloader relay something I can simply buy and replace myself? Any idea where it is in a 318ti?

Thanks so much!
s_menezes is offline   Reply With Quote
Old 05-30-2009, 09:12 PM   #4
xxxJohnBoyxxx
Senior Member
 
Join Date: Dec 2007
Location: Gulfport, Florida
Posts: 3,208
iTrader: (1)
Default

Quote:
Originally Posted by s_menezes View Post
Hey I really appreciate the response. Is this unloader relay something I can simply buy and replace myself? Any idea where it is in a 318ti?

Thanks so much!
Sorry for the delayed reponse. I forgot about this thread. Yes it can be purchased and is a plug in item. I'm not sure where it is on the ti. mine is a 97 318is and is position #2 in the relay group in fuse box. I'm sure someone on the board can help if you post a question of were is my unloader relay. Maybe check a Bentley manual.

Good luck
xxxJohnBoyxxx is offline   Reply With Quote
Reply

Bookmarks

Tags
electrical , ignition , shut off , wipers


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical questions minicoop900 Interior and ICE 11 05-25-2008 06:15 PM
Electrical drain Borg561 Electrical 5 03-24-2008 01:16 AM
electrical problems m44ic Electrical 7 05-15-2005 01:07 PM
Electrical woos Teno Electrical 5 04-18-2005 02:02 PM
electrical problem dodj Electrical 6 08-11-2004 05:18 AM


All times are GMT +1. The time now is 06:08 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2017, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 78.15 k/90.64 k (13.77%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.