318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Electrical

Notices

Electrical All wiring questions.

.
» Recent Threads
Knocking noise when cold...
11-11-2017 03:53 PM
Last post by Ivan
Today 11:39 PM
6 Replies, 837 Views
The 318ti OBD-II engine...
10-19-2006 07:48 PM
Last post by wmealer
Today 11:33 PM
94 Replies, 47,462 Views
new engine build. dasc +...
01-02-2016 02:28 AM
Last post by VanRich
Today 10:25 PM
134 Replies, 51,127 Views
[332ti: S54 Hellrot...
04-10-2017 06:25 PM
Last post by VanRich
Today 09:57 PM
27 Replies, 3,724 Views
HELP!! Airbag sensor
11-18-2017 08:18 PM
Last post by newto318
Today 01:15 AM
6 Replies, 387 Views
Another Swapped Ti
11-19-2016 07:43 PM
Last post by BlackBMWs
Yesterday 07:50 PM
64 Replies, 19,347 Views
WTB: Ascot Green 318ti,...
11-17-2017 03:08 PM
Last post by apexspeedtech
11-19-2017 07:26 PM
1 Replies, 310 Views
WTB M44 Motor
11-18-2017 09:38 PM
Last post by radicalr6
11-18-2017 09:38 PM
0 Replies, 226 Views
2018 318ti.org Calendar...
11-15-2017 04:10 PM
Last post by FunElan
11-18-2017 08:05 PM
8 Replies, 663 Views
Thermostat housing
11-17-2017 06:51 PM
Last post by rudyst514
11-17-2017 09:09 PM
2 Replies, 276 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 05-26-2009, 06:59 PM   #1
s_menezes
Junior Member
 
Join Date: Jan 2009
Location: Miami
Posts: 13
iTrader: (0)
Angry Electrical Shutoff after Ignition ?!?!?!?!

Very strange and dangerous issue with my '95 TI :

I turn the car on (before the ignition) .... all electrical elements work perfect (radio, wipers, etc.). As soon as I turn the ignition key and the motor starts running .... radio, wipers, windows all cease to function.

Sometimes ... while driving ... out of nowhere the electrical comes on miraculously; but more often than not I have to make sure it won't rain, etc. because I live in South Florida and this could be a real hazard while driving.

Anyone have any clue what is going on?

Comments MOST APPRECIATED ! THANKS
s_menezes is offline   Reply With Quote
Old 05-26-2009, 10:28 PM   #2
xxxJohnBoyxxx
Senior Member
 
Join Date: Dec 2007
Location: Gulfport, Florida
Posts: 3,208
iTrader: (1)
Default

Quote:
Originally Posted by s_menezes View Post
Very strange and dangerous issue with my '95 TI :

I turn the car on (before the ignition) .... all electrical elements work perfect (radio, wipers, etc.). As soon as I turn the ignition key and the motor starts running .... radio, wipers, windows all cease to function.

Sometimes ... while driving ... out of nowhere the electrical comes on miraculously; but more often than not I have to make sure it won't rain, etc. because I live in South Florida and this could be a real hazard while driving.

Anyone have any clue what is going on?

Comments MOST APPRECIATED ! THANKS
Bad unloader relay or bad wiring to unloader relay or ground issues
xxxJohnBoyxxx is offline   Reply With Quote
Old 05-26-2009, 10:46 PM   #3
s_menezes
Junior Member
 
Join Date: Jan 2009
Location: Miami
Posts: 13
iTrader: (0)
Thumbs up Unloader Relay

Hey I really appreciate the response. Is this unloader relay something I can simply buy and replace myself? Any idea where it is in a 318ti?

Thanks so much!
s_menezes is offline   Reply With Quote
Old 05-30-2009, 10:12 PM   #4
xxxJohnBoyxxx
Senior Member
 
Join Date: Dec 2007
Location: Gulfport, Florida
Posts: 3,208
iTrader: (1)
Default

Quote:
Originally Posted by s_menezes View Post
Hey I really appreciate the response. Is this unloader relay something I can simply buy and replace myself? Any idea where it is in a 318ti?

Thanks so much!
Sorry for the delayed reponse. I forgot about this thread. Yes it can be purchased and is a plug in item. I'm not sure where it is on the ti. mine is a 97 318is and is position #2 in the relay group in fuse box. I'm sure someone on the board can help if you post a question of were is my unloader relay. Maybe check a Bentley manual.

Good luck
xxxJohnBoyxxx is offline   Reply With Quote
Reply

Bookmarks

Tags
electrical , ignition , shut off , wipers


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical questions minicoop900 Interior and ICE 11 05-25-2008 07:15 PM
Electrical drain Borg561 Electrical 5 03-24-2008 02:16 AM
electrical problems m44ic Electrical 7 05-15-2005 02:07 PM
Electrical woos Teno Electrical 5 04-18-2005 03:02 PM
electrical problem dodj Electrical 6 08-11-2004 06:18 AM


All times are GMT +1. The time now is 11:41 PM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2017, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 77.41 k/90.02 k (14.01%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.