318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Engine

Notices

Engine Tuneups, chips, wires, spark plugs.

.
» Recent Threads
Brakes - soft pedal and...
04-14-2024 01:02 PM
Last post by bcp
04-14-2024 01:09 PM
1 Replies, 662 Views
lolita porn
04-13-2024 11:45 PM
Last post by Josephtus
04-13-2024 11:45 PM
0 Replies, 192 Views
lolita porn
04-13-2024 11:43 PM
Last post by Josephtus
04-13-2024 11:44 PM
1 Replies, 128 Views
lolita porn
04-13-2024 11:40 PM
Last post by Josephtus
04-13-2024 11:41 PM
1 Replies, 119 Views
lolita porn
04-13-2024 11:38 PM
Last post by Josephtus
04-13-2024 11:39 PM
1 Replies, 116 Views
lolita porn
04-13-2024 11:36 PM
Last post by Josephtus
04-13-2024 11:37 PM
1 Replies, 114 Views
lolita porn
04-13-2024 11:35 PM
Last post by Josephtus
04-13-2024 11:35 PM
0 Replies, 104 Views
lolita porn
04-13-2024 11:34 PM
Last post by Josephtus
04-13-2024 11:34 PM
0 Replies, 106 Views
lolita porn
04-13-2024 11:33 PM
Last post by Josephtus
04-13-2024 11:33 PM
0 Replies, 100 Views
lolita porn
04-13-2024 11:33 PM
Last post by Josephtus
04-13-2024 11:33 PM
0 Replies, 94 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 10-25-2007, 10:34 PM   #1
Will'sBimmer
Senior Member
 
Will'sBimmer's Avatar
 
Join Date: May 2006
Location: Memphis, Tn
Posts: 1,299
iTrader: (0)
Default Problem with my heat!!

My car will not produce any heat. Since some cold weather has moved into my town in the past few days I have noticed a promblem with my Ti. My engine will not heat up past the blue mark. it gets to the edge of the blue and that is it. I try to use the heat during this time and all I get is cool air. This is not good. I figure that if my car was heating up (to the halfway mark) then maybe my heat would work???? But i am not sure. could someone help me out. I need some heat for the upcoming winter.
__________________
custom dual exhaust,M3 front and rear bumper, 10.4 inch roof mount drop screen, Viper alarm system, DSII's rims, M3 Vader Seats, M3 Mirrors, Carbon Fiber CAI, Smoked Corners, Side Markers, Leatherz armrests, black grilles


225k miles and still the Ti goes on
Will'sBimmer is offline   Reply With Quote
Old 10-25-2007, 10:41 PM   #2
aceyx
Senior Member
 
aceyx's Avatar
 
Join Date: Aug 2004
Location: state college, pa
Posts: 3,431
iTrader: (0)
Default

You need a new thermostat.
__________________
I scream, you scream, we all scream for ZOMBIES.
aceyx is offline   Reply With Quote
Old 10-25-2007, 11:10 PM   #3
Will'sBimmer
Senior Member
 
Will'sBimmer's Avatar
 
Join Date: May 2006
Location: Memphis, Tn
Posts: 1,299
iTrader: (0)
Default

thanks for the advice. i already have a new thermostat out in the garage. so i quess now all i need to do is install it and then bleed the coolant off. well if anyone else has anymore advice, it would be much appreciated.
__________________
custom dual exhaust,M3 front and rear bumper, 10.4 inch roof mount drop screen, Viper alarm system, DSII's rims, M3 Vader Seats, M3 Mirrors, Carbon Fiber CAI, Smoked Corners, Side Markers, Leatherz armrests, black grilles


225k miles and still the Ti goes on
Will'sBimmer is offline   Reply With Quote
Old 10-26-2007, 12:32 AM   #4
CirrusSR22
Senior Member
 
Join Date: Nov 2004
Location: Minneapolis
Posts: 1,587
iTrader: (3)
Default

Yep, most likely a thermostat. If you let your car idle (stopped), will it warm up more than if it was rolling? If so, it's the thermostat stuck open.

I recommend using the bleed instructions on understeer.com. http://understeer.com/waterpump.shtml Step#10
CirrusSR22 is offline   Reply With Quote
Old 10-26-2007, 12:43 AM   #5
adamud
Senior Member
 
adamud's Avatar
 
Join Date: Mar 2005
Location: Detroit, MI
Posts: 585
iTrader: (0)
Default

When I first bought my ti, I couldn't get it to move past the first white mark. I replaced the thermo and got my heat and the temp gauge to work. I'm going to agree with everyone else and say its the thermostat.
adamud is offline   Reply With Quote
Old 10-26-2007, 06:34 AM   #6
aceyx
Senior Member
 
aceyx's Avatar
 
Join Date: Aug 2004
Location: state college, pa
Posts: 3,431
iTrader: (0)
Default

There's a writeup somewhere. Apart from draining the coolant, it's just a bolt-on part.

Two things:
1. Use penetrating spray like Kroil, PB Blaster, etc, preferrably starting the night before to let it soak in. WD40 is crap.
2. To remove the hoses easier, twist them before pulling to break the seal, and twist back and forth while pulling.
__________________
I scream, you scream, we all scream for ZOMBIES.
aceyx is offline   Reply With Quote
Old 01-19-2008, 05:11 PM   #7
Will'sBimmer
Senior Member
 
Will'sBimmer's Avatar
 
Join Date: May 2006
Location: Memphis, Tn
Posts: 1,299
iTrader: (0)
Default

Ok I think this problem is past a new thermostat. I have now noticed that the cable for the turn knob must be broken. Because I can not get it to switch from cold to Hot. It just turns and nothing happens from there. I am hoping that someone on this forum could point me in the right direction about how I can get to this cable and possibly fix the situation. Is there a way I can just pull on the broken cable and get it to switch to Heat and not have to buy a new cable????? All and any help is welcome. I can't drive my car when it is 30 degrees outside and I have no heat. My toes freeze and everything else. Plus no heat means no hot chicks............ help me get the chicks back guys.
__________________
custom dual exhaust,M3 front and rear bumper, 10.4 inch roof mount drop screen, Viper alarm system, DSII's rims, M3 Vader Seats, M3 Mirrors, Carbon Fiber CAI, Smoked Corners, Side Markers, Leatherz armrests, black grilles


225k miles and still the Ti goes on
Will'sBimmer is offline   Reply With Quote
Old 01-19-2008, 05:55 PM   #8
cali-ti
aka Stabby
 
cali-ti's Avatar
 
Join Date: Nov 2004
Location: Mead, CO
Posts: 5,336
iTrader: (0)
Default

not the best pics, but might help: http://www.318ti.org/forum/showthrea...highlight=heat
__________________
1996 318ti, California package, 267k miles
current mods: bilstein sports, bavauto springs, e30 m3 LCABs, solid metal ball joints, bavauto RSMs w/reinforcements, e30 3.73 LSD & halfshafts, supersprint cat-back exhaust, turner rear sway bar reinforcements, IE poly subframe & RTABs + camber/toe kits, powdercoated e36 32x front calipers, sport mirrors, H&R 28mmF/19mmR sway bars, x-brace, auto solutions SSK w/poly bushing upgrade, BMW CD43 head unit, DICE HD Radio w/iPod integration and "stealth" HD antenna, staggered style 68s, orange electronic TPMS, leather arm rest, JT Designs metal undertray

acquired and awaiting install: heated seat kit, cali top switch relo, lumbar support kit, park distance control kit, heated washer nozzle kit, m-coupe rear subframe, trailing arms, differential, and halfshafts, m-coupe front/rear brakes with master cylinder, under hood light kit, mud flaps, rear sun blind, auto-dimming rear view mirror, tilt steering wheel retrofit, apexcone 5000K HIDs with 55W ballasts




2002 X5 4.4 Sport Package, 53.5k miles
Current Mods: e46 m3 steering wheel
cali-ti is offline   Reply With Quote
Old 01-19-2008, 06:03 PM   #9
Will'sBimmer
Senior Member
 
Will'sBimmer's Avatar
 
Join Date: May 2006
Location: Memphis, Tn
Posts: 1,299
iTrader: (0)
Default

Thanks for the quick reply and for the pics. not the best but hey they work for me and have given me insight. thanks cali ti
__________________
custom dual exhaust,M3 front and rear bumper, 10.4 inch roof mount drop screen, Viper alarm system, DSII's rims, M3 Vader Seats, M3 Mirrors, Carbon Fiber CAI, Smoked Corners, Side Markers, Leatherz armrests, black grilles


225k miles and still the Ti goes on
Will'sBimmer is offline   Reply With Quote
Old 01-19-2008, 10:32 PM   #10
cooljess76
NOBODY F's with the Jesus
 
cooljess76's Avatar
 
Join Date: Oct 2006
Location: Ventura California
Posts: 7,824
iTrader: (6)
Default

Hey Will, I had this happen to me a couple of months ago. There was a recall a while back and the dealer was supposed to put a screw through the little yellow tab to hold it in place and keep it from slipping out of it's detent. On my car, the dealer had already performed this mod, but the yellow clip with the screw ripped a big chunk out of my heater box. After several minutes of racking my brain, I decided to ziptie the cable to the steel tubular support frame under the dash where the cable intersects it. With the yellow tab firmly wedged into it's detent, the cable is now snug as a bug. There's no chance of it ever slipping out again and the routing of the cable allows smooth turning of the knob. I tested it about a hundred times before I buttoned everything back up and it works perfectly now. Good Luck, LMK if you have anymore problems getting it to work.

BTW, you'll get better access if you take the glove compartment and kick panel out from the passenger's side legwell.
__________________
4 MORE YEARS BABY!!!
cooljess76 is offline   Reply With Quote
Old 01-20-2008, 12:24 AM   #11
Will'sBimmer
Senior Member
 
Will'sBimmer's Avatar
 
Join Date: May 2006
Location: Memphis, Tn
Posts: 1,299
iTrader: (0)
Default UpDate

I went out to my dad's friend's body shop. My dad and me changed the Thermostat with a brand new one. So now my engine temp. is exactly where it should be. The car runs a lot better when it is warm. But my heat is still having a problem. I know now that it is not my cable. When I turn it to heat it begins to get maybe like luke warm or just a few degrees below that but you can tell it is trying. But just not hard enough. Now my dad's friend suggest that it is this small grey thing that is located on the driver's side pretty close to the firewall. He says that it is a water pump that helps the heat or something. I need to confirm this will of you all to make sure that I am headed in the right direction of getting a replacement piece and fixing the problem. Thanks for any help.
__________________
custom dual exhaust,M3 front and rear bumper, 10.4 inch roof mount drop screen, Viper alarm system, DSII's rims, M3 Vader Seats, M3 Mirrors, Carbon Fiber CAI, Smoked Corners, Side Markers, Leatherz armrests, black grilles


225k miles and still the Ti goes on
Will'sBimmer is offline   Reply With Quote
Old 01-20-2008, 01:48 AM   #12
cali-ti
aka Stabby
 
cali-ti's Avatar
 
Join Date: Nov 2004
Location: Mead, CO
Posts: 5,336
iTrader: (0)
Default

#5? http://www.realoem.com/bmw/showparts...02&hg=64&fg=18
__________________
1996 318ti, California package, 267k miles
current mods: bilstein sports, bavauto springs, e30 m3 LCABs, solid metal ball joints, bavauto RSMs w/reinforcements, e30 3.73 LSD & halfshafts, supersprint cat-back exhaust, turner rear sway bar reinforcements, IE poly subframe & RTABs + camber/toe kits, powdercoated e36 32x front calipers, sport mirrors, H&R 28mmF/19mmR sway bars, x-brace, auto solutions SSK w/poly bushing upgrade, BMW CD43 head unit, DICE HD Radio w/iPod integration and "stealth" HD antenna, staggered style 68s, orange electronic TPMS, leather arm rest, JT Designs metal undertray

acquired and awaiting install: heated seat kit, cali top switch relo, lumbar support kit, park distance control kit, heated washer nozzle kit, m-coupe rear subframe, trailing arms, differential, and halfshafts, m-coupe front/rear brakes with master cylinder, under hood light kit, mud flaps, rear sun blind, auto-dimming rear view mirror, tilt steering wheel retrofit, apexcone 5000K HIDs with 55W ballasts




2002 X5 4.4 Sport Package, 53.5k miles
Current Mods: e46 m3 steering wheel
cali-ti is offline   Reply With Quote
Old 01-20-2008, 02:54 AM   #13
Will'sBimmer
Senior Member
 
Will'sBimmer's Avatar
 
Join Date: May 2006
Location: Memphis, Tn
Posts: 1,299
iTrader: (0)
Default

Yeah Number 5$ Do you know where I can get that fairly cheap?
__________________
custom dual exhaust,M3 front and rear bumper, 10.4 inch roof mount drop screen, Viper alarm system, DSII's rims, M3 Vader Seats, M3 Mirrors, Carbon Fiber CAI, Smoked Corners, Side Markers, Leatherz armrests, black grilles


225k miles and still the Ti goes on
Will'sBimmer is offline   Reply With Quote
Old 01-20-2008, 03:04 AM   #14
Will'sBimmer
Senior Member
 
Will'sBimmer's Avatar
 
Join Date: May 2006
Location: Memphis, Tn
Posts: 1,299
iTrader: (0)
Default

I see that bavauto.com has the part for 75. anyone else find it any cheaper??
__________________
custom dual exhaust,M3 front and rear bumper, 10.4 inch roof mount drop screen, Viper alarm system, DSII's rims, M3 Vader Seats, M3 Mirrors, Carbon Fiber CAI, Smoked Corners, Side Markers, Leatherz armrests, black grilles


225k miles and still the Ti goes on
Will'sBimmer is offline   Reply With Quote
Old 01-20-2008, 03:43 AM   #15
cali-ti
aka Stabby
 
cali-ti's Avatar
 
Join Date: Nov 2004
Location: Mead, CO
Posts: 5,336
iTrader: (0)
Default

tischer bmw: $70.40 http://www.trademotion.com/partlocat...&siteid=214336

autohausaz.com and pelicanparts.com were both more expensive.
__________________
1996 318ti, California package, 267k miles
current mods: bilstein sports, bavauto springs, e30 m3 LCABs, solid metal ball joints, bavauto RSMs w/reinforcements, e30 3.73 LSD & halfshafts, supersprint cat-back exhaust, turner rear sway bar reinforcements, IE poly subframe & RTABs + camber/toe kits, powdercoated e36 32x front calipers, sport mirrors, H&R 28mmF/19mmR sway bars, x-brace, auto solutions SSK w/poly bushing upgrade, BMW CD43 head unit, DICE HD Radio w/iPod integration and "stealth" HD antenna, staggered style 68s, orange electronic TPMS, leather arm rest, JT Designs metal undertray

acquired and awaiting install: heated seat kit, cali top switch relo, lumbar support kit, park distance control kit, heated washer nozzle kit, m-coupe rear subframe, trailing arms, differential, and halfshafts, m-coupe front/rear brakes with master cylinder, under hood light kit, mud flaps, rear sun blind, auto-dimming rear view mirror, tilt steering wheel retrofit, apexcone 5000K HIDs with 55W ballasts




2002 X5 4.4 Sport Package, 53.5k miles
Current Mods: e46 m3 steering wheel
cali-ti is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
E46 Ti - Front speaker replacement using existing speaker housing and standard 6.5" vatovey Knowledge Base 4 01-29-2010 11:51 AM
bulb help classicronnie Exterior 9 12-27-2007 10:54 PM
Standard H1 Bulb Or ...... Tyler Exterior 16 01-13-2007 07:55 PM
Difference between standard and Sport susp? PeteN95 Suspension 5 09-20-2006 08:01 PM
Standard for Standard Diff Swap stormos Differentials 4 03-14-2006 11:33 PM


All times are GMT +1. The time now is 08:29 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2024, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 127.73 k/152.12 k (16.03%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.