318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Engine

Notices

Engine Tuneups, chips, wires, spark plugs.

.
» Recent Threads
Learning to drift
06-29-2019 09:11 PM
Last post by andakn
Yesterday 02:59 AM
2 Replies, 1,762 Views
Repair vs. Replace? ...
07-29-2019 03:41 PM
Last post by roadrash
08-16-2019 04:53 PM
4 Replies, 1,871 Views
M47 crank on m44, crank...
08-16-2019 03:24 PM
Last post by Rtalatief
08-16-2019 03:24 PM
0 Replies, 140 Views
'95 318ti auto to 325ti...
01-06-2016 06:56 PM
Last post by EtherD5
08-16-2019 12:45 PM
8 Replies, 3,000 Views
DASC install manual...
08-15-2017 02:28 PM
Last post by Alivinglegend
08-16-2019 06:59 AM
7 Replies, 2,472 Views
WTB in Norcal
01-13-2019 11:33 PM
Last post by cabrenee
08-15-2019 02:28 AM
12 Replies, 3,842 Views
Engine Bay Whine and...
08-09-2019 02:34 AM
Last post by teamjoe
08-14-2019 05:17 PM
4 Replies, 1,523 Views
98 Ti Wiring Harness and...
08-14-2019 05:13 PM
Last post by 98318ti
08-14-2019 05:13 PM
0 Replies, 209 Views
How much is too much $...
06-22-2019 10:31 PM
Last post by shriberone
08-13-2019 09:17 PM
5 Replies, 2,825 Views
California Top Complete...
08-11-2019 09:43 PM
Last post by Trusted-1
08-13-2019 02:48 PM
6 Replies, 836 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 08-08-2019, 03:34 PM   #1
Rj318ti97
Junior Member
 
Join Date: Aug 2019
Location: Pennsylvania
Posts: 3
iTrader: (0)
Default Hard start

I have a 1997 318ti that had recently overheated I got the car home and noticed the water hose connector on the rear cylinder head was leaking so I replaced it no more leaking but and I also replaced thermostat and engine temp sensor on head but I can only get the car to start with the pedal to the floor and itidles rough for a minute then it will run and idle fine I do not know what the problem is it happened after the engine overheated I'm hoping it is a minor problem and not a blown engine or blown head also I pulled the spark plugs after running and they are dry and light Brown color which is normal no signs of being wet at all also I smell gas when I am crank to start the engine any help is greatly appreciated thank you
Rj318ti97 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
97 318ti overheating hard start Rj318ti97 Engine 0 08-08-2019 02:18 PM
1995 Club Sport Hard to Start Has Codes: PowerClubSport Engine 1 10-05-2016 06:03 AM
Very hard to start - no power under load MikeLiv Engine 1 02-15-2013 10:19 PM
Hard to start when its warm outside RodneyWarren Engine 0 05-01-2012 11:41 PM
M42 w/ DASC hard start mystery ? Pursuit Induction 6 09-01-2010 03:37 AM


All times are GMT +1. The time now is 06:27 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2019, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 64.64 k/73.97 k (12.62%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.