318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Engine

Notices

Engine Tuneups, chips, wires, spark plugs.

.
» Recent Threads
WTB: 318ti with...
04-20-2022 09:57 AM
Last post by Andy318
02-27-2024 05:14 PM
20 Replies, 112,853 Views
What model ti do you own?
02-26-2003 04:40 AM
Last post by huirtera
02-24-2024 03:08 PM
356 Replies, 267,791 Views
1997 318i M44 Electric...
02-14-2024 06:17 PM
Last post by MussSyke
02-22-2024 09:27 PM
1 Replies, 32,172 Views
Downing Atlanta...
02-21-2024 06:57 PM
Last post by Glane
02-21-2024 06:57 PM
0 Replies, 5,116 Views
Break free from...
02-20-2024 02:43 PM
Last post by tom100
02-20-2024 02:43 PM
0 Replies, 8,081 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 04-07-2014, 05:28 AM   #1
BlackBMWs
Senior Member
 
BlackBMWs's Avatar
 
Join Date: Feb 2012
Location: Sacramento, CA
Posts: 2,451
Vehicles
iTrader: (7)
Post OBD Code 1243 - Dead Secondary air pump

Ti'ers

I started my questions on this repair in a different thread and decided to consolidate my questions and document the fix in case someone else has the same issue. Easy fix.

I should mention there are multiple conditions that could trigger a P1243, This simply addresses one of the causes and my action to repair it. Good luck!

--------------------------------------------------------------------------------------------------------------------------------------

Quote:
Originally Posted by cooljess76 View Post
Secondary air pump rivet failure is a common issue on these cars. Myself and several others have replaced the rivets with nuts and bolts. As for removal, disconnect the hose and you can either unbolt the bracket and remove it as an assembly or simply slide the rubber bushing off of the bracket.
I'll pull the air pump this weekend, but can someone describe which rivets fail here? I'm asking to get an advance idea of what the probable fix is. A pic would be great. Thanks!

-------------------------------------------------------------------------------------------------------------

Cleared codes last week, drove around, only P1423 reemerged. Arrgghh, I was going to swap diffs today. o well.

So, I'll check the rigid hose and air pump. Are folks referring to the rivets in the top of the pump?


-----------------------------------------------------------------------------------------------------------------

OK, I removed my strut brace, the MAF and the ASC throttle plate assembly to get to the air pump. I removed the rigid emissions tube/hose. The hard hose is intact, no cracks and seems to seal tight. Clips on both end are intact. There was a little moisture in the pipe. Like a teaspoon amount or less.


I removed the air pump by removing the two 13mm nuts, unclipping a rubber carrier for another emissions valve and unclipped the electrical connector at the bottom of the pump. Visual inspection: all rivets look fine, no gaps in the seams between top bottom and middle pieces that the rivets secure. The plastic clips on the pump are all also intact.



I checked for 12v at the red/yellow wire coming into the pump with ignition on. No voltage, but looked in ETK and Bentley and there is a relay from the air pump. I'm not sure how to test the inbound power to the pump.


I applied 12V/grn directly to the air pump. Nothing. May seem obvious, but do these pump motors generally fail? I'll cross check PN# and head out to the yards to see if I can locate an operating one after lunch as a new one is $350. $24.99 at Pick n Pull if you can locate one. Look for a late model 1996+ I suspect the production date should past June, but good to confirm.


It's interesting that this PN# does not show up in REALOem. Am I reading it correctly? 1172 1 432 593

-------------------------------------------------------------------------------------------------------------------------------------------

OK, so no pump was available in the local yards on Saturday, but I did find one in a yard about 50 miles away in a 1997 318i sedan Sunday morning. I lucked out, as someone had pulled it, saw the failed rivets and kindly left it intact on the drivers floor.

I tested the pump I found at the pick n pull in the parking lot. It tested fine. The one I found had failed rivets, but it did not impact the testing or operation of its motor. The original one I pulled out of my car failed a power test totally.

So, the motor drives a centrifugal fan. (I didn't know what was under the cap) I went to Ace Hardware and picked up some black Allen bolts and silver nuts with a friction washer. The nylon nuts turned out to be too big. Looked odder. I wish I found some black ones, but the nuts are on the bottom anyway and aren't visible.



I hand tightened the nuts/bolts, plus another 1/8 turn with some red Locktite. The nuts aren't going anywhere. The black allen bolts look almost original. The replacement is in the foreground, with the failed pump in the background.


The air pump is suspended in place with three rubber mounts that attach with 10mm nuts. When you are reassembling the carriers, you can use a 17mm open end wrench to hold the mounts so you don't end up twisting them when you are tightening the nut. I'll order a few replacement mounts as these were pretty soft after 190k miles.

One tip, mark the position of the pump in the two carriers BEFORE you take them apart.


One you have it all back together, reassemble in reverse order as you took it out.

Shortly upon startup, I heard the fan kick in. I guess it has been out for awhile, cause it was a totally new sound. I reset the codes and will drive around, until it either fails again or my reader says I'm good to go retest for SMOG.

I'll take apart the original motor to see why it failed. If I can fix it, I'll keep it as a spare. I never really paid much attention to this pump in the past, I just knew it existed. I know the one on my 540it is larger and still is spinning along.

I hope this helps someone else.

Cheers!
__________________


1998 318ti Sport - "Cali" Schwartz II/Schwartz sport interior, Cali top
1998 318ti Sport - "Max" Schwartz II/Schwartz sport interior, S52
1997 318ti Sport - "Tiny" Schwartz II/Schwartz sport interior
1995 318ti Active - "Blanca" Alpineweib III/Schwartz leather interior

Other Current Bimmers: 2006 530i / 2000 2.3L Z3 / 1997 1.9L Z3 / 1999 540it

1997 318ti Sport - "Huera" - RIP
1995 318ti Active - RIP
1995 318ti Sport - "Tiny" Sold
1994 325i Sedan - "Jade" - Sold
1991 318ic - "Bert" - Sold
1985 635csi sold
1984 533i "Max" Sold
1984 318i sold

BMWCCA #160411

SUPPORT 318ti.org! CLICK THE LINK ABOVE!
Hosting a forum like this is not free. 318ti.org is one of the best BMW forums on the web because it is member supported, not vendor supported. The cost to become a Supporter is a nominal $10.00... A YEAR! DO IT! NOW!

Last edited by BlackBMWs; 04-08-2014 at 02:56 AM.
BlackBMWs is offline   Reply With Quote
Old 04-07-2014, 08:28 PM   #2
30yrMbr
Senior Member
 
30yrMbr's Avatar
 
Join Date: Feb 2005
Location: Laguna Beach
Posts: 357
Vehicles
iTrader: (3)
Default Q. Did you find a replacement that worked or....

"OK, so no pump was available in the local yards, on Saturday, but I did find one in a yard about 50 miles away in a 1997 318i sedan Sunday morning. I lucked out, as someone had pulled it, saw the failed rivets and kindly left it intact on the drivers floor.

I applied 12V/grn to the pump motor and it fired right up.

So, the motor drives a centrifugal fan. (I didn't know what was under the cap) I went to Ace Hardware and picked up some black Allen bolts and silver nuts with a friction washer. The nylon nuts turned out to be too big. Looked odder. I wish I found some black ones, but the nuts are on the bottom anyway and aren't visible. "

Somewhere I lost the tread of this writeup. You said that no pump available at the local Pick a Part and the one 50 miles away had "failed riviets". So then you say you applied 12V/grn and it worked. Would that be the original one or another?

THanks
Roger
__________________
1996 ///M 318ti
Alaska Blue, M-Technic, Chip, Stromung catback, 17" BMW Ltw Wheels, B&M SSK, H&R Springs/Bilsteins, StopTech Brake Lines;

http://www.318ti.org/gallery/data/54...27_clipped.jpg
30yrMbr is offline   Reply With Quote
Old 04-07-2014, 10:50 PM   #3
BlackBMWs
Senior Member
 
BlackBMWs's Avatar
 
Join Date: Feb 2012
Location: Sacramento, CA
Posts: 2,451
Vehicles
iTrader: (7)
Default

Hi Roger. Ah, I'll clarify when I get home. I tested the pump I found at the pick n pull in the parking lot. It tested fine. The found one had failed rivets, but it did not impact the testing or operation of its motor. The original one I pulled out of my car failed a power test totally.


Sent from my mobile device
__________________


1998 318ti Sport - "Cali" Schwartz II/Schwartz sport interior, Cali top
1998 318ti Sport - "Max" Schwartz II/Schwartz sport interior, S52
1997 318ti Sport - "Tiny" Schwartz II/Schwartz sport interior
1995 318ti Active - "Blanca" Alpineweib III/Schwartz leather interior

Other Current Bimmers: 2006 530i / 2000 2.3L Z3 / 1997 1.9L Z3 / 1999 540it

1997 318ti Sport - "Huera" - RIP
1995 318ti Active - RIP
1995 318ti Sport - "Tiny" Sold
1994 325i Sedan - "Jade" - Sold
1991 318ic - "Bert" - Sold
1985 635csi sold
1984 533i "Max" Sold
1984 318i sold

BMWCCA #160411

SUPPORT 318ti.org! CLICK THE LINK ABOVE!
Hosting a forum like this is not free. 318ti.org is one of the best BMW forums on the web because it is member supported, not vendor supported. The cost to become a Supporter is a nominal $10.00... A YEAR! DO IT! NOW!
BlackBMWs is offline   Reply With Quote
Old 04-10-2014, 11:17 PM   #4
xxxJohnBoyxxx
Senior Member
 
Join Date: Dec 2007
Location: Gulfport, Florida
Posts: 3,208
iTrader: (1)
Default

If you want to delete the SAP and get no CEL error (Even passes Emission testing) build and install the SAP simulator in the knowledge base. The SAP simulator emulates the secondary air pump test completed by the DME then when the DME shuts off the SAP the emulator turns off which is a pass through mode.

SAP on the emulator removes actual O2 voltage and sends a 200mv voltage fooling the DME into thinking the SAP is working correctly.

With the SAP simulator I've not had a sap error in many years
xxxJohnBoyxxx is offline   Reply With Quote
Old 04-10-2014, 11:20 PM   #5
30yrMbr
Senior Member
 
30yrMbr's Avatar
 
Join Date: Feb 2005
Location: Laguna Beach
Posts: 357
Vehicles
iTrader: (3)
Default

Quote:
Originally Posted by xxxJohnBoyxxx View Post
If you want to delete the SAP and get no CEL error (Even passes Emission testing) build and install the SAP simulator in the knowledge base. The SAP simulator emulates the secondary air pump test completed by the DME then when the DME shuts off the SAP the emulator turns off which is a pass through mode.

SAP on the emulator removes actual O2 voltage and sends a 200mv voltage fooling the DME into thinking the SAP is working correctly.

With the SAP simulator I've not had a sap error in many years

I'm afraid that would not pass visual smog inspection in California. Good idea tho'
__________________
1996 ///M 318ti
Alaska Blue, M-Technic, Chip, Stromung catback, 17" BMW Ltw Wheels, B&M SSK, H&R Springs/Bilsteins, StopTech Brake Lines;

http://www.318ti.org/gallery/data/54...27_clipped.jpg
30yrMbr is offline   Reply With Quote
Old 04-11-2014, 05:54 PM   #6
xxxJohnBoyxxx
Senior Member
 
Join Date: Dec 2007
Location: Gulfport, Florida
Posts: 3,208
iTrader: (1)
Default

Quote:
Originally Posted by 30yrMbr View Post
I'm afraid that would not pass visual smog inspection in California. Good idea tho'
Pump on car simulator hidden in cabin behind radio I would bet 99.9% no one would catch it. However doing it right and fixing it original is the best way most of the time. Plus you are not a track or race car so I don't recommend disabling emission parts. BEst of luck, John S
xxxJohnBoyxxx is offline   Reply With Quote
Old 04-11-2014, 05:59 PM   #7
BlackBMWs
Senior Member
 
BlackBMWs's Avatar
 
Join Date: Feb 2012
Location: Sacramento, CA
Posts: 2,451
Vehicles
iTrader: (7)
Default

The fix at this point seems to be holding up after 150 miles as there has been no reemergence of the code. This weekend, I'll work the other code a P0455 so I can get on with SMOG certification.

I'm thinking I'll get under the car to inspect all rubber hoses. I will replace some new silicone hoses I put in when I swapped motors. If the hoses are intact, I may have to being it in as I don't know how to test the purge or vent valves.
__________________


1998 318ti Sport - "Cali" Schwartz II/Schwartz sport interior, Cali top
1998 318ti Sport - "Max" Schwartz II/Schwartz sport interior, S52
1997 318ti Sport - "Tiny" Schwartz II/Schwartz sport interior
1995 318ti Active - "Blanca" Alpineweib III/Schwartz leather interior

Other Current Bimmers: 2006 530i / 2000 2.3L Z3 / 1997 1.9L Z3 / 1999 540it

1997 318ti Sport - "Huera" - RIP
1995 318ti Active - RIP
1995 318ti Sport - "Tiny" Sold
1994 325i Sedan - "Jade" - Sold
1991 318ic - "Bert" - Sold
1985 635csi sold
1984 533i "Max" Sold
1984 318i sold

BMWCCA #160411

SUPPORT 318ti.org! CLICK THE LINK ABOVE!
Hosting a forum like this is not free. 318ti.org is one of the best BMW forums on the web because it is member supported, not vendor supported. The cost to become a Supporter is a nominal $10.00... A YEAR! DO IT! NOW!
BlackBMWs is offline   Reply With Quote
Reply

Bookmarks

Tags
air pump , p1243 , smog


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Secondary air pump code troubleshooting - valve, pump or both failing? bond007 Engine 7 04-29-2012 03:34 AM
Error Code List - Stomp Test OBD1 biorjin Engine 28 02-08-2011 02:21 AM
Quick Secondary Air Pump Question Recon427 Engine 1 02-18-2010 04:19 PM
SAP (Secondary Air Pump) Repairs cali-ti Knowledge Base 5 01-23-2010 11:10 PM
error code list biorjin Exhausts 0 10-10-2005 02:55 AM


All times are GMT +1. The time now is 10:52 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2024, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 112.17 k/128.46 k (12.68%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.