318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Electrical

Notices

Electrical All wiring questions.

.
» Recent Threads
WTB: Drivers Side...
02-10-2020 07:39 PM
Last post by joe1602
Today 06:42 PM
1 Replies, 994 Views
318ti parts
06-09-2020 12:00 AM
Last post by joe1602
Today 06:39 PM
6 Replies, 1,212 Views
TPS and ICV signals on...
07-01-2020 07:06 PM
Last post by paul somlo
07-07-2020 05:43 PM
6 Replies, 814 Views
Ultimate Supercharger...
06-23-2019 08:06 AM
Last post by Z3nki
07-07-2020 02:54 PM
117 Replies, 114,607 Views
_-_Door Panel/Cards...
09-24-2011 03:17 PM
Last post by BMW_Hatchback
07-05-2020 10:48 PM
103 Replies, 22,034 Views
free door card (+...
03-27-2020 01:07 AM
Last post by sortasorted
07-03-2020 06:05 PM
7 Replies, 2,000 Views
M44 Lower Timing Chain...
05-25-2020 05:17 AM
Last post by 96318ticali
07-02-2020 09:44 PM
4 Replies, 982 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 05-22-2020, 03:32 AM   #1
chevale
Member
 
Join Date: Jul 2015
Location: Toronto, ON, Canada
Posts: 32
Vehicles
iTrader: (0)
Default Instrument cluster: no tach, speedo, temp and gas gauges

Hi all:
I've tried to replace bulbs in the headlights and fog light pull buttons and for this, I've pulled instrument cluster bezel and instrument cluster.
After I've re-assembled everything back (was not able to change those bulbs, btw) there is no tacho, speedo, gas and temp gauges working.
I found that fuse 23 was blown. After replacing and starting the car it was blown again.
Any pointers?
Thanks!
__________________
Stuff for sale.
chevale is offline   Reply With Quote
Old 05-23-2020, 12:49 AM   #2
1996 328ti
Senior Member
 
1996 328ti's Avatar
 
Join Date: Jun 2003
Location: Greenville, SC
Posts: 9,342
Vehicles
iTrader: (1)
Default

Pinched wire? Broken pin? I found those connectors becoming very brittle.
__________________
...steven
BMW CCA #146825
1995 BMW 318ti Club Sport 1996 BMW 328ti 2003 MINI Cooper S
www.bmwcca.org
1996 328ti is offline   Reply With Quote
Old 05-29-2020, 12:26 AM   #3
J!m
Moderator
 
J!m's Avatar
 
Join Date: Jun 2003
Location: Bouncing off the rev limiter in CT!
Posts: 2,994
Vehicles
iTrader: (1)
Default

Yes probably not fully seated.

And I’ve changed those bulbs twice so far (another is out now) and it is accessed by removing only the cluster.
__________________
"Speed's just a question of money. How fast you 'wanna go?"

Order Swap Manuals Here => http://www.318ti.org/forum/showthread.php?t=12912

WolferJ- gone but not forgotten. R.I.P.
J!m is offline   Reply With Quote
Old 05-29-2020, 12:40 AM   #4
chevale
Member
 
Join Date: Jul 2015
Location: Toronto, ON, Canada
Posts: 32
Vehicles
iTrader: (0)
Default

Thanks for the replies. I drove about 5 km without the cluster, then plugged it in and it started to work!
I am a bit nervous as I didn't found what the problem was, but as long as it works, I am good.
__________________
Stuff for sale.
chevale is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gas gauge and temp gauge going crazy buildabear Electrical 16 05-12-2017 01:45 PM
I have a fuse problem. Gas and the Temp. Will'sBimmer Electrical 11 11-02-2009 04:15 AM
Turn signal, gas, temp, rpm gauge not working deci Electrical 11 09-28-2007 02:07 AM


All times are GMT +1. The time now is 10:29 PM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2020, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 76.50 k/89.02 k (14.07%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.