318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Brakes

Notices

Brakes From what pads to use to brake upgrades.

.
» Recent Threads
Injector...
02-19-2019 11:23 PM
Last post by spidertri
Yesterday 08:57 PM
5 Replies, 435 Views
TI part?
Yesterday 05:26 AM
Last post by FunElan
Yesterday 05:37 PM
1 Replies, 186 Views
Dash lights on strike
01-18-2008 04:24 PM
Last post by pilsberry
02-20-2019 09:55 PM
38 Replies, 6,885 Views
Window coming off track
01-27-2003 04:51 PM
Last post by FunElan
02-20-2019 06:11 PM
216 Replies, 81,049 Views
What intake for S54...
02-20-2019 09:29 AM
Last post by Simas323
02-20-2019 09:29 AM
0 Replies, 185 Views
Happy Birthday barische
02-20-2019 06:00 AM
Last post by 1996 328ti
02-20-2019 06:00 AM
0 Replies, 153 Views
OEM roof spoiler
06-14-2018 01:19 AM
Last post by sortasorted
02-19-2019 06:27 PM
16 Replies, 4,236 Views
Swap Manual Q&A
01-09-2007 04:32 AM
Last post by Dphu
02-16-2019 05:21 PM
195 Replies, 55,514 Views
new engine build. dasc +...
01-02-2016 02:28 AM
Last post by Jean H.318TI
02-16-2019 05:55 AM
190 Replies, 94,689 Views
throttle bodies on the...
01-19-2019 12:20 AM
Last post by jerseytim
02-15-2019 11:13 PM
2 Replies, 605 Views
  Share/Bookmark
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-31-2009, 12:11 AM   #1
xunearthhxcx
Member
 
Join Date: Jul 2009
Location: Arizona
Posts: 69
iTrader: (0)
Default ABS light... Location of Control Unit?

I recently went through and put new OEM quality pads and rotors on all 4 wheels because I had both the ABS and the Pad wear lights... I still have the pad wear light, and also the ABS light.. While changing the brakes, I cleaned all the sensors with electric parts cleaner . This didnt make a difference...

What im wondering now is regarding the abs.. Where is the control unit located? Is it wise to unplug it, clean it, and plug it back in in hopes that it works and clears the light? Or should I get new sensors and just hope that does the trick?

I know the control unit is expensive, but ive found a few for less than 100.00 used.. would it be wise to get new sensors anyways, and if that doesnt work then to look to change the control unit?

also with the pad wear light still on, I did not bleed the brakes. Could this possibly solve the pad wear light issue?

thank you for any information !

Im learning more about these cars everyday, slowly starting to get my Clubsport back to perfect stock form.

Anthony
xunearthhxcx is offline   Reply With Quote
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB: ABS control unit for 95 ti 95gizmo US and North America 1 04-06-2009 04:50 AM
m44 injectors/Cruise Control Unit Viper3812 eBay and Craig's list listings 0 09-04-2008 06:01 AM
How to remove the air conditioning control unit Marv17 Interior and ICE 4 10-13-2007 09:12 PM
Cruise Control actuator and control unit mohaughn US and North America 8 02-22-2007 03:13 AM
EWS II CONTROL UNIT 318ti Coupe Misc 1 01-24-2006 07:53 AM


All times are GMT +1. The time now is 11:38 PM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2019, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 145.84 k/155.53 k (6.23%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.