318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Misc

Notices

Misc Does not fit in any of the forums below.

.
» Recent Threads
Feeler: 98 318Ti Black M...
09-09-2017 04:57 AM
Last post by GregGT
Yesterday 11:38 PM
24 Replies, 4,658 Views
aqua cali in Tampa Fl
Yesterday 02:21 AM
Last post by aqua cali
Yesterday 10:19 PM
3 Replies, 204 Views
FS: 1995 BMW 318ti Only...
11-28-2017 06:16 PM
Last post by manydubs
Yesterday 09:39 PM
4 Replies, 731 Views
96 318ti Chico, CA
Yesterday 02:35 AM
Last post by manydubs
Yesterday 09:38 PM
2 Replies, 269 Views
Question: ti m52 swap...
12-08-2017 03:49 AM
Last post by Strawman
Yesterday 07:28 PM
8 Replies, 827 Views
M52/ZF into '96 318ti...
07-28-2013 07:49 PM
Last post by apexspeedtech
Yesterday 06:45 PM
64 Replies, 24,206 Views
Happy Birthday graymae
12-14-2017 06:01 AM
Last post by graymae
Yesterday 10:20 AM
1 Replies, 236 Views
San Jose CA 318ti Owner...
11-30-2017 02:15 AM
Last post by cocofunk
Yesterday 06:39 AM
12 Replies, 1,198 Views
Derek's Sluggish and...
03-19-2015 10:32 PM
Last post by DerekNH
Yesterday 05:51 AM
49 Replies, 9,114 Views
The 318ti OBD-II engine...
10-19-2006 07:48 PM
Last post by Beam318i
Yesterday 05:23 AM
98 Replies, 51,541 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 06-21-2010, 06:44 AM   #1
34s2104
Junior Member
 
Join Date: May 2010
Location: usa
Posts: 14
iTrader: (0)
Exclamation First time BMW user has questions :)

i bought a maroon 1996 318ti

it has some problems and i need your help.

first i sit in the car i realised that the steering wheel seems like looking left and i asked some of my friends and they said all bmws steering wheels are same they r not straight

is it right ?

when i started to drive i heard a noise coming from steering wheel like sequek and i read about that in this forum but when i shake it up and down it has a space not a big space but it has.

is it same for all ???

before me i think the car stayed somewhere for a while because brakes were rusty and the indicator light for brakes was on. so i did a good brake job . but the indicator light is on yet. should i get it reset or should it has gone after the brake job ?

friends who have experience about this issue, i am waiting for your advices.

i tried my car 6 times after refuelling and it shows 21.6 mpg . is it normal milage for these cars for city usage. my car also shows po420 code and i checked that the owner before me used an universal oxygen sensor (after cat) and this effects my milage i think i ll change both oxygen sensors on the car.

do you guys have any advices on this ?


ofcourse i have more questions but now i need these answers immediately please.


sorry for my bad english
34s2104 is offline   Reply With Quote
Old 06-21-2010, 04:01 PM   #2
ti-billy
Senior Member
 
ti-billy's Avatar
 
Join Date: Mar 2010
Location: Tulsa, OK
Posts: 250
iTrader: (0)
Default

first off welcome to the forum
brakes - when u did your brakes did you replace your brake sensors? you have 2, one on the left front caliper and one on the right rear caliper, don't worry about rusty rotors mine get rusty over night but we have a lot of humidity in OK, the rust will be gone after the first couple of times you brake
steering - is it a tilt column?
fuel milage - i seam to be getting around 24 to 26 mpg in town, but i need new plugs
hope this helps start the healing process for your car
__________________
1996 318ti base: m44, 5 spd, lsd - 18x8 bremmer kraft wheels w/sumitumo tires 225/40R18 & bmw locking lug studs, 10mm spacers in rear, halo headlights, cold air intake, koni str.t struts and shocks w/mounts, h&r sport springs, serp belts, control arm & tie rod kits, front sway bar links, JVC kd-x50bt headunit w/ipod hook up in the glove box, alpine sps-500(front and rear), jl audio 10" powerwedge max, jl audio 250.1 amp, motor mounts, fuel filter, passenger side window motor, drivers lower window run, muffler hanger kit, various interior bulbs, left door striker/ajar switch, lower hood latches, changed from gray vinal to black leather shift and parking brake boots, m3 weighted shift knob, ngk-r spark plugs, magnecor spark plug wires(blue),new cabin micro-filters,new headliner & a-pillar mouldings, 5w20 synth-blend oil and filter, BG Ultra Guard syn. rear end fluid & ls additive, BG Syncro Shift II syn. manual trans fluids, stainless steel braided brake lines and dot 4 fluid, extra brake light mod, new p/s reservoir and rubber hoses

need to do - fix door panels, paint job, MORE MONEY!!
ti-billy is offline   Reply With Quote
Old 06-22-2010, 04:49 AM   #3
34s2104
Junior Member
 
Join Date: May 2010
Location: usa
Posts: 14
iTrader: (0)
Default

my fault i couldnt explain enough i changed the front brake rotors and pads and for the rear just the pads.
i mean i checked the two sensors they seemed good to me

incase , i want to check again

if i take them off from the pads and isolate them with tape the light has to turn off, right??? or is there any other proper way to check it.
34s2104 is offline   Reply With Quote
Old 06-22-2010, 06:24 PM   #4
ti-billy
Senior Member
 
ti-billy's Avatar
 
Join Date: Mar 2010
Location: Tulsa, OK
Posts: 250
iTrader: (0)
Default

my brake light came on about 3 weeks ago and the rear brakes had just been done about a month before that, upon inspection i found the right rear pad sensor was laying on the top of the cv axle and had been rubbed though so i repaired the wire and rerouted it and all good now, maybe someone else has some ideas?
__________________
1996 318ti base: m44, 5 spd, lsd - 18x8 bremmer kraft wheels w/sumitumo tires 225/40R18 & bmw locking lug studs, 10mm spacers in rear, halo headlights, cold air intake, koni str.t struts and shocks w/mounts, h&r sport springs, serp belts, control arm & tie rod kits, front sway bar links, JVC kd-x50bt headunit w/ipod hook up in the glove box, alpine sps-500(front and rear), jl audio 10" powerwedge max, jl audio 250.1 amp, motor mounts, fuel filter, passenger side window motor, drivers lower window run, muffler hanger kit, various interior bulbs, left door striker/ajar switch, lower hood latches, changed from gray vinal to black leather shift and parking brake boots, m3 weighted shift knob, ngk-r spark plugs, magnecor spark plug wires(blue),new cabin micro-filters,new headliner & a-pillar mouldings, 5w20 synth-blend oil and filter, BG Ultra Guard syn. rear end fluid & ls additive, BG Syncro Shift II syn. manual trans fluids, stainless steel braided brake lines and dot 4 fluid, extra brake light mod, new p/s reservoir and rubber hoses

need to do - fix door panels, paint job, MORE MONEY!!
ti-billy is offline   Reply With Quote
Old 06-22-2010, 10:13 PM   #5
spidertri
Senior Member
 
spidertri's Avatar
 
Join Date: Apr 2007
Location: Elizabeth City, NC
Posts: 3,807
Vehicles
iTrader: (9)
Default

If the indicator light for the brakes was on that means that the brake pad sensor was destroyed. When the pads get low, the sensor is exposed and ground down as part of the pad. This is how the car knows to turn on the brake wear indicator. There are only two sensors, you can check them to see which one is worn or just replace both of them, that should turn off the indicator light.

The steering wheel should be straight.

Change the O2 sensor and your mpg should improve.
__________________
~Dave~

98 328ti Morea Grun slicktop
02 Z3 Coupe Topas Blau slicktop

Search | RealOEM
spidertri is offline   Reply With Quote
Reply

Bookmarks

Tags
brakes , mileage , oxygen sensor , steering wheel


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New User netfatih Lounge 14 10-01-2008 03:20 AM
New user saying hi! Manimillion Lounge 14 03-14-2008 03:23 PM
new user from Italy... Prada Exterior 14 03-28-2005 07:17 PM
First time questions forbz I'm thinking about buying a ti. 3 01-11-2005 07:43 PM


All times are GMT +1. The time now is 02:33 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2017, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 85.79 k/99.48 k (13.77%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.