318ti.org forum

Go Back   318ti.org forum > Garage > Personal bios and Introductions

Notices

Personal bios and Introductions A short personal history.

.
» Recent Threads
Coil on PLug Conversion...
01-04-2020 11:26 PM
Last post by J!m
Yesterday 12:43 PM
4 Replies, 930 Views
Snow Tires/Rims
01-10-2020 08:46 PM
Last post by J!m
Yesterday 02:19 AM
3 Replies, 560 Views
Happy Birthday ...
01-12-2020 06:00 AM
Last post by J!m
Yesterday 02:12 AM
1 Replies, 382 Views
WTB: manual driveshaft
11-13-2019 12:04 AM
Last post by J!m
Yesterday 02:12 AM
2 Replies, 970 Views
S52 ti - Question about...
08-09-2019 02:13 AM
Last post by J!m
Yesterday 02:09 AM
2 Replies, 12,962 Views
1998 328ti 5spd
01-05-2020 02:32 AM
Last post by J!m
Yesterday 02:04 AM
8 Replies, 1,677 Views
Longtime Listener. First...
01-16-2020 01:37 PM
Last post by J!m
Yesterday 02:01 AM
2 Replies, 287 Views
5 spd, tree crushed it
12-02-2019 07:16 PM
Last post by jay7602
01-16-2020 03:58 AM
7 Replies, 2,011 Views
Lightweight Flywheel and...
01-15-2020 07:30 AM
Last post by gkatzens
01-15-2020 07:30 AM
0 Replies, 222 Views
Ultimate Supercharger...
06-23-2019 09:06 AM
Last post by OllieNZ
01-14-2020 07:04 PM
104 Replies, 71,751 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 11-05-2019, 02:59 PM   #1
ricardoflynn
Junior Member
 
Join Date: Nov 2019
Location: UK
Posts: 1
iTrader: (0)
Default New member from the UK

I have an automatic 318ti which I bought back in June, after lurking around forums for a while. Has a surprising amount of extras for a '97 model, have been really happy with it, but it now has a rough idle/stalling issue. Would appreciate if anyone has any suggestions before I take it to a garage. Would like to avoid spending a fortune trying lots of different things to diagnose the problem! I wrote more info in the video description. Thanks for reading!

https://youtu.be/UMim5HbVdt4
ricardoflynn is offline   Reply With Quote
Old 11-05-2019, 09:54 PM   #2
thenjnick
Junior Member
 
Join Date: Aug 2018
Location: Beachwood
Posts: 28
iTrader: (0)
Default

Sounds like its really struggling to get started, is that a new problem?

How about the vacuum system? Have you gone around and checked hoses and/or sprayed around with some carb cleaner or anything?

Any loss in power other than the dropping RPMs? A compression test could be in order if you have the tool, its very cheap and a good one to have for any car.


Sent from my iPhone using Tapatalk
thenjnick is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
NEW 318ti member and website member jempsmaramba Wheel Cleaners 8 06-29-2012 05:08 AM
Cracked rear cross member tire warmer Suspension 5 09-18-2010 02:09 PM
Bad Post-Sale Experience with Org Member... what can I do? SNOWti US and North America 68 01-17-2010 02:43 PM
FS: Headlights, Front core support, Front cross member, Differential, Bumper Cover zboot US and North America 6 12-16-2007 08:45 AM
Member 3000 1996 328ti Announcements 11 01-27-2007 08:45 AM


All times are GMT +1. The time now is 05:21 PM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2020, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 67.07 k/77.37 k (13.31%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.