318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Electrical

Notices

Electrical All wiring questions.

.
» Recent Threads
DME relay plug (socket)...
07-17-2015 11:07 PM
Last post by ilokano
Today 06:13 AM
24 Replies, 1,538 Views
Happy Birthday 318ti
Today 05:00 AM
Last post by 1996 328ti
Today 05:00 AM
0 Replies, 23 Views
Testing dual radiator...
08-05-2011 02:49 AM
Last post by chevale
Today 04:08 AM
41 Replies, 18,656 Views
OK, now how do I change...
Yesterday 12:41 AM
Last post by roadrash
Today 01:03 AM
5 Replies, 242 Views
My 332ti running with...
07-26-2015 07:17 PM
Last post by M-technik-3
Yesterday 01:04 PM
2 Replies, 312 Views
Wisco Touring...
07-31-2012 03:09 PM
Last post by Earl
Yesterday 11:06 AM
815 Replies, 100,819 Views
How does one remove the...
07-26-2015 04:52 PM
Last post by Dinoti
07-26-2015 11:50 PM
1 Replies, 214 Views
Radiator Electric Fan...
04-14-2014 12:39 AM
Last post by chevale
07-26-2015 09:15 PM
4 Replies, 2,885 Views
1998 5speed Alpine White...
07-26-2015 07:37 PM
Last post by David19
07-26-2015 07:37 PM
0 Replies, 207 Views
Help!! Crank But no...
03-17-2015 06:11 AM
Last post by ilokano
07-26-2015 02:31 PM
6 Replies, 942 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 12-24-2010, 03:21 AM   #1
kelly88
Junior Member
 
Join Date: Dec 2010
Location: brisbane
Posts: 1
iTrader: (0)
Default 1994 318i fuel and temp gauge not working

hi,

i have a 1994 318i, i recently noticed my fuel, temp gauge and also my warning lights was not working however everthing else is working, so i replaced the fuses, then it started working for all of about 4 minutes, then it blew again. Any idea what this could be and/or how to fix it.

Much appreicated
thanks
kelly88 is offline   Reply With Quote
Old 12-24-2010, 01:00 PM   #2
BMW_Hatchback
Moderator
 
BMW_Hatchback's Avatar
 
Join Date: Mar 2007
Location: Maryland
Posts: 3,046
iTrader: (1)
Default

sounds like you caught a short along the way, check your relays while you're at it
__________________
BMW_Hatchback is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel Gauge, Temp Gauge, and clock...oh my! kwayocu Electrical 14 09-11-2014 03:56 AM
Fuel Gauge and the Engine heat not working! drkblu318ti Electrical 2 08-07-2012 02:37 PM
are 1994 318i turboed? central09 Misc 4 08-09-2008 06:44 PM
Turn signal, gas, temp, rpm gauge not working deci Electrical 11 09-28-2007 02:07 AM
fuel gauge not working TORJTHM Electrical 5 06-29-2006 03:44 AM


All times are GMT +1. The time now is 07:06 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2015, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 67.52 k/77.91 k (13.33%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.