318ti.org forum (http://www.318ti.org/forum/index.php)
-   Engine Swaps (http://www.318ti.org/forum/forumdisplay.php?f=26)
-   -   S52 swap EVAP question (http://www.318ti.org/forum/showthread.php?t=44741)

ilillund83 10-20-2019 01:25 AM

S52 swap EVAP question
 
Hi guys, I have a 98 ti that I recently swapped a 98 s52 into with the help of J!ms guide and lots of good info here on the site. Anyhow, everything is up and running great but I am having an issue with my readiness monitors specifically EVAP and SAP. Also I am getting code p1403- Charcol Filter Shutoff Valve. I am looking for any input I can get, I assumed that both cars used the same charcoal can located near the gas tank and hooked the purge valve coming from the intake to the blue line running to the rear of the car. Is this correct or did the ti use one of the older round cans? Do I need to dig up an s52 canister? BTW I know that I can have the dme flash these out but would really rather get things hooked up correctly if possible. I plan on taking this to the smog ref to get my swap sticker and dont want to worry about having a flashed dme throw a red flag. -Thanks all, Ian

ilillund83 10-20-2019 10:10 PM

I found this on real oem,
https://www.realoem.com/bmw/enUS/sho...diagId=16_1034

I see that 97 was the cutoff but cant find any info on 98+ ti's. Do they share the same e36 sedan/coupe Charcoal filter/valve (the plastic box) near the fuel tank? I have been under looking for it and looked for access in the rear hatch floor but I dont see anything.

If anyone knows or has any knowledge relating to the charcoal filter on 98+ ti's or code p1403 on s52 engines that they could share I would really appreciate it. Thx all

BRADESTAR 10-21-2019 01:06 AM

I think your set up is correct. Do you know that the Ti wasn't throwing this code before the swap? Maybe a line is clogged, or something like that.

ilillund83 10-21-2019 05:26 AM

Yeah to my knowledge everything was good with the smog equipment prior to swap. Never a CEL or anything. I did some more digging around and found that yes indeed the later TI's have the plastic box style charcoal filter shared with other e36s it was located on the driver's side rear seat side panel behind another access panel. I had seen the suggestion to blow air through each of the disconnected lines and filter on the m3forum so I went ahead and gave it a try. No codes thus far, going to give it a few cycles and hope it readies up. I will report back as soon as I know if all's well.

ilillund83 10-23-2019 10:14 PM

After 3 days of light driving my CEL light is back on with P1403 and my readiness monitors for SAP and EVAP are still not set. I swapped breather valves with the donor car, used compressed air to blow out the lines and checked all connections. Any ideas?

I am almost to the last resort of having my DME reprogrammed to delete EVAP/SAP and set to ready. Does anyone have any experience with this and passing with a CA smog ref?

Thanks all, Ian

ilillund83 10-29-2019 11:02 PM

Thank you to Trusted-1 on this forum, this issue is finally solved. P1403 was cleared and ecu readiness has set. Can be solved by double checking the pinout's on the harness's as indicated on the last post of this thread http://www.318ti.org/forum/showthread.php?t=42041 .


All times are GMT +1. The time now is 09:58 PM.

vBulletin Version 3.8.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2021, 318ti.org