318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Electrical

Notices

Electrical All wiring questions.

.
» Recent Threads
advise for selling my...
09-25-2022 05:29 PM
Last post by Greg_328ti
09-25-2022 05:29 PM
0 Replies, 269 Views
Glowing foot wells
05-12-2009 10:27 PM
Last post by runnr548
09-25-2022 05:45 AM
20 Replies, 3,867 Views
WTB 1998 CALI TOP
09-24-2022 12:29 PM
Last post by pvansickler
09-24-2022 12:29 PM
0 Replies, 246 Views
S52 Cams w/ M52 Valve...
07-26-2018 07:17 PM
Last post by StoneWheelRacing
09-23-2022 01:44 AM
3 Replies, 5,374 Views
names for your TI
10-08-2004 03:48 AM
Last post by StoneWheelRacing
09-23-2022 01:17 AM
353 Replies, 133,902 Views
WTB: Spare Tire and...
09-19-2022 02:59 AM
Last post by Beam318i
09-19-2022 02:59 AM
0 Replies, 921 Views
Connecting up a remote...
09-14-2022 04:06 AM
Last post by Hank
09-18-2022 02:13 PM
2 Replies, 1,302 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 08-27-2008, 04:07 PM   #31
greenmeanie
Member
 
Join Date: Oct 2007
Location: Devon U.K.
Posts: 34
iTrader: (0)
Default

90% of the time the problem is the connector under the seat, it either gets kicked or the contact areas need a clean.You can reposition the cable if you have a good look at it, just note how far the seat moves from end to end. The dealers must be making a fortune from this poor design.
Good job the rest of the car is far better!!!!
greenmeanie is offline   Reply With Quote
Old 09-05-2009, 12:57 AM   #32
318tian
Senior Member
 
Join Date: Aug 2007
Location: louisiana
Posts: 188
iTrader: (0)
Default

just take out the cluster and pull the srs bulb out if it keeps you from getting an inspection sticker. you take off the headlight switch cover and fog log cover and unscrew the four torx head screws holding in it then just wiggle out the cluster and take the bulb out.
318tian is offline   Reply With Quote
Old 09-05-2009, 01:20 AM   #33
tiFreak
Senior Member
 
Join Date: Sep 2007
Location: asdfasdf
Posts: 10,002
Vehicles
iTrader: (8)
Default

it would be nice if it was that simple, unless it's some crappy place where everyone half-asses everything they'll figure it out
tiFreak is offline   Reply With Quote
Old 11-11-2009, 05:50 PM   #34
L84THSKY
Senior Member
 
L84THSKY's Avatar
 
Join Date: Sep 2004
Location: Manassas, VA
Posts: 4,129
iTrader: (0)
Default If I may piggy back on this thread

Went to Brooklyn Monday night to see a concert. On the way back, I hit a bump/pothole that really slammed my car. The SRS light came on, and stayed on. I have the Peake reset tool and reset it, but it came right back.

What could have happened to mess up the SRS system? I will try to reset again, and remove and reinstall the fuse.
__________________

1998 (July) 318ti, 5-spd
OEM Armrest • Blaupunkt Heidelberg CD50 CD Player/Compact Drive MP3 Player • Diamond Audio 5.25" rear speakers • Navman ICN 530 GPS • BMWALARM.COM (with comfort settings) after market alarm system • Magnecor 8.5mm wires • M-Z3 Shifter/Momo Knob • Burlwood Dashboard • Stromung Exhaust • X-brace • Racing Dynamics Front Strut Bar • Carbonio C.A.I. • 17" Rial Rims • Vader Seats/Heated/Lumbar Support • M-tech Steering Wheel/Front Sway Bar/Front & Rear Bumper • Depos/w 6500K Angel Eyes/6000K HIDs • Clear Corners • M3 Mirrors • UUC Light Weight Flywheel/M5 Clutch/M3 Clutch Slave • E28 3.46 LSD/Mcoupe Cover/E30 Flanges & Halfshafts • UUC S.S. Brake/Clutch Lines • Hartge Roof Spoiler • BavAuto Springs• Bilstein Sport Struts/Shocks • E46 M3 Rear Shock Mounts • SPC Front Camber Kit • Reiger Hatch Spoiler • BavAuto Rear Camber Kit • Dinan Stage II Software • Turner Rear Sway Bar Reinforcements • BMW E46 Auto dimming mirror with Clown Nose alarm • Engine Compartment Light • Heated Wiper Fluid Retrofit • OEM Fire Extinguisher • Da'lan Trailer Hitch • Rear Sun Shade • OEM Fog Light Retrofit • H & R MZ3 Rear Sway Bar/ UUC Adjustable End Links • Cruise Control Retrofit • On Board Computer Retrofit • M3 twistie style side skirts • Carbon Fiber Hood
L84THSKY is offline   Reply With Quote
Old 11-12-2009, 11:06 PM   #35
tiFreak
Senior Member
 
Join Date: Sep 2007
Location: asdfasdf
Posts: 10,002
Vehicles
iTrader: (8)
Default

maybe you disconnected or severed the wire on one of the crash sensors? I'm not sure exactly where they are but it's near the front bumper
tiFreak is offline   Reply With Quote
Old 11-09-2013, 02:49 PM   #36
trusty110
Junior Member
 
Join Date: Nov 2013
Location: lovingston, va
Posts: 4
iTrader: (0)
Default

airbag light stays on; 1997 Z3; i have the reset tool . i have a 100 ohm resistor, but my black connector has four wires instead of three. any ideas which to put the resistor in??
tks
trusty110 is offline   Reply With Quote
Old 03-17-2015, 12:07 PM   #37
John Firestone
Senior Member
 
John Firestone's Avatar
 
Join Date: Nov 2004
Location: Bremerhaven, Germany
Posts: 977
iTrader: (0)
Default

Quote:
Originally Posted by trusty110 View Post
airbag light stays on; 1997 Z3.... i have a 100 ohm resistor, but my black connector has four wires instead of three. any ideas which to put the resistor in??
If it were my car, I might get a gold Siemens contact and apply the resistor at the SRS controller connector: fewer things to fail.

What fault(s) are setting the airbag light?

Last edited by John Firestone; 03-17-2015 at 12:15 PM.
John Firestone is offline   Reply With Quote
Old 12-30-2018, 09:16 PM   #38
adcurtin
Junior Member
 
Join Date: Mar 2018
Location: USA
Posts: 24
Vehicles
iTrader: (0)
Default

in my car, the airbag light comes on when I start the car, but goes off after a short while. it's reporting a passenger seat problem.

Anyone know why the light would come on every time I start the car, but then go off?

I just did a seat cushion swap, including swapping the sensor mat in the passenger seat (different shape with the extendable leg rest vs. not), and nothing has changed, the light still turns on with the car, and off after a little while.
adcurtin is offline   Reply With Quote
Old 11-05-2020, 01:46 PM   #39
AquaCali
Member
 
Join Date: Sep 2007
Location: N.W. VT
Posts: 33
iTrader: (0)
Default Airbag Light

As a result of a recent experience with the Airbag light on my wifes Z3 I thought I would post this for my fellow Ti owners since they also suffer from the known issue with wiring on the seat belt receptacle for the tension charge, I was told that it has to do with the connector between the seat belt receptacle and the body harness. BMW sells a upgraded harness which requires replacing the portion from the connector on the tension charge to the body connector and a piece that has to be replaced on the body harness, due to the upgraded harness having a moisture resistant connector between the receptacle wiring and the body harness. Because the codes I was getting indicated that the passenger seat receptacle need to be replaced and the drivers seat wiring needed the upgraded harness, I ordered 2 of the upgraded harnesses and sent both receptacles to Safety Restore https://www.safetyrestore.com/?utm_s...paign=map_logo to have them both "restored". Once the restored receptacles and upgraded harnesses were installed, I had the codes cleared and no more Airbag light.
AquaCali is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 03:20 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2022, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 91.32 k/108.58 k (15.90%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.