318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Engine

Notices

Engine Tuneups, chips, wires, spark plugs.

.
» Recent Threads
CodE: 2 ,1995 318ti...
Yesterday 06:53 AM
Last post by Biolite
Yesterday 11:30 PM
1 Replies, 142 Views
318ti Family History
03-10-2022 02:27 AM
Last post by cctm
05-24-2022 10:37 PM
5 Replies, 1,766 Views
new to me 98 318ti
05-03-2021 04:16 PM
Last post by red97ti
05-21-2022 03:12 PM
15 Replies, 5,342 Views
First BMW
05-13-2022 06:24 PM
Last post by ZEK
05-20-2022 04:35 AM
3 Replies, 781 Views
Biolite's Build
05-11-2022 02:28 AM
Last post by J!m
05-20-2022 03:08 AM
6 Replies, 1,344 Views
Danny's 318ti Thread...
05-03-2022 07:13 PM
Last post by Biolite
05-20-2022 12:09 AM
7 Replies, 763 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 09-30-2005, 11:33 PM   #1
Rhys H
Member
 
Join Date: Sep 2005
Location: Vancouver, B.C. Canada
Posts: 92
iTrader: (0)
Default i turn the key and all i hear is clicking

i went to start my car today and i had the unpleasant suprise of not hearing my engine roar to life, unforutnatley all it did was making a cliking sound. I checked the battery and it says that its charged, so i didint think that my battery was dead. I tried jumping the car anyways and nothing happened, all i heard was the clicking sound coming from around the alternator. I am assuming that because the battery is not dead and when i turn the key all the alternator seems to do is click that the alternator is dead. Any help would be appreciated
Rhys H is offline   Reply With Quote
Old 10-01-2005, 01:17 AM   #2
mischief
Senior Member
 
mischief's Avatar
 
Join Date: Jan 2004
Location: MD/VA/DC
Posts: 834
iTrader: (0)
Default

its the battery'
if the alternator is bad the car should still turn over
the watts might be good but what about the amps
im telling u the battrey
mischief is offline   Reply With Quote
Old 10-01-2005, 03:18 AM   #3
DeadpaN
Senior Member
 
DeadpaN's Avatar
 
Join Date: Apr 2005
Location: San Francisco
Posts: 308
iTrader: (0)
Default

battery. even if you're lights work & the radio & the......etc. it doesn't mean that the battery has enough juice to crank the engine. after you get a jump-start, go buy a battery.
DeadpaN is offline   Reply With Quote
Old 10-01-2005, 04:42 AM   #4
Rhys H
Member
 
Join Date: Sep 2005
Location: Vancouver, B.C. Canada
Posts: 92
iTrader: (0)
Default

I already started taking apart the alternator because i was planning on buying a new one tomorow.....which is gonna run me around 500. I trust your judgment cause u have had the car longer then me. Why did the car not start when i tried to jump it though?
Rhys H is offline   Reply With Quote
Old 10-01-2005, 06:35 AM   #5
mischief
Senior Member
 
mischief's Avatar
 
Join Date: Jan 2004
Location: MD/VA/DC
Posts: 834
iTrader: (0)
Default

if you give them the core it will cost u $300

i tell you this becouse i own 2 TI's and one dose not have the alternator
i changed the batter and everything working get but the car would not start i keeped hearing a clicking sound

when u tryed jump start in order for that to work there has to be that right amount of cca ITS not like hondas where where u can crank it tell the battery dies
mischief is offline   Reply With Quote
Old 10-01-2005, 06:37 AM   #6
mischief
Senior Member
 
mischief's Avatar
 
Join Date: Jan 2004
Location: MD/VA/DC
Posts: 834
iTrader: (0)
Default

and if you here a sound like a supercharger that mean that the alternator is going bad
mischief is offline   Reply With Quote
Old 10-01-2005, 06:33 PM   #7
Rhys H
Member
 
Join Date: Sep 2005
Location: Vancouver, B.C. Canada
Posts: 92
iTrader: (0)
Default

I have not heard a supercharger like sound so i guess thats a good thing. Are u suggesting i get a new battery or what, because by what u just said u bought a new battery and that didnt fix ur problem.
Rhys H is offline   Reply With Quote
Old 10-01-2005, 11:09 PM   #8
Rhys H
Member
 
Join Date: Sep 2005
Location: Vancouver, B.C. Canada
Posts: 92
iTrader: (0)
Default

Went and bought a new battery today.....fired up almost instantly. Thanks so much for the help guys, saved me a few hundred dollars
Rhys H is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 03:20 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2022, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 80.00 k/95.40 k (16.15%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.