318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Electrical

Notices

Electrical All wiring questions.

.
» Recent Threads
WTB: 318ti clubsport in...
05-21-2021 02:08 PM
Last post by jasminemicheal
Yesterday 11:55 AM
6 Replies, 2,395 Views
WTB: Manual 318ti
05-17-2021 09:34 PM
Last post by jasminemicheal
Yesterday 11:54 AM
3 Replies, 2,453 Views
WTB: M-Tech molding
06-25-2021 02:07 AM
Last post by jasminemicheal
Yesterday 11:54 AM
3 Replies, 3,709 Views
New
Yesterday 11:53 AM
Last post by jasminemicheal
Yesterday 11:53 AM
0 Replies, 69 Views
BMW type 32 alloy wheels...
07-22-2021 02:41 AM
Last post by old_sports_cars
07-22-2021 02:41 AM
0 Replies, 267 Views
15x6 steel wheels and...
07-22-2021 02:36 AM
Last post by old_sports_cars
07-22-2021 02:36 AM
0 Replies, 100 Views
Colorado Front Range...
07-11-2021 03:23 PM
Last post by b0m
07-20-2021 04:56 AM
9 Replies, 1,010 Views
'95 Boston Green, ALL...
06-29-2021 04:24 PM
Last post by 06MR6
07-20-2021 01:20 AM
8 Replies, 2,503 Views
WMD 456 Supercharger Kit...
07-13-2021 09:28 AM
Last post by MisterM52
07-16-2021 10:12 AM
2 Replies, 619 Views
recommendations for...
07-13-2021 04:48 AM
Last post by happysloth
07-15-2021 12:07 AM
2 Replies, 535 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 02-28-2008, 10:34 PM   #1
blndweasel
Senior Member
 
Join Date: Jan 2008
Location: San Diego
Posts: 340
iTrader: (0)
Default Aftermarket Amplifiers...

Hey folks,

I'm having a helluva time with my charging system.

I have a basic question for all of you...

1. What is the total RMS wattage of the amplifier(s) you are running in your Ti.

2. Are you running the stock Alternator?

3. How is your battery not dying all the time?

I have the 10-speaker stereo setup, and I am using the OEM amplifier, as well as an Infinity Basslink which advertises a 200 watt RMS draw. Under what I would consider "normal" conditions for a stereo (I'm not blasting it, just listening to some bass with a good kick) I consistently drain my battery.

Checked for shorts, bad grounds, etc, it's not that. Basically I think my alternator needs rebuilt. But I'm wondering how closely BMW designed the charging system according to the electrical system's average load. 80Amps isn't that big for a car alternator, and my guess is the amplifier I installed could be drawing as much as 20Amps. And it's pushing the alternator past it's capacity to charge the battery. When I disconnect my amp via the fuse, the system charges just fine.

It's like impossible to find a higher capacity alternator for the 318ti, I've looked and there's nothing in the stock casing. Since I hate paying other people to do things, I'm thinking of buying another Valeo alternator (90 or 105 A) and changing out the internals to the stock 318ti casing.

If I can avoid this with a simple alt rebuild, I'll stick with the stock unit. Thoughts? There have to be folks running bigger sound systems than me here...

the blonde weasel
blndweasel is offline   Reply With Quote
Old 02-28-2008, 11:00 PM   #2
Will'sBimmer
Senior Member
 
Will'sBimmer's Avatar
 
Join Date: May 2006
Location: Memphis, Tn
Posts: 1,299
iTrader: (0)
Default

I am running a 500 watt amp. I play the music pretty loud and with my speakers on all the time. I also sometimes play the music or watch movies while the car is off. I have the stock alternator and my battery never runs down or even seems to get low. I would just get another alternator. I believe if your alternator was working you wouldn't be having any problems.
__________________
custom dual exhaust,M3 front and rear bumper, 10.4 inch roof mount drop screen, Viper alarm system, DSII's rims, M3 Vader Seats, M3 Mirrors, Carbon Fiber CAI, Smoked Corners, Side Markers, Leatherz armrests, black grilles


225k miles and still the Ti goes on
Will'sBimmer is offline   Reply With Quote
Old 02-28-2008, 11:14 PM   #3
stormos
Senior Member
 
Join Date: May 2005
Location: England, UK
Posts: 1,288
iTrader: (0)
Default

I had a 960 watt amp driving all my ti speakers with a bosch silver battery. never caused me any issues and i had the dde rings, stereo and blowers on 24/7
__________________
1995 BMW 316i Cosmos Black
Mods: • Magnex Cat-Back Exhaust • Smoked Corner Lights + Repeators • M3 17" Wheels • De-Baffled Air Box • AC HandBrake Handle and Gear Knob • DEPO Euro Epsiloids + Predator Chronium Rings • Chrome Interior bits •IE Poly-Urethane RSFMs • Kenwood Power Series Audio • Powder Coated e36 325 Front Callipers • Sports Seats
stormos is offline   Reply With Quote
Old 02-29-2008, 01:09 AM   #4
cooljess76
NOBODY F's with the Jesus
 
cooljess76's Avatar
 
Join Date: Oct 2006
Location: Ventura California
Posts: 7,825
iTrader: (6)
Default

Have you checked your alternator's output with a multimeter? What was the voltage? Test it with the amplifier completely disconnected and then check it with the system running. You should have 13.8-14.4v going to the battery. If not, check your main engine ground behind the passenger front wheel well. It's connected to the right motor mount and the chassis. Mine had a bad connection and was arcing. I found it after replacing 3 alternators and 2 batteries. GL
__________________
4 MORE YEARS BABY!!!
cooljess76 is offline   Reply With Quote
Old 02-29-2008, 01:22 AM   #5
tiFreak
Senior Member
 
Join Date: Sep 2007
Location: asdfasdf
Posts: 10,029
Vehicles
iTrader: (8)
Default

you could get a capacitor, my friend had this one with his 1000w amp and 2 12" subs and his battery never got run down
tiFreak is offline   Reply With Quote
Old 02-29-2008, 06:08 AM   #6
blndweasel
Senior Member
 
Join Date: Jan 2008
Location: San Diego
Posts: 340
iTrader: (0)
Default

Quote:
Originally Posted by cooljess76 View Post
Have you checked your alternator's output with a multimeter? What was the voltage? Test it with the amplifier completely disconnected and then check it with the system running. You should have 13.8-14.4v going to the battery. If not, check your main engine ground behind the passenger front wheel well. It's connected to the right motor mount and the chassis. Mine had a bad connection and was arcing. I found it after replacing 3 alternators and 2 batteries. GL
Right, I read your other thread about the Alternator mysteries... I will be sure to check those grounds if I'm in there.

From the sound of it considering what other people are running, I'm going to assume it's just worn brushes on the alt. I'll just have to tear her open and check the carbon stacks.

Thanks for all the replies!

tbw
blndweasel is offline   Reply With Quote
Old 02-29-2008, 06:11 AM   #7
blndweasel
Senior Member
 
Join Date: Jan 2008
Location: San Diego
Posts: 340
iTrader: (0)
Default

Quote:
Originally Posted by tiFreak View Post
you could get a capacitor, my friend had this one with his 1000w amp and 2 12" subs and his battery never got run down
A capacitor only helps in situations where the speakers/amps are drawing so much current at once that the charging system under supplies the amplifier and it shuts down. i.e. hitting a big 20hz bass note on a 1000W amp, or something like that.

alternator sizing has more to do with averages... average draw over a period of time resulting in overall charging or discharging of the battery.

it sounds like my alternator isn't putting out what it should, so I'll go for a rebuild.
blndweasel is offline   Reply With Quote
Old 02-29-2008, 05:00 PM   #8
classicronnie
Senior Member
 
Join Date: Oct 2007
Location: Fallon Nevada
Posts: 178
iTrader: (0)
Default

weird i was just about to make a thread about this , my battery costantly dies and i only have about 500rms and i also got a 2 farad cap, how can i fix this problem
classicronnie is offline   Reply With Quote
Old 02-29-2008, 10:32 PM   #9
thesk8nmidget
Senior Member
 
thesk8nmidget's Avatar
 
Join Date: Oct 2007
Location: Eugene Oregon
Posts: 6,232
iTrader: (2)
Default

i used to run a 1200 watt amp and 2 12's constanly. never had a single problem with my battery.

i would also do it with my car not running.

i would say as well alternator or battery
__________________
-Josh
Sold-1995 318ti, Club Sport, Hellrot
Sold-1996 318ti, Active Model, Boston Green
Current- 1995 318ti, sport model, schwartz
thesk8nmidget is offline   Reply With Quote
Old 03-03-2008, 11:58 PM   #10
classicronnie
Senior Member
 
Join Date: Oct 2007
Location: Fallon Nevada
Posts: 178
iTrader: (0)
Default

which alternator should i buy?
classicronnie is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
i may have fractured my back. thesk8nmidget Lounge 121 11-05-2008 11:55 PM
To Houston...and eventually back Flametail General Chit Chat 5 06-02-2008 02:35 PM
Fitting front seats in the back lberry Interior and ICE 9 04-16-2008 05:09 PM
Back looking around AKBimmer General Chit Chat 1 11-27-2007 01:19 PM
BMW Back Windshield HUGO E. CONTRERAS Lounge 0 08-28-2004 12:54 PM


All times are GMT +1. The time now is 04:07 PM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2021, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 101.49 k/120.07 k (15.47%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.