318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Misc

Notices

Misc Does not fit in any of the forums below.

.
» Recent Threads
Partial Interior Part out
05-23-2021 09:40 PM
Last post by bronzybook
06-12-2021 04:55 AM
13 Replies, 3,058 Views
What sensor does OBD2...
06-12-2021 12:24 AM
Last post by paul somlo
06-12-2021 12:32 AM
1 Replies, 288 Views
FS: 1996 slicktop 318ti...
06-02-2021 02:35 AM
Last post by automaton
06-11-2021 03:30 AM
1 Replies, 1,570 Views
Hazard Switch wiring
06-06-2021 12:32 AM
Last post by FunElan
06-08-2021 08:47 PM
1 Replies, 1,530 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 12-07-2008, 05:07 AM   #1
Maverix
Senior Member
 
Maverix's Avatar
 
Join Date: Apr 2008
Location: Austin
Posts: 3,063
Vehicles
iTrader: (14)
Default Seat Swap = Airbag light

I just purchased leather tan seats from a active. I disconnected the batteries before swapping. After 2 hours of swapping the front to seats, I reconnect the battery and start the car up to a airbag light. The seats didn't have a problem on the previous car.

I quadruple checked all the wiring. Can I just take it to BMW and have it cleared? or is there more to this?
__________________
Come get a ti-shirt
Quote:
From the e30 M3, evolved the e36.
They were "Keepin it Real" when they introduced the 318ti ClubSport in '95 and the 318ti Sports from '96 to '99.
After that... well nothing else really matters.
~Jess
Maverix is offline   Reply With Quote
Old 12-07-2008, 05:18 AM   #2
minicoop900
Senior Member
 
minicoop900's Avatar
 
Join Date: Jan 2008
Location: New Orleans
Posts: 970
iTrader: (0)
Default

might be that the passenger seat occupancy sensors busted, its a little black box on the bottom of the passenger seat.

swap it with your old seats and try again, might want to cycle the key a few times so it can clear it.
if not, the dealer can clear it.
__________________

^being rebuilt^

until then:
daily car:
96' Blue DASC'd ti with koni coilovers
slowly progressing...
weekend car:
85 1/2' 944 Porsche
no a/c, p/s, gutted cat, loud as hell exhaust, loud as hell sound system
minicoop900 is offline   Reply With Quote
Old 12-07-2008, 05:20 AM   #3
Maverix
Senior Member
 
Maverix's Avatar
 
Join Date: Apr 2008
Location: Austin
Posts: 3,063
Vehicles
iTrader: (14)
Default

Quote:
Originally Posted by minicoop900 View Post
might be that the passenger seat occupancy sensors busted, its a little black box on the bottom of the passenger seat.

swap it with your old seats and try again, might want to cycle the key a few times so it can clear it.
if not, the dealer can clear it.
The leather seats didn't have it, so I removed it from my old seat and used it. Btw, I have a base.
__________________
Come get a ti-shirt
Quote:
From the e30 M3, evolved the e36.
They were "Keepin it Real" when they introduced the 318ti ClubSport in '95 and the 318ti Sports from '96 to '99.
After that... well nothing else really matters.
~Jess
Maverix is offline   Reply With Quote
Old 12-07-2008, 05:23 AM   #4
minicoop900
Senior Member
 
minicoop900's Avatar
 
Join Date: Jan 2008
Location: New Orleans
Posts: 970
iTrader: (0)
Default

oh ok, i have a 96 base auto and thats what was wrong with mine, swapped it out with one from a spare pair of seats we had and cleared the code with our scanner and it worked fine.

did you try cycling the key in hopes that it clears it? what works sometimes is going all the way to the position before start and back to off 5 times quickly.
__________________

^being rebuilt^

until then:
daily car:
96' Blue DASC'd ti with koni coilovers
slowly progressing...
weekend car:
85 1/2' 944 Porsche
no a/c, p/s, gutted cat, loud as hell exhaust, loud as hell sound system
minicoop900 is offline   Reply With Quote
Old 12-07-2008, 05:28 AM   #5
Maverix
Senior Member
 
Maverix's Avatar
 
Join Date: Apr 2008
Location: Austin
Posts: 3,063
Vehicles
iTrader: (14)
Default

Quote:
Originally Posted by minicoop900 View Post
oh ok, i have a 96 base auto and thats what was wrong with mine, swapped it out with one from a spare pair of seats we had and cleared the code with our scanner and it worked fine.

did you try cycling the key in hopes that it clears it? what works sometimes is going all the way to the position before start and back to off 5 times quickly.
I'll try it out right now.

Edit: No luck =\
__________________
Come get a ti-shirt
Quote:
From the e30 M3, evolved the e36.
They were "Keepin it Real" when they introduced the 318ti ClubSport in '95 and the 318ti Sports from '96 to '99.
After that... well nothing else really matters.
~Jess
Maverix is offline   Reply With Quote
Old 12-07-2008, 05:35 AM   #6
minicoop900
Senior Member
 
minicoop900's Avatar
 
Join Date: Jan 2008
Location: New Orleans
Posts: 970
iTrader: (0)
Default

hmm probably going to have to find a way to clear the light then to see whether its bad or not and if it is, replace it then clear it again.
__________________

^being rebuilt^

until then:
daily car:
96' Blue DASC'd ti with koni coilovers
slowly progressing...
weekend car:
85 1/2' 944 Porsche
no a/c, p/s, gutted cat, loud as hell exhaust, loud as hell sound system
minicoop900 is offline   Reply With Quote
Old 12-07-2008, 05:42 AM   #7
Maverix
Senior Member
 
Maverix's Avatar
 
Join Date: Apr 2008
Location: Austin
Posts: 3,063
Vehicles
iTrader: (14)
Default

Ah ok. I was thinking the same thing. Thanks for the help. I'm gonna stop by the dealership tomorrow and see what's up.

If anyone else can pinpoint the problem, then post away.
__________________
Come get a ti-shirt
Quote:
From the e30 M3, evolved the e36.
They were "Keepin it Real" when they introduced the 318ti ClubSport in '95 and the 318ti Sports from '96 to '99.
After that... well nothing else really matters.
~Jess
Maverix is offline   Reply With Quote
Old 12-07-2008, 05:42 AM   #8
minicoop900
Senior Member
 
minicoop900's Avatar
 
Join Date: Jan 2008
Location: New Orleans
Posts: 970
iTrader: (0)
Default

no problem
__________________

^being rebuilt^

until then:
daily car:
96' Blue DASC'd ti with koni coilovers
slowly progressing...
weekend car:
85 1/2' 944 Porsche
no a/c, p/s, gutted cat, loud as hell exhaust, loud as hell sound system
minicoop900 is offline   Reply With Quote
Old 12-07-2008, 05:53 AM   #9
Maverix
Senior Member
 
Maverix's Avatar
 
Join Date: Apr 2008
Location: Austin
Posts: 3,063
Vehicles
iTrader: (14)
Default

Btw, paid $50 for the perfect condition front seats. Tomorrow i'm going back and purchasing the perfect rears for another $50. What a steal!
__________________
Come get a ti-shirt
Quote:
From the e30 M3, evolved the e36.
They were "Keepin it Real" when they introduced the 318ti ClubSport in '95 and the 318ti Sports from '96 to '99.
After that... well nothing else really matters.
~Jess
Maverix is offline   Reply With Quote
Old 12-07-2008, 07:31 AM   #10
Mallard
Senior Member
 
Mallard's Avatar
 
Join Date: Nov 2006
Location: Land of the Vikings
Posts: 2,702
Vehicles
iTrader: (0)
Default

check again the plugs for the seatbelts are in properly.

Remeber never to have the ignition on when the seats are removed , as the SRS lamp will come on !

The lamp must be reset. Whether its at BMW or with at home reset tool that has this function.
__________________


Vin Number decode and Retrofit Pdfs Available Free ! Just PM
Mallard is offline   Reply With Quote
Old 12-08-2008, 06:58 PM   #11
Maverix
Senior Member
 
Maverix's Avatar
 
Join Date: Apr 2008
Location: Austin
Posts: 3,063
Vehicles
iTrader: (14)
Default

Wtf $100 just to have them "look at the problem". Is there any other way that I can reset it like the service light?
__________________
Come get a ti-shirt
Quote:
From the e30 M3, evolved the e36.
They were "Keepin it Real" when they introduced the 318ti ClubSport in '95 and the 318ti Sports from '96 to '99.
After that... well nothing else really matters.
~Jess
Maverix is offline   Reply With Quote
Old 12-08-2008, 08:48 PM   #12
adamud
Senior Member
 
adamud's Avatar
 
Join Date: Mar 2005
Location: Detroit, MI
Posts: 585
iTrader: (0)
Default

I have a 96' and I did an interior swap with a 98'. I had the light on in my car and the other car didn't but my light still stayed on. I've tried to clear it and it still stays on. If it annoys you enough just remove the bulb.

I don't know about resetting it, I tried that and it came right back on.

And also couldn't the SRS light be on because of the seat belt latch/harness not just the seat sensor? Or did I just make that up.
adamud is offline   Reply With Quote
Old 12-09-2008, 12:06 AM   #13
cooljess76
NOBODY F's with the Jesus
 
cooljess76's Avatar
 
Join Date: Oct 2006
Location: Ventura California
Posts: 7,825
iTrader: (6)
Default

Hmm, my vader swap went without a hitch. They had the older style seat belt receptacles, so I swapped the ones off of my sport seats onto them. I disconnected BOTH positive and negative cables from the battery prior to the swap and hooked them back up after everything was back together. No airbag light. It lights up for the first 4 or 5 seconds when I start the car, which is normal. Then when Bobbak installed my sport seats into his car, he had to install his older style receptacles onto them. He only disconnected the negative battery cable IIRC and sure enough, when he started the car, the airbag light came on.

note, the front seat belt receptacles are armed with an Automatic Locking Tensioner. This device retracts the recepticle about 2 inches in the event of an accident. 318ti's built up to 03/97 use a mechanical auto-locking mechanism(part#'s 72118167711 left and 72118167712 right) while models built after 03/97 use a pyrotechnic auto-locking mechanism (part#'s 72118221013 left and 72118221014 right).
__________________
4 MORE YEARS BABY!!!

Last edited by cooljess76; 07-11-2011 at 01:46 AM.
cooljess76 is offline   Reply With Quote
Old 12-09-2008, 12:23 AM   #14
Maverix
Senior Member
 
Maverix's Avatar
 
Join Date: Apr 2008
Location: Austin
Posts: 3,063
Vehicles
iTrader: (14)
Default

Son of a damnit!! I did the same thing bobbak did.

I was in a rush that I wasn't even thinking. Did he ever fix it?
__________________
Come get a ti-shirt
Quote:
From the e30 M3, evolved the e36.
They were "Keepin it Real" when they introduced the 318ti ClubSport in '95 and the 318ti Sports from '96 to '99.
After that... well nothing else really matters.
~Jess
Maverix is offline   Reply With Quote
Old 12-09-2008, 12:44 AM   #15
cooljess76
NOBODY F's with the Jesus
 
cooljess76's Avatar
 
Join Date: Oct 2006
Location: Ventura California
Posts: 7,825
iTrader: (6)
Default

Quote:
Originally Posted by Maverix View Post
Son of a damnit!! I did the same thing bobbak did.

I was in a rush that I wasn't even thinking. Did he ever fix it?
I'm pretty sure he did. You'll need to buy or borrow an SRS reset tool. Most shops will have one and will probably let you use it or charge very little if you explain what you've done to them.
__________________
4 MORE YEARS BABY!!!
cooljess76 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Passenger Seat Airbag Sensor davebird61 Australia and New Zealand 4 05-25-2008 10:01 PM
Airbag light Q. Seat belt buckle. septimus Interior and ICE 0 11-02-2006 07:13 AM
Airbag light? blackti Electrical 2 07-08-2006 11:08 PM
Airbag Light??? x177izikex Misc 1 12-08-2005 04:02 AM
Airbag front seat mat 007monkey Electrical 3 08-11-2004 11:01 PM


All times are GMT +1. The time now is 03:05 PM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2021, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 133.34 k/157.40 k (15.29%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.