318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Engine

Notices

Engine Tuneups, chips, wires, spark plugs.

.
» Recent Threads
Running rough
09-13-2021 02:37 PM
Last post by FunElan
09-25-2021 04:46 AM
2 Replies, 1,021 Views
Finally introducing...
09-23-2021 05:50 PM
Last post by FunElan
09-25-2021 04:42 AM
3 Replies, 305 Views
Long time member/lurker.....
09-24-2021 04:14 AM
Last post by b0m
09-24-2021 04:44 AM
1 Replies, 159 Views
6 1/2" speakers in stock...
04-27-2008 12:21 AM
Last post by iski123
09-24-2021 04:32 AM
28 Replies, 22,085 Views
FRONT SPEAKERS 4" to...
11-28-2005 05:03 PM
Last post by iski123
09-24-2021 04:21 AM
11 Replies, 4,997 Views
Subwoofer wiring heat...
09-24-2021 04:02 AM
Last post by iski123
09-24-2021 04:02 AM
0 Replies, 130 Views
WTB: S50/S52 swapped or...
08-29-2021 04:22 PM
Last post by hernandez706
09-23-2021 05:51 PM
7 Replies, 1,961 Views
1998 Cali Top
09-23-2021 05:39 PM
Last post by hernandez706
09-23-2021 05:39 PM
0 Replies, 155 Views
I miss C'ing Ti Pics
07-31-2021 08:08 AM
Last post by hernandez706
09-23-2021 05:37 PM
9 Replies, 3,741 Views
Black 1998 Ti
09-19-2021 07:37 PM
Last post by J!m
09-23-2021 11:05 AM
1 Replies, 414 Views
Reply Share/Bookmark
 
Thread Tools Display Modes
Old 05-05-2009, 11:37 PM   #1
Variance
Senior Member
 
Variance's Avatar
 
Join Date: Aug 2005
Location: Melbourne, Fl/Athens, AL
Posts: 393
iTrader: (0)
Default Strange blowing/vaccuum noise from M44 ti

Hey guys,
I recently got a CEL and started hearing a strange vaccuum noise from my engine bay. The engine still runs like normal, and the noise stops after sitting at idle for a couple minutes. I tracked it down to the part in the center of the following picture:



When I stick my hand next to it, I feel air blowing out the sides of the "lid", and the noise subsides when I push down on the top. I took a quick video to show this and the noise:
http://www.youtube.com/watch?v=5nkN8wYPpVY

Any ideas what the problem might be, and is it safe to drive the car in the meantime?
__________________
-Kenny
Variance is offline   Reply With Quote
Old 05-05-2009, 11:49 PM   #2
b.u.ti-ful
Senior Member
 
b.u.ti-ful's Avatar
 
Join Date: Sep 2006
Location: Wisconsin
Posts: 1,895
iTrader: (1)
Default

Secondary airpump.

cooljess76 wrote how to fix it somewhere on this site.

I seem to remember the fix was to grind off the rivets and bolt down the lid.
__________________
...

ʎɐqǝ uo pɹɐoqʎǝʞ ɐ ʎnq ı ǝɯıʇ ʇsɐן ǝɥʇ sı sıɥʇ
b.u.ti-ful is offline   Reply With Quote
Old 05-05-2009, 11:55 PM   #3
Variance
Senior Member
 
Variance's Avatar
 
Join Date: Aug 2005
Location: Melbourne, Fl/Athens, AL
Posts: 393
iTrader: (0)
Default

That seems kinda... iffy. If it's an airpump, I guess it's part of the emissions system? Does anybody know what would cause it to randomly start doing this?
__________________
-Kenny
Variance is offline   Reply With Quote
Old 05-12-2009, 08:26 PM   #4
b.u.ti-ful
Senior Member
 
b.u.ti-ful's Avatar
 
Join Date: Sep 2006
Location: Wisconsin
Posts: 1,895
iTrader: (1)
Default

Any progress?
__________________
...

ʎɐqǝ uo pɹɐoqʎǝʞ ɐ ʎnq ı ǝɯıʇ ʇsɐן ǝɥʇ sı sıɥʇ
b.u.ti-ful is offline   Reply With Quote
Old 05-12-2009, 08:39 PM   #5
cooljess76
NOBODY F's with the Jesus
 
cooljess76's Avatar
 
Join Date: Oct 2006
Location: Ventura California
Posts: 7,824
iTrader: (6)
Default

The secondary air pump is basically composed of a series of plates that are held together by 6 aluminum rivets to make up the body of the actual pump. The rivets tend to break, allowing the plates to separate and leak air. The reason that you only hear it momentairily after startup is because it only runs for about 30 seconds after the car has been started on a cold engine. You can easily fix the problem by first removing the secondary air pump, removing the broken rivets and possibly drilling out the others. Then replace them with machine screws and locknuts. This should eliminate any problems and extinguish your CEL. Depending on how long you've known the noise to be there, you may consider taking the pump apart and cleaning the internals with brake cleaner. It's not absolutely necessary, but just a suggestion. Also, while you're working in that area, you may want to replace the ribbed rubber boot between the MAF and the ASC valve as it's known to crack and give you misfire codes as well as trigger a CEL. Good Luck, sorry I came in so late.
cooljess76 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange engine noise nontien Engine 0 06-24-2008 04:46 PM
318ti M44 strange sucking noise zerouali Engine 0 09-12-2006 08:19 PM
Strange/bad noise from brakes? Viper3812 Brakes 1 06-21-2006 07:19 AM
strange rubbing noise maherbaz Misc 5 02-21-2006 04:12 AM
Strange Vibration Noise mrnine Suspension 8 02-04-2005 12:22 AM


All times are GMT +1. The time now is 10:33 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2021, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 81.95 k/95.50 k (14.19%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.