318ti.org forum

Go Back   318ti.org forum > Technical, Maintenance and Modifications > Electrical

Notices

Electrical All wiring questions.

.
» Recent Threads
I miss C'ing Ti Pics
07-31-2021 08:08 AM
Last post by b0m
08-02-2021 01:18 AM
3 Replies, 519 Views
1999 318ti w/ M-Sport &...
07-31-2021 08:49 PM
Last post by AlexWJD
07-31-2021 08:49 PM
0 Replies, 163 Views
unfinished supercharged...
06-22-2021 03:57 PM
Last post by Spartan 059
07-31-2021 01:29 PM
6 Replies, 5,836 Views
recommendations for...
07-13-2021 04:48 AM
Last post by BRADESTAR
07-31-2021 08:20 AM
3 Replies, 956 Views
'95 Boston Green, ALL...
06-29-2021 04:24 PM
Last post by irdave
07-27-2021 02:21 AM
10 Replies, 3,394 Views
New to the group
05-30-2021 05:47 AM
Last post by FunElan
07-27-2021 12:02 AM
4 Replies, 2,334 Views
What model ti do you own?
02-26-2003 03:40 AM
Last post by sarinasr75
07-26-2021 02:40 PM
340 Replies, 173,049 Views
Longtime lurker via...
07-26-2021 07:33 AM
Last post by primo107
07-26-2021 07:33 AM
0 Replies, 287 Views
Happy Birthday ...
07-26-2021 05:00 AM
Last post by 1996 328ti
07-26-2021 05:00 AM
0 Replies, 278 Views
  Share/Bookmark
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-15-2011, 11:25 PM   #1
LeadFox
Junior Member
 
LeadFox's Avatar
 
Join Date: Jan 2011
Location: walnut creek, ca
Posts: 14
Vehicles
iTrader: (0)
Exclamation Uknown power flux

I have a '95 318ti, 4cyl, 2 dr. All stock. I've been having this power issue where first my stereo will lose sound, then die all together. Then the ABS and battery light will come on, shortly after the entire dash will die. No RPMs, no MPH, no milage, natta. Even the outside temp will warn me saying it's 4F or 16F (wtf??) Then the car itself would die.So first I test the battery-bad cell=replaced battery, but still same prob. Then replace alternator (which looked and felt like it really needed it) which did seem to help or at least prolong the car from dying. So now I still have the problem of stereo dying and my ABS light coming on and temp going wacky, but my RPMs maintain now and I feel I could drive it but the longer I drive it the worse it gets, then when I stop it seems to slowly recover. Like I'll sit in the driveway after a spin and the stereo will eventually work again.
SOoo...any one got any ideas of what to do? I plugged it into an analyzer and got codes for a fuel pressure reg, fuel filter (bought but not in yet) and oxygen sensor.
LeadFox is offline   Reply With Quote
 

Bookmarks

Tags
electrical problem


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
No Power! M5Yates Engine 5 05-31-2010 11:09 PM
Best Way to run Power for amp? M-Tech TI Lounge 3 01-28-2010 01:41 AM
E46 M3 Power Seat w/Lumbar and power side bolsters Non Heated dahamler US and North America 3 01-03-2008 06:13 PM
need more power!!! shabz Engine 3 12-14-2007 11:09 PM
need more power :( turbo87 Engine 8 04-13-2007 09:06 AM


All times are GMT +1. The time now is 12:27 AM.


.
Powered by site supporters
vBulletin Version 3.8.8
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright ©1999 - 2021, 318ti.org
© vBadvanced CMPS v3.2.2
[page compression: 111.20 k/120.78 k (7.93%)]

318ti.org does not warrant or assume any legal liability or responsibility for the accuracy, completeness, or usefulness of any information or products discussed.